做了一个eclipse3.1的包已经加入源,需要者自行安装

最新ubuntu/linux/开源新闻或者其它IT相关资讯
回复
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

做了一个eclipse3.1的包已经加入源,需要者自行安装

#1

帖子 oneleaf » 2005-07-15 17:54

安装:
apt-get install eclipse

制作流程:

http://www.ubuntu.org.cn/support/documentation/doc/deb/
上次由 oneleaf 在 2005-07-15 20:25,总共编辑 1 次。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 firehare » 2005-07-15 18:21

一叶兄真是又做了件好事呀!
呵呵!顺便好好学习学习,嘻嘻!
我心无畏,源自于我心无知。
图片
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#3

帖子 yonsan » 2005-07-15 19:36

请顺便说一说如何使用apt-get命令安装!!
I will be back!
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#4

帖子 firehare » 2005-07-15 20:17

这个东东不是用apt-get安装的,因为它并不在源中,而是在本地!所以你要用dpkg -i 包名 来安装!
我心无畏,源自于我心无知。
图片
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#5

帖子 oneleaf » 2005-07-15 20:25

不是,已经加入源了。
直接使用apt-get install eclipse 安装
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#6

帖子 firehare » 2005-07-15 20:26

:D
赞一个!!
我心无畏,源自于我心无知。
图片
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#7

帖子 yonsan » 2005-07-15 21:10

建议:
先执行 apt-get update 更新一下列表.
然后才 apt-get install eclipse

如果不用apt-get update更新一下,可能会出现“无法找到eclipse“的信息!!
I will be back!
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#8

帖子 oneleaf » 2005-07-16 11:42

今天将eclipse包拆分了修改为eclipse3 主要是将ve和wtp升级了
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#9

帖子 firehare » 2005-07-16 13:22

建议一叶兄包分开来做,如下所示:
eclipse-platform
eclipse-pde
eclipse-jdt
eclipse-sdk(依赖关系设为上面3个)
eclipse-cdt
eclipse-emf
eclipse-gef
eclipse-uml2
eclipse-ve
eclipse-tools(依赖关系为上面6个)
eclipse-wst
eclipse-wtp(依赖关系类似)
eclipse-nls-sdk(与上面对应即可)
这样的话,一则可以定制,二则也不需要一次下载太大。
同时,采用links方式加载插件,这样删除也方便!
上述想法供一叶兄参考!
我心无畏,源自于我心无知。
图片
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#10

帖子 oneleaf » 2005-07-16 13:33

这样当然最好,不过太麻烦啊,我只是简单的分为:

eclipse-emf-sdo-xsd-SDK_2.1.0_i386.deb
eclipse-gef_3.1_i386.deb
eclipse-sdk_3.1_i386.deb
eclipse-uml2-SDK_1.1.0_i386.deb
eclipse-ve-SDK_1.1.0-I20050715.i386.deb
eclipse-wtp_1.0M5-I20050715.i386.deb
eclipse.cdt.sdk_2.1.1_i386.deb

我平时用的最多的就是 ve 和 wtp 嘿嘿,就为了这个升级方便才拆的,我都想并到一起去。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#11

帖子 firehare » 2005-07-16 13:44

哈哈!
那倒也是!
不过这里兄弟这么多,
一人领一个任务,算算也不要多少个人
只是一叶兄要把规范做好
否则集成不起来!
我心无畏,源自于我心无知。
图片
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#12

帖子 yonsan » 2005-07-16 18:57

呵呵!人多难管理的话倒不如自已一个人做!!
是这样吗,一叶兄!!
I will be back!
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#13

帖子 firehare » 2005-07-16 19:11

文档做好就成!
比较说Eclipse-SDK中的包放在什么目录!
附加包放在什么目录下等!
我心无畏,源自于我心无知。
图片
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#14

帖子 oneleaf » 2005-07-16 19:27

没有关系,做好deb包,直接上传到ftp://ubuntu.org.cn 的upload目录,我就加上去。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
max0000
帖子: 310
注册时间: 2005-04-08 14:54
送出感谢: 0
接收感谢: 0

#15

帖子 max0000 » 2005-07-16 20:16

源里有一个eclipse-nls-sdk
但是: 依赖: eclipse-platform (>=2.1.2) but it is not installable
这是怎么回事?
回复

回到 “新闻和通知”