再发scim1.4.2/fcitx3.1.1

最新ubuntu/linux/开源新闻或者其它IT相关资讯
回复
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

再发scim1.4.2/fcitx3.1.1

#1

帖子 yongyi » 2005-08-18 22:05

声明:
这是非官方源,是我个人行为,所以很可能并没官方的稳定性和兼容性,请三思而后用。
需要的兄弟就拿吧。
想自己编译的兄弟,请自行编译。
追求稳定的官方源的兄弟可以略过。
在 ubuntu5.04(hoary)+kde3.4.0 中编译测试。我在breezy 也在用。
现在可以apt-get 了。


使用:

scim1.4.2:

1.先卸载旧的scim(因为升级是 1.0.x -> 1.4.x):

代码: 全选

sudo apt-get --purge remove scim scim-gtk2-immodule scim-modules-socket scim-modules-table scim-pinyin scim-tables-zh scim-input-pad

如果提示有些目录非空而删除不了,请手动删除一下。把 ~/.scim 也删除了。

现在可以直接加 apt 源来apt-get 了:

代码: 全选

sudo gedit /etc/apt/sources.list

加入:

代码: 全选

deb http://www.hanyangltd.com/upload ./

然后:

代码: 全选

sudo apt-get update

最后就通过 sudo apt-get install 来安装吧!
=======================
软件列表:
scim (1.4.2-1hoary_i386)
scim-fcitx (3.1.1-4hoary-1_i386)
scim-pinyin (0.5.91-1hoary_i386)
libchewing (0.2.7-1hoary_i386)
scim-chewing (0.2.1-1hoary_i386)
scim-input-pad (0.1.0-4hoary-1_i386)
table-im-engine (0.5.3-2hoary_i386)
scim-tables-zh (0.5.3-1hoary_i386)
scim-tables-icons (0.5.3-2hoary_i386)
scim-tables (0.5.3-2hoary_i386)
skim (1.4.1-3hoary_i386) #暂时有些小问题,请先别用。
fcitx (3.1.1-hoary-1_i386)

**如果你是 apt-get 的,请直接跳到第 4 步设置




2.下载 deb包 (按需要下载 ):
scim平台:
http://www.hanyangltd.com/upload/scim_1 ... y_i386.deb
fcitx 输入法(五/二/仓/拼):
http://www.hanyangltd.com/upload/scim-f ... 1_i386.deb
智能拼音:
http://www.hanyangltd.com/upload/scim-p ... y_i386.deb
繁体的chewing:
http://www.hanyangltd.com/upload/libche ... y_i386.deb
http://www.hanyangltd.com/upload/scim-c ... y_i386.deb
Iput Pad:
http://www.hanyangltd.com/upload/scim-i ... 1_i386.deb
scim-tables-zh(简体:二/二青松/五/广拼/自然 ; 繁体:吴语注音/仓颉/注音/大易/港式广东话/笔顺五码/简易/粤语拼音/行列/轻松/速成):
http://www.hanyangltd.com/upload/table- ... y_i386.deb
http://www.hanyangltd.com/upload/scim-t ... y_i386.deb
http://www.hanyangltd.com/upload/scim-t ... y_i386.deb
注:如果韩、日还有其它国家的都要的话,下这个 scim-tables 大包就可以了:
http://www.hanyangltd.com/upload/scim-t ... y_i386.deb

3. 安装:

代码: 全选

sudo dpkg -i 软件包名

如:

代码: 全选

sudo dpkg -i scim_1.4.2-1hoary_i386.deb


4. 设置:

代码: 全选

sudo sh -c " echo 'export XMODIFIERS=@im=SCIM ; export GTK_IM_MODULE="scim" ; scim -d ' > /etc/X11/Xsession.d/95xinput " sudo chmod +755 /etc/X11/Xsession.d/95xinput



注:1. scim 一定要安装,然后选择自己喜欢的输入法安装。
2. chewing 我是可以调出来,但不知道怎么用,所以也不清楚是否成功了的。


skim1.4.1:

请自行下载源码,编译安装。
我安装起来总有些小问题!


3.设置:

killall scim-launcher
skim -d -f
然后右击skim的系统托盘图标,配置:
前端-scim常规-其他,选上scim-panel-kde 和 kconfig
前端-X窗口,选上“KDE启动时,自动运行skim”

最后:

代码: 全选

sudo sh -c " echo 'export XMODIFIERS=@im=SCIM ; export GTK_IM_MODULE="scim" ' > /etc/X11/Xsession.d/95xinput " 
sudo chmod +755 /etc/X11/Xsession.d/95xinput



fcitx3.1.1:
1. 下载
http://www.hanyangltd.com/upload/fcitx_ ... 1_i386.deb

2. 安装
sudo dpkg -i fcitx_3.1.1-hoary-1_i386.deb

3. 设置

代码: 全选

sudo sh -c " echo 'export XMODIFIERS=@im=fcitx ; export GTK_IM_MODULE="fcitx" ; fcitx ' > /etc/X11/Xsession.d/95xinput " sudo chmod +755 /etc/X11/Xsession.d/95xinput
上次由 yongyi 在 2005-08-20 10:21,总共编辑 5 次。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 firehare » 2005-08-18 23:15

赞一个,Yongyi兄功力日显深厚呀!
我心无畏,源自于我心无知。
图片
头像
oneleaf
论坛管理员
帖子: 10209
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#3

帖子 oneleaf » 2005-08-19 8:41

如果可以将编译的包的名字改为 scim-org-cn 表明不是官方制作的,并

Replaces: scim
Conflicts: scim ....

我就添加到源中。

因为很多人都在使用源,不想影响到他们。不然又有意见了。

其它也以此类推 如: fcitx-org-cn

如果你有更好的命名方法也可以。

关于源,我计划 将 ubuntu.org.cn 修改为 horay 和 breezy .以方便以后增加
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 yongyi » 2005-08-19 8:59

firehare 写了:赞一个,Yongyi兄功力日显深厚呀!

过奖了,我只是在取巧而已 :P

oneleaf 写了:如果可以将编译的包的名字改为 scim-org-cn 表明不是官方制作的,并

Replaces: scim
Conflicts: scim ....

我就添加到源中。

因为很多人都在使用源,不想影响到他们。不然又有意见了。

其它也以此类推 如: fcitx-org-cn

如果你有更好的命名方法也可以。

关于源,我计划 将 ubuntu.org.cn 修改为 horay 和 breezy .以方便以后增加

名字倒好办,Replaces Conflicts 这两个就还得研究研究了。
但是,我个人倒觉得改动包的主文件名,如fcitx --> fcitx-cn,这不大明智,更会影响到搜索软件包。我觉得就在文件名的后面部分注明一下就可以,如scim_1.4.2-1hoary_i386.deb --> scim_1.4.2-1hoary-org-cn_i386.deb。
为什么?因为名字相同,大家都知道它是谁。再者,系统可以检测到这个包有新版本,方便升级,比如前天我breezy上的scim是1.4.1的,scim-fcitx/scim-input-pad 都是基于1.4.1编译的,但昨晚我一加上我上面的源,更新后,系统就自动发现有新版本(我在命令上专门把version后面的数字调得大于1.4.1的),我就可以直接apt-get dist-upgrade 了。这,我感觉还方便一些。

如果怕加到源中引起XDJM们以为是官方的,那倒没问题了,现在我以帖子形式这样发布,大家得添加上面的源才会出现我那些版本,这样,谁也不会认为它们是官方的了吧。就是怕以后我也没空间放。呵呵。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zengsun
帖子: 334
注册时间: 2005-05-17 14:45
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 zengsun » 2005-08-19 10:17

用上了,但没有什么新功能。
现在还是在学java!
头像
oneleaf
论坛管理员
帖子: 10209
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#6

帖子 oneleaf » 2005-08-19 14:21

呵呵,我主要是想和官方的区别开来,如果需要安装就自行安装,如果自动升级了,有时如果用户不想升级,就会觉得比较麻烦,我是比较担心,毕竟自己做的包的考虑问题方面没有官方的好。就好像这次由于我加入了台湾方面编译的scim包,结果就有人反应使用不了。所以现在我删除也不是,留着也不是。有点两难。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#7

帖子 yonsan » 2005-08-19 14:27

呵呵 :o 偶的建议是我们自已不打包,只介绍源代码安装过程!!
I will be back!
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 yongyi » 2005-08-19 14:37

yonsan 写了:呵呵 :o 偶的建议是我们自已不打包,只介绍源代码安装过程!!

编译:
scim 及其输入法模块均用
代码
./configure --prefix=/usr
make
sudo makeinstall

skim的编译请阅读skim包里面的说明文件来编译安装!
上次由 yongyi 在 2005-08-19 21:36,总共编辑 1 次。
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#9

帖子 yonsan » 2005-08-19 14:41

yongyi 写了:
yonsan 写了:呵呵 :o 偶的建议是我们自已不打包,只介绍源代码安装过程!!

编译:
scim 及其输入法模块均用
代码
./configure --prefix=/usr
make
sudo makeinstall

skim用
代码
./configure
make
sudo makeinstall

注:先安装scim后才编译输入法模块。如果安装skim后才编译输入法模块的,scim-pinyin 和 scim-input-pad 要用
代码
./configure --prefix=/usr --disable-skim-support

编译,不然会报错。

不过,这些在INSTALL或README文件都写着的了。


这我知道,但是新手们少的就是如果出现未安装的依赖库的话他们就不知如何是好了! 我的意思是必须列出编译这个软件包所包括的相关依赖库是哪些?
他们出问题就发贴问就可以了! 这样更有利于他们学习!! 毕竟总靠别人不是出路!!
I will be back!
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#10

帖子 yonsan » 2005-08-19 14:47

:o 还有一个相当有意思的问题就是:
yongyi兄你也编译过不少源代码包了吧!! 但开始学linux的第一次编译源代码出错时你的感受如何? (我的第一个想法是放弃)!
在没有办法的情况下只能靠自已解决,所以又重新编译,再自已上google找解决办法!!
这个过程是可以学会自已解决linux问题的!! 呵呵,偶总是觉得不希望来这论坛的都是新手才来这!如果现在没"高手"相信一段时间后总会有吧!!

(以上纯属个人意见.... 呵呵,有点灌水的味了)
I will be back!
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#11

帖子 firehare » 2005-08-19 15:03

其实我倒是觉得用Linux的有几种人,其中占绝大多数的就是用户,他们并不想搞清楚系统,他们只想搞清楚的就是在Linux运行的那些对他们有用的应用软件,以及如何可以很方便地使用。他们并不希望自已来解决Linux问题,就象在Windows下一样。
Windows的贡献在于它只需要用户知道如何开机,以及应用软件的Setup.exe文件在哪就行了,而Ubuntu现在也可以用Apt-get install 应用软件名就可以了。所以对于这部分用户而言,有已经编译的包那是最好的了!毕竟在这世上,我们不能强求用户都有计算机专业的水平,不是吗?所以说Yongyi兄还是做了件大好事,呵呵!

以上是我的一些粗浅的看法,供大家参考!
我心无畏,源自于我心无知。
图片
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#12

帖子 内存不足 » 2005-08-21 0:13

痛苦啊 我这里下载
http://www.hanyangltd.com/upload/scim_1 ... y_i386.deb

速度才1kb多 还几分钟断一次线 :shock: 什么时候是个头啊 痛苦

有没有别的源/?
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 yongyi » 2005-08-21 10:36

主机是电信的。
或者你用源里的吧。看看“快速设置”
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#14

帖子 内存不足 » 2005-08-21 18:58

http://www.hanyangltd.com/upload/scim-t ... y_i386.deb

我要这个包包 下载回来后要怎样手工安装? 为了装泰文的输入法 :cry:

我已经安装好了SICM
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#15

帖子 lyreopera » 2005-08-21 19:16

sudo dpkg -i scim-tables_0.5.3-2hoary_i386.deb
……
回复

回到 “新闻和通知”