从7.04升级到7.10应该注意的问题

最新ubuntu/linux/开源新闻或者其它IT相关资讯
回复
头像
oneleaf
论坛管理员
帖子: 10228
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

从7.04升级到7.10应该注意的问题

#1

帖子 oneleaf » 2007-10-20 13:42

请使用 系统 -> 系统管理 -> 更新管理器 来升级

命令行使用:

代码: 全选

sudo apt-get install update-manager-core
sudo do-release-upgrade
来升级。
不要使用 sudo apt-get dist-upgrade 升级。
此命令无法保证正确的升级。
已知问题:会出现

代码: 全选

device-mapper: table: 254:3: linear: dm-linear: Device lookup failed
device-mapper: ioctl: error adding target to table
的异常。处理办法,删除 evms 及相关包。

需要删除的包:
正在删除 cdrecord ...
正在删除 desktop-effects ...
正在删除 esound ...
正在删除 evms-ncurses ...
正在删除 evms ...
update-initramfs: deferring update (trigger activated)
正在删除 feisty-session-splashes ...
正在删除 feisty-wallpapers ...
正在删除 gaim ...
正在删除 gaim-data ...
正在删除 gs-common ...
正在删除 gs-esp-x ...
正在删除 libcurl3 ...
正在删除 libevms-2.5 ...
正在删除 libflac++5c2 ...
正在删除 libflac7 ...
正在删除 libgcj7-0 ...
正在删除 libgda2-3 ...
正在删除 libgda2-common ...
正在删除 libgdiplus ...
正在删除 libgnomecupsui1.0-1c2a ...
正在删除 libgpod1 ...
正在删除 libgs-esp8 ...
正在删除 libgstreamer-plugins-pulse0.10-0 ...
正在删除 libjack0.100.0-0 ...
正在删除 libjasper-1.701-1 ...
正在删除 libmdbtools ...
正在删除 libneon25 ...
正在删除 libnspr4 ...
正在删除 libpoppler1-glib ...
正在删除 libpoppler1 ...
正在删除 libquicktime0 ...
正在删除 libservlet2.3-java ...
正在删除 libslab0 ...
正在删除 libsnmp9 ...
正在删除 libstlport5.1 ...
正在删除 libswfdec0.3 ...
正在删除 libtotem-plparser1 ...
正在删除 libwvstreams4.2-extras ...
正在删除 libwvstreams4.2-base ...
正在删除 linux-headers-2.6.20-15-generic ...
正在删除 linux-headers-2.6.20-16-generic ...
正在删除 linux-headers-2.6.20-16 ...
正在删除 nfs-kernel-server ...
* Stopping NFS kernel daemon [ OK ]
* Unexporting directories for NFS kernel daemon... [ OK ]
正在删除 vmware-server-kernel-modules-2.6.20-15 ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.22-14-generic
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
无法连上Internet使用 alternate CD/DVD 来升级
挂载iso后,执行:
gksu "sh /cdrom/cdromupgrade" 或 kdesu "sh /cdrom/cdromupgrade"
上次由 oneleaf 在 2007-11-10 18:54,总共编辑 3 次。
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 hualang0929 » 2007-10-20 14:05

我就是用 sudo aptitude dist-upgrade 升级上来的,看来我运气不错 :lol:
抬头望星空一片晴,我独行,夜已渐寒……
ilsa
帖子: 1
注册时间: 2007-10-20 15:01
送出感谢: 0
接收感谢: 0

我就是用的dist-upgrade

#3

帖子 ilsa » 2007-10-20 15:04

到目前位置看起来一切正常,
不过因为以前pidgin是自己编译的,
所以貌似有些问题,
登录不了msn,
把自己编译的版本删除了就好了。
gbz55
帖子: 15
注册时间: 2007-10-07 2:52
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 gbz55 » 2007-10-20 15:18

升级了一天,老是提示失败
vsscj
帖子: 16
注册时间: 2007-06-04 17:33
送出感谢: 0
接收感谢: 0

#5

帖子 vsscj » 2007-10-20 15:30

升级成功,不过问题多多,CTRL+ALT+123456都不能用了
topspace
帖子: 25
注册时间: 2007-01-17 18:36
送出感谢: 0
接收感谢: 0

#6

帖子 topspace » 2007-10-20 15:34

刚使用 sudo apt-get dist-upgrade 升级,暂时没发现问题,传说中的3D效果不知怎样弄出来,不是说已经集成了吗?难道还要自己装?
头像
ofewiofewo
帖子: 547
注册时间: 2007-06-02 14:56
送出感谢: 0
接收感谢: 0

#7

帖子 ofewiofewo » 2007-10-20 15:52

还有一种方法:编辑/etc/evms.conf文件,在sysfs_devices段里设置:
exclude = [ * ]
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#8

帖子 dogfox » 2007-10-20 17:07

我是使用

代码: 全选

sudo aptitude dist-upgrade
升的
升完后悔啊
还没7.04的好
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
enjoygo
帖子: 35
注册时间: 2007-02-03 11:52
送出感谢: 0
接收感谢: 0

#9

帖子 enjoygo » 2007-10-20 17:14

俺还没做好备份,先不升了;)
waf7225
帖子: 36
注册时间: 2007-08-18 11:36
送出感谢: 0
接收感谢: 0

#10

帖子 waf7225 » 2007-10-20 19:57

看看啊~
渡边
帖子: 17
注册时间: 2007-01-30 15:50
送出感谢: 0
接收感谢: 0

#11

帖子 渡边 » 2007-10-20 20:11

升以后怎么样啊,我正在升
lonestone
帖子: 65
注册时间: 2006-09-10 13:38
送出感谢: 0
接收感谢: 0

[分享]升级到7.10,感觉不错的说

#12

帖子 lonestone » 2007-10-20 20:47

一天一夜下载了dvd版本的,想着软件包比较全些,不用什么都到网上下载。

然后直接把iso挂载起来,就运行了光盘里面的升级程序,升级过程一切顺利。

完成后重启,第一次桌面不能正常显示,第二次就好了,不过发现compiz fusion不能用,于是就卸载了,重新安装,好了,呵呵

很是欣慰的就是,compiz fusion这个版本很稳定,性能也好多了,在我的ati 7500上很是流畅!原先自己安装的就不是很流畅。

其他的小问题基本都解决了,如natuails不能使用输入法等。

总之一句话,新版很不错!ubuntu就是不一样!
头像
Legendaryfish
帖子: 166
注册时间: 2006-06-10 16:55
来自: 厦门.IUE
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 Legendaryfish » 2007-10-20 21:36

要是UB有SuSE那样的直接光盘升级安装就方便多了,毕竟这种update还是有点怕怕,我等着买硬盘了全新装
头像
tigerdoo
帖子: 327
注册时间: 2006-11-17 23:02
送出感谢: 0
接收感谢: 0

#14

帖子 tigerdoo » 2007-10-20 21:49

我是用sudo aptitude dist-upgrade升级的,一切正常。很好用

升级后kopete不能使用,那是kdelibs的问题,今天已经有新版本出来了,已经解决了这个问题。
IBM T41-P4M 1.5G/1GB/40GB HDD/DVD/14.1TFT/IPW2100 & 10-100M
OS:Xubuntu 11.10
生活就是折腾
活在成都
使用update-rc.d管理Linux服务
lonestone
帖子: 65
注册时间: 2006-09-10 13:38
送出感谢: 0
接收感谢: 0

#15

帖子 lonestone » 2007-10-20 22:04

Legendaryfish 写了:要是UB有SuSE那样的直接光盘升级安装就方便多了,毕竟这种update还是有点怕怕,我等着买硬盘了全新装
完全可以的阿,你直接以root运行里面的cdromupgrade就是
回复

回到 “新闻和通知”