当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 为啥ubuntu、opensuse之类不像arch只更新软件包?
帖子发表于 : 2008-08-21 20:08 

注册: 2007-09-14 19:51
帖子: 972
送出感谢: 0 次
接收感谢: 0 次
是为了方便用户把系统整合的太复杂了,只更新软件包会出问题?
还是各个开源软件不够协调,没有统一的标准,肯定会出问题?
还是商业利益驱动?
猜想一下,如果这些主流的发行版都像archlinux的话。哇咔咔。。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-21 20:11 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
ubuntu也是只更新软件包吧?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-21 20:19 

注册: 2007-09-14 19:51
帖子: 972
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
ubuntu也是只更新软件包吧?

6.10和8.04用官方源升级到最新后,每个软件包的版本一样吗?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-21 21:10 

注册: 2007-09-19 13:48
帖子: 131
送出感谢: 0 次
接收感谢: 0 次
me 写道:
leeaman 写道:
ubuntu也是只更新软件包吧?

6.10和8.04用官方源升级到最新后,每个软件包的版本一样吗?

请说明什么是版本一致,
是指Ubuntu 8.04中Firefox3.0的版本和mplayer的版本是否一致吗?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-21 21:12 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
???不懂


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-21 21:14 
头像

注册: 2006-10-27 11:14
帖子: 1140
地址: 悉尼
送出感谢: 0 次
接收感谢: 0 次
基本上不知道你在说什么,arch是滚动发行版,它的基础库更新极快,如果天天跟着那还没感觉,如果你半年或者三个月才更新一次,出问题的几率就大了很多。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-26 13:43 
头像

注册: 2006-08-11 0:44
帖子: 89
送出感谢: 0 次
接收感谢: 0 次
arch 的pacman.是压缩的编译好的程序。
就是解压缩就可以使用。
一般很小的系统也用,例如tty linux 。用他装 apache 只有 几百K。
安装 mysql 也只有10M.
deb包和他的机制不同。
不过如果你愿意。你可以在一个系统上安装多个包管理器。
我在centos 上同时装了 yum 和 apt 。
呵呵都可以用。
问题是 容易乱,你要是更新用错软件包管理器。就出错了。


_________________
Linux fans,
Research and development


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-26 16:03 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
wangbo351 写道:
arch 的pacman.是压缩的编译好的程序。
就是解压缩就可以使用。
一般很小的系统也用,例如tty linux 。用他装 apache 只有 几百K。
安装 mysql 也只有10M.
deb包和他的机制不同。
不过如果你愿意。你可以在一个系统上安装多个包管理器。
我在centos 上同时装了 yum 和 apt 。
呵呵都可以用。
问题是 容易乱,你要是更新用错软件包管理器。就出错了。
deb不也是压缩编译好的程序么?大小差不多吧,有的deb大可能是静态编译的。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-08-26 17:56 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
下一代的deb要用LZMA了。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-08-26 21:39 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
首先ubuntu、opensese不是arch,再者这样做有什么意思。。。


_________________
Ubuntu User


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-08-27 18:34 

注册: 2007-05-13 15:20
帖子: 333
送出感谢: 0 次
接收感谢: 0 次
suse,RHEL都是商用的,叫你不停升级,你会放心吗???

ubuntu就不要提了,影响不大,有bug都不升级(如7.10的 alsa)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译