[原创]请大家帮助检阅Dubuntu-6.10 需求设计说明书

Ubuntu国外衍生版本或其它衍生版本
回复
头像
lvjinhua
帖子: 436
注册时间: 2006-02-23 14:46
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

[原创]请大家帮助检阅Dubuntu-6.10 需求设计说明书

#1

帖子 lvjinhua » 2006-08-20 1:46

为了使以后的开发与测试更加规范,我简单的写了个 Dubuntu-6.10 的需求设计说明书,里面包含了Dubuntu-6.10 应该包含的主要软件及其特性,还有一些其它内容。

现在请大家对此文档进行审视,审视的过程中主要关注以下几个方面:语义/语法错误,标点错误,需求说明模糊不清,存在多余需求或遗漏相关需求等。

大家发现问题后可以提出,我会将收集到的所有回馈,对需求说明书进行一次修订,并将修改后的版本作为接下来两个月指导我们开发及测试的主要依据!

需求说明书主要有两个作用:
一个作用是指导开发:开发人员将依据需求说明中的内容进行设计,最终达到相应的结果。
另一个很重要的作用是指导测试:测试人员将依据需求指导书中的需求,写出一组测试用例,然后测试实施人员再根据测试用例的描述对某一个功能或需求进行测试,以检验开发人员输出的内容是否达到需求所描述的内容。

附件中的为说明书的三种格式,任选其一即可!其中 .eio 为永中Office的格式。

谢谢大家的参与!

-- Dubuntu 吕进华
-- 2006.08.20
附件
Dubuntu-6.10需求设计说明书.doc.tar.gz
(19.42 KiB) 下载 131 次
Dubuntu-6.10需求设计说明书.eio.tar.gz
(52.85 KiB) 下载 63 次
Dubuntu-6.10需求设计说明书.pdf.tar.gz
(277.4 KiB) 下载 412 次
====
dubuntu-6.06-livecd-i386正式版正式完工!
====
*支持LiveCD硬盘启动
*Linux 2.6.15-23-686
*永中Office 2007
*LumaQQ+OpenQ+cycloneQQ
**N 多的编程及调试工具**
xieguozhong
帖子: 39
注册时间: 2005-09-26 12:51
来自: 江西南昌
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xieguozhong » 2006-08-20 10:07

:P 支持
热爱一切新技术的新手
xieguozhong
帖子: 39
注册时间: 2005-09-26 12:51
来自: 江西南昌
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 xieguozhong » 2006-08-20 10:39

1 文档里面有些地方用“!”结束,有些地方用“。”号结束,不知道这个算不算,
2 有些功能有点重复,像QQ,我觉得只要一个lumaQQ就可以了
3 系统字体能不能加入MS雅黑,挺好看的
4 安装时的分区,多做点说明,这样才会明白,特别是针对只是将dubuntu安装在一个分区的用户来说,因为很担心
其它分区的数据会不会丢掉,所以一犹豫就不玩了
热爱一切新技术的新手
头像
lvjinhua
帖子: 436
注册时间: 2006-02-23 14:46
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 lvjinhua » 2006-08-20 17:46

xieguozhong 写了:1 文档里面有些地方用“!”结束,有些地方用“。”号结束,不知道这个算不算,
2 有些功能有点重复,像QQ,我觉得只要一个lumaQQ就可以了
3 系统字体能不能加入MS雅黑,挺好看的
4 安装时的分区,多做点说明,这样才会明白,特别是针对只是将dubuntu安装在一个分区的用户来说,因为很担心
其它分区的数据会不会丢掉,所以一犹豫就不玩了
1 主要是由于感情色彩!
2 主要是Linux下的几个QQ客户端实现都不完美,有时这个不能登录,换另一个就行了!
3 下一版将使用wqy,如果wqy没有最终完成,会使用Uming,Ukai。
4 这一点会注意!
====
dubuntu-6.06-livecd-i386正式版正式完工!
====
*支持LiveCD硬盘启动
*Linux 2.6.15-23-686
*永中Office 2007
*LumaQQ+OpenQ+cycloneQQ
**N 多的编程及调试工具**
robinyyh
帖子: 13
注册时间: 2006-08-25 14:57
送出感谢: 0
接收感谢: 0

#5

帖子 robinyyh » 2006-08-26 23:22

安装程序能否提供软件选择功能,能否给出包之间的依存关系。以便选择性安装?

fcitx的联想功能不强,选词快捷健有些别扭,选词字体有些难看。
我想要是能改进能让大家在dubuntu下敲文档更加轻松。:)
tonylin
帖子: 17
注册时间: 2007-01-23 9:18
送出感谢: 0
接收感谢: 0

能否给其它的开发程序一个支持.LAZARUS0.920

#6

帖子 tonylin » 2007-02-02 11:43

能否给其它的开发程序一个支持.LAZARUS0.920
wolvever
帖子: 39
注册时间: 2007-01-11 20:40
送出感谢: 0
接收感谢: 0

#7

帖子 wolvever » 2007-02-02 20:36

上海做的那个Linux版本(RAYS)不知道可不可以借鉴借鉴,汉化美化都做好了,输入法是紫光的,如果能换成sogou input会好些吧,其他qq,办公等都预先提供了比较好的支持。
peigen
帖子: 234
注册时间: 2006-10-12 21:31
送出感谢: 0
接收感谢: 0

#8

帖子 peigen » 2007-02-06 14:26

为啥是
ubuntu-6.06-新手指南(英文版)

而不是6.10的?
jfy3d
帖子: 16
注册时间: 2006-08-17 14:20
送出感谢: 0
接收感谢: 0

#9

帖子 jfy3d » 2007-02-07 9:02

有的字体会影响INTEL IJ IDEA 的运行
头像
wtwang1985
帖子: 54
注册时间: 2005-06-25 21:57
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 wtwang1985 » 2007-02-09 9:17

能把bmp换成audacious么?觉得bmp不好用
另外,浏览器的字体不好看。firefox和opera的都是。能设置一下么?谢谢。
Recobi
帖子: 76
注册时间: 2007-02-09 22:47
来自: 重庆-中山
送出感谢: 0
接收感谢: 1 次

#11

帖子 Recobi » 2007-02-09 23:14

这个版本进度怎么样了?6。06中的永中好象已经用不了了,前两天装了Ubuntu6.10!
头像
titainium
帖子: 689
注册时间: 2006-12-02 12:25
送出感谢: 0
接收感谢: 0

#12

帖子 titainium » 2007-02-10 17:14

MySQL其实不算好用啦,建议换成PostgreSQL,还有个建议就是直接升到7.04版本。eclipse能提供插件齐全的版本吗?昨天晚上我尝试使用Eclipse自带的升级工具升级,居然弄到Eclipse不能使用了,郁闷!删掉重装也不可以,不知道新立德是怎么配置安装文件的。最后干脆重装整个系统,忙到临晨才弄好。最好下一个发行版就是DVD的,呵呵,与时俱进哦 :D :D
Titainium
头像
adqin
帖子: 1417
注册时间: 2007-01-24 22:07
来自: http://adqin.cn
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 adqin » 2007-02-20 4:48

我还没有用过,今天才开始了解。
但我希望音乐播放器加入一个audacious
Eclipse插件多提供几个罢,特别是PHPEclipse
cweiyu
帖子: 74
注册时间: 2007-01-08 12:10
送出感谢: 0
接收感谢: 0

#14

帖子 cweiyu » 2007-04-07 10:53

bmp在我的电脑上使用的时候,cpu一高就会失去反应,希望能换个播放器
文档里面木有说集成的firefox版本,能不能在6.10里默认安装2.0.0.3?
技术?不懂……我就是跟着起哄的
所以我爱看pk版
niaomo
帖子: 36
注册时间: 2007-03-31 18:09
送出感谢: 0
接收感谢: 0

#15

帖子 niaomo » 2007-06-07 15:20

cweiyu 写了:bmp在我的电脑上使用的时候,cpu一高就会失去反应,希望能换个播放器
文档里面木有说集成的firefox版本,能不能在6.10里默认安装2.0.0.3?
看来这是BMP的一个固有缺憾,虽然我用的是Hiweed,但同样存在这样的情况,BMP经常在CPU占用较大时停止,非得重新点一下暂停,再点一下播放,才能继续。例如先打开BMP播放ing歌曲,再打开Firefox,就会出现BMP自动停止的情况。
最小化运行BMP,或者在另一个桌面运行BMP,情况就有所改善,打开Firefox也不会卡住BMP了,但如果apt-get安装某个软件(例如EVA),BMP就会同样卡住。
回复

回到 “Ubuntu国外衍生版”