10.10安装e17错误,完全无解...求救中...请高手进来看看

Ubuntu国外衍生版本或其它衍生版本
回复
eva01
帖子: 17
注册时间: 2010-10-01 19:12
送出感谢: 0
接收感谢: 0

10.10安装e17错误,完全无解...求救中...请高手进来看看

#1

帖子 eva01 » 2011-05-12 16:26

帮同学在他已经使用了半年的机器(10.10)上安装e17,参考adagio的帖子(viewtopic.php?f=120&t=250022),三种方法全部失败。添加源之后安装提示找不到软件。第二种方法网页无法打开,第三种,进行到第二步时提示:gpg: 找不到有效的 OpenPGP 数据。官网下载安装文件之后无法编译。
参考这个帖子(viewtopic.php?f=48&t=311828)的安装方式提示一堆依赖关系不能满足,我尝试安装需要的东西,但是发现其中有些是矛盾的,安装其中一个就需要卸载另外一些,始终无法安装。
还请各位e17 fans们不吝赐教,万分感谢....
头像
TeliuTe
论坛版主
帖子: 7431
注册时间: 2007-11-25 13:29
系统: 14/16/18/Fedroa22/w7
来自: 新疆博乐
送出感谢: 29 次
接收感谢: 99 次
联系:

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#2

帖子 TeliuTe » 2011-05-12 20:53

貌似10.10不用加其他源,
把你的软件源发上来看看
eva01
帖子: 17
注册时间: 2010-10-01 19:12
送出感谢: 0
接收感谢: 0

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#3

帖子 eva01 » 2011-05-12 21:11

软件源没有问题,新力德里面也有e17的相关软件包,但是奇怪的是要安装就会显示很多依赖关系不能满足,可是这些依赖关系是矛盾的,有很多这样的情况:安装e17需要满足依赖关系A,A要满足B和C,可是安装C就会自动删除B,很多这种情况,我很崩溃....
头像
月下叹逍遥
论坛版主
帖子: 33994
注册时间: 2010-10-07 14:23
系统: Archdows10
来自: 某系某星某洲某国某省某市
送出感谢: 8 次
接收感谢: 63 次
联系:

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#4

帖子 月下叹逍遥 » 2011-05-12 21:11

先安装e16,再安装e17……
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙
eva01
帖子: 17
注册时间: 2010-10-01 19:12
送出感谢: 0
接收感谢: 0

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#5

帖子 eva01 » 2011-05-12 21:13

必须先安装e16么??
头像
月下叹逍遥
论坛版主
帖子: 33994
注册时间: 2010-10-07 14:23
系统: Archdows10
来自: 某系某星某洲某国某省某市
送出感谢: 8 次
接收感谢: 63 次
联系:

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#6

帖子 月下叹逍遥 » 2011-05-12 21:14

不知道,当时我就是这么安装的,不解……
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙
eva01
帖子: 17
注册时间: 2010-10-01 19:12
送出感谢: 0
接收感谢: 0

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#7

帖子 eva01 » 2011-05-12 21:21

安装e16上之后安装e17提示:
依赖: libecore-evas-svn-05 但是此软件包将不会被安装
依赖: libecore-imf-svn-05 但是此软件包将不会被安装
依赖: libecore-input-svn-05 但是此软件包将不会被安装
依赖: libecore-x-svn-05 但是此软件包将不会被安装
依赖: libedbus-svn-05 但是此软件包将不会被安装
依赖: libedje-svn-05 但是此软件包将不会被安装
依赖: libeet1 但是此软件包将不会被安装
依赖: libevas-svn-05 但是此软件包将不会被安装
依赖: libevas-svn-05-engine-software-x11
依赖: libedje-bin 但是此软件包将不会被安装
头像
photor
论坛版主
帖子: 11003
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#8

帖子 photor » 2011-05-12 22:06

eva01 写了:软件源没有问题,新力德里面也有e17的相关软件包,但是奇怪的是要安装就会显示很多依赖关系不能满足,可是这些依赖关系是矛盾的,有很多这样的情况:安装e17需要满足依赖关系A,A要满足B和C,可是安装C就会自动删除B,很多这种情况,我很崩溃....
那是你的源加乱了,只保留官方源试试,10.10源里的e17安装起来绝对没有问题的,就是自带的emodule太少 :em09
eva01
帖子: 17
注册时间: 2010-10-01 19:12
送出感谢: 0
接收感谢: 0

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#9

帖子 eva01 » 2011-05-12 22:29

郁闷啊,10.10下就没有办法完美安装r17么?
eva01
帖子: 17
注册时间: 2010-10-01 19:12
送出感谢: 0
接收感谢: 0

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#10

帖子 eva01 » 2011-05-12 22:36

恢复默认源之后sudo apt-get install e17提示:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
e17 : 依赖: libecore-evas-svn-05 (>= 0.9.9.063) 但是它将不会被安装
依赖: libecore-imf-svn-05 (>= 0.9.9.063) 但是它将不会被安装
依赖: libecore-input-svn-05 (>= 0.9.9.063) 但是它将不会被安装
依赖: libecore-x-svn-05 (>= 0.9.9.063) 但是它将不会被安装
依赖: libedbus-svn-05 (>= 0.5.0.063) 但是它将不会被安装
依赖: libedje-svn-05 (>= 0.9.92.063) 但是它将不会被安装
依赖: libeet1 (>= 1.2.3) 但是它将不会被安装
依赖: libevas-svn-05 (>= 0.9.9.063) 但是它将不会被安装
依赖: libevas-svn-05-engine-software-x11
依赖: libedje-bin 但是它将不会被安装
E: 破损的软件包
头像
wo8818
帖子: 36
注册时间: 2008-07-29 21:22
送出感谢: 0
接收感谢: 0

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#11

帖子 wo8818 » 2011-07-09 19:01

photor 写了:
eva01 写了:软件源没有问题,新力德里面也有e17的相关软件包,但是奇怪的是要安装就会显示很多依赖关系不能满足,可是这些依赖关系是矛盾的,有很多这样的情况:安装e17需要满足依赖关系A,A要满足B和C,可是安装C就会自动删除B,很多这种情况,我很崩溃....
那是你的源加乱了,只保留官方源试试,10.10源里的e17安装起来绝对没有问题的,就是自带的emodule太少 :em09
11.04的也一样,用默认的源能安装E17,但是emodule就几个,emodule从哪里安装。找到的帖子都是很早之前的,都没有。
头像
寒声碎
帖子: 1723
注册时间: 2009-07-31 16:50
送出感谢: 3 次
接收感谢: 4 次
联系:

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#12

帖子 寒声碎 » 2011-07-09 20:27

加debian源安装~~ 试试aptitude install~~
头像
photor
论坛版主
帖子: 11003
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 10.10安装e17错误,完全无解...求救中...请高手进来看看

#13

帖子 photor » 2011-08-03 9:25

wo8818 写了:
photor 写了:
eva01 写了:软件源没有问题,新力德里面也有e17的相关软件包,但是奇怪的是要安装就会显示很多依赖关系不能满足,可是这些依赖关系是矛盾的,有很多这样的情况:安装e17需要满足依赖关系A,A要满足B和C,可是安装C就会自动删除B,很多这种情况,我很崩溃....
那是你的源加乱了,只保留官方源试试,10.10源里的e17安装起来绝对没有问题的,就是自带的emodule太少 :em09
11.04的也一样,用默认的源能安装E17,但是emodule就几个,emodule从哪里安装。找到的帖子都是很早之前的,都没有。
不装emodule也没什么,光板桌面又简洁又省资源,至少功能也比openbox强多了 :em09
回复

回到 “Ubuntu国外衍生版”