今天安装了 Opensolaris 了,呵呵.遇到了网卡驱动问题.

其它Linux/Unix/BSD/OSX等发行版讨论
回复
头像
糊里糊涂
帖子: 43
注册时间: 2006-11-03 14:14
来自: Women's Heart
送出感谢: 0
接收感谢: 0
联系:

今天安装了 Opensolaris 了,呵呵.遇到了网卡驱动问题.

#1

帖子 糊里糊涂 » 2008-06-07 21:19

帖子内容是转贴.解决我的问题了.呵呵.

Solaris 10 x86 (1/06)安装nVIDIA nForce板载网卡驱动

前两天在自己的机子上安装了Solaris 10 x86 (1/06),安装盘系参加SUN社区技术日领的DVD光盘。

由于Solaris官方硬件支持列表里面没有对nVIDIA nForce芯片网卡的支持,因此在安装的过程中没有识别网卡,也就不能配置网络。(这些我也是在安装完后才发现)。

转到CentOS下google搜索,找到如下地址里面有一些免费for Solaris的网卡驱动,其中也有针对nVIDIA nForce芯片网卡的,

http://homepage2.nifty.com/mrym3/taiyodo/eng/

下载里面的nfo-x.x.x.tar.gz拷贝到U盘里面,然后启动到Solaris10,系统自动就挂载了U盘,
然后拷贝nfo-x.x.x.tar.gz到$HOME目录下,解开文件,

[Copy to clipboard] [ - ]CODE:
#gunzip -cd nfo-x.x.x.tar.gz | tar xf -
#cd nfo-x.x.x
在里面有一个README.txt是安装的说明,但是不知道是Solaris 10 (1/06)的原因还是硬件的原因,
按照里面的提示操作不能成功。下面是我的安装配置过程,因为我的就是32位机
作者已经使用gcc编译好了for i386的32位和64位机的驱动,因此我直接

[Copy to clipboard] [ - ]CODE:
#/usr/ccs/bin/make install
就可以了。(如果是64位机的话就得先 #ln -s amd64 obj 然后 #/usr/ccs/bin/make install)

[Copy to clipboard] [ - ]CODE:
#./adddrv.sh
这一步系统提示
"pci10de,1c3","pci10de,66","pci10de,d6","pci10de,86","pci10de,8c",
"pci10de,e6","pci10de,df","pci10de,56","pci10de,57","pci10de,37"
already xxx (我也不记得到底是哪些,反正就是这样类似的信息)

所以这一步实际上没有操作成功,解决的办法如下:

[Copy to clipboard] [ - ]CODE:
#prtconf -pv > tmp.txt
然后再到tmp.txt里面查找“Ethernet”,在它上面一行有"pci10de,xx",
再将nfo "pci10de,xx"加到/etc/driver_aliases的最后。

然后创建/etc/hostname.nfo0文件,里面添加你所取的主机名;
修改/etc/hosts,添加IP和对应的主机名,第一行的127.0.0.1对应的主机名就是localhost,
建议将其后面的域名删除,而在实际IP地址对应的后面一定要加上域名,没有就随便取一个名字。我的如下

QUOTE:

127.0.0.1 localhost
219.242.115.229 Solaris10 bjtu.edu.cn loghost
修改/etc/inet/ipnodes和/etc/hosts一样,

修改/etc/inet/netmasks,配置子网、掩码,格式如下:

QUOTE:
子网地址 掩码
我的配置如下

QUOTE:

219.242.115.0 255.255.255.0
修改/etc/nsswitch.conf,/etc/nsswitch.files中hosts: files为hosts: files dns

创建/etc/resolv.conf文件,配置dns,内容格式如下:

QUOTE:
nameserver dns的地址
如:

QUOTE:

nameserver 202.112.144.30
创建/etc/defaultrouter文件,配置网关,里面直接写上网关的IP就可以了。

[Copy to clipboard] [ - ]CODE:
#reboot
如果不出意外的话应该就可以正常联网了。一点经验,希望对大家有用。
回复

回到 “其它类Unix OS发行版”