当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : CentOS用Yum安装软件出了点问题
帖子发表于 : 2009-04-14 11:23 
头像

注册: 2009-02-27 2:11
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
一直用Ubuntu,今天第一次用CentOS,发现许多软件都不能安装,如xmms ,mplayer 都无法安装。这是出错的提示:
代码:
[root@localhost falcon]# yum install xmms
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: apt.sw.be
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package xmms.i386 1:1.2.10-14.el5.rf set to be updated
filelists.xml.gz                                         | 3.4 MB     02:54     
--> Processing Dependency: gtk+ >= 1:1.2.2 for package: xmms
--> Processing Dependency: libgmodule-1.2.so.0 for package: xmms
--> Processing Dependency: libgtk-1.2.so.0 for package: xmms
--> Processing Dependency: libmikmod.so.2 for package: xmms
--> Processing Dependency: libglib-1.2.so.0 for package: xmms
--> Processing Dependency: libgdk-1.2.so.0 for package: xmms
--> Processing Dependency: libgthread-1.2.so.0 for package: xmms
--> Finished Dependency Resolution
1:xmms-1.2.10-14.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libmikmod.so.2 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
1:xmms-1.2.10-14.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgmodule-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
1:xmms-1.2.10-14.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgtk-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
1:xmms-1.2.10-14.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgthread-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
1:xmms-1.2.10-14.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgdk-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
1:xmms-1.2.10-14.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libglib-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
1:xmms-1.2.10-14.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: gtk+ >= 1:1.2.2 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libmikmod.so.2 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libglib-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgmodule-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgtk-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgdk-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgthread-1.2.so.0 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)
Error: Missing Dependency: gtk+ >= 1:1.2.2 is needed by package 1:xmms-1.2.10-14.el5.rf.i386 (rpmforge)


这是我的源配置文件
代码:
# CentOS-Base.repo
#
# This file uses a new mirrorlist system developed by Lance Davis for CentOS.
# The mirror system uses the connecting IP address of the client and the
# update status of each mirror to pick mirrors that are updated to and
# geographically close to the client.  You should use this for CentOS updates
# unless you are manually picking other mirrors.
#
# If the mirrorlist= does not work for you, as a fall back you can try the
# remarked out baseurl= line instead.
#
#

[base]
name=CentOS-5.3 - Base
baseurl=http://centos.ustc.edu.cn/centos/5.3/os/$basearch/
gpgcheck=1
gpgkey=http://centos.ustc.edu.cn/centos/RPM-GPG-KEY-CentOS-5

#released updates
[updates]
name=CentOS-5.3 - Updates
baseurl=http://centos.ustc.edu.cn/centos/5.3/updates/$basearch/
gpgcheck=1
gpgkey=http://centos.ustc.edu.cn/centos/RPM-GPG-KEY-CentOS-5

#packages used/produced in the build but not released
[addons]
name=CentOS-5.3 - Addons
baseurl=http://centos.ustc.edu.cn/centos/5.3/addons/$basearch/
gpgcheck=1
gpgkey=http://centos.ustc.edu.cn/centos/RPM-GPG-KEY-CentOS-5

#additional packages that may be useful
[extras]
name=CentOS-5.3 - Extras
baseurl=http://centos.ustc.edu.cn/centos/5.3/extras/$basearch/
gpgcheck=1
gpgkey=http://centos.ustc.edu.cn/centos/RPM-GPG-KEY-CentOS-5

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-5.3 - Plus
baseurl=http://centos.ustc.edu.cn/centos/5.3/centosplus/$basearch/
gpgcheck=1
enabled=1
gpgkey=http://centos.ustc.edu.cn/centos/RPM-GPG-KEY-CentOS-5

另外我也加了rpmforge的源,Apt-get国内的源(http://mirror.be10.com )连不上,希望大家推荐一个可以连得上的源,我是电信用户。谢谢 :em01 :em01 :em01


_________________
——菜鸟之心,黑客之路

CPU:AMD sempron 2800 (Single Core)
内存:Corsair 512M DDR2 675
主板:ONDA n61v
显卡:Geforce 6100 400集成显卡
硬盘:Westdata 80G
系统:Centos 5.3+windows 2003


页首
 用户资料  
 
2 楼 
 文章标题 : Re: CentOS用Yum安装软件出了点问题
帖子发表于 : 2009-04-14 14:24 
头像

注册: 2007-10-06 23:37
帖子: 582
送出感谢: 0 次
接收感谢: 0 次
rpmforge 、 centos.ustc.edu.cn 同步时间差造成的,等吧。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译