当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-17 21:30 

注册: 2009-05-20 12:30
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
本人准备学习一下Solaris,所以今天装了个。。。正好把一前的系统也删了,一起重装一下。。。结果出现问题了 。
我装了3个系统,XP,Solaris,ubuntu8.04...安装的顺序也是如此。。。结果发现grub一引导菜单里没有Soralis。。。大概是ubuntu不能识别吧。。。
我现在想试试手动修改ubuntu里的menu.lst看看能不能启动Solaris。。。。所以我想要OpenSolaris的menu.lst里的内容。。。。我的OpenSolaris是刚下的。。。应该是最新的。。如果和我的系统一个版本,请把你的menu.lst发给我asmaster@126.com或者直接把里面的内容回复下,谢谢 !


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-18 13:51 

注册: 2007-10-19 20:08
帖子: 164
送出感谢: 0 次
接收感谢: 0 次
我的opensolaris安装在第二个硬盘上,整个硬盘不分区,全部归opensolaris使用了 :em32


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-18 21:05 
头像

注册: 2008-11-04 15:21
帖子: 61
送出感谢: 0 次
接收感谢: 0 次
同感。玩linux的都是爱折腾的,搞第二个硬盘是最明智的选择


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-19 1:00 
头像

注册: 2008-05-10 9:53
帖子: 752
送出感谢: 0 次
接收感谢: 1
ubuntu的grub不认os,估计要用opensolaris livecd修复grub。
不行就用删了grub用grub4dos啊,http://forum.ubuntu.org.cn/download/file.php?id=57090

(hd0,2,a)按自己改,ubuntu的自己加。

title opensolaris x86
root (hd0,2,a)
bootfs rpool/ROOT/opensolaris
kernel$ /platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS
module$ /platform/i86pc/$ISADIR/boot_archive
boot$

title OpenSolaris X86 Single User Mode
root (hd0,2,a)
bootfs rpool/ROOT/opensolaris
kernel$ /platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS -s
module$ /platform/i86pc/$ISADIR/boot_archive
boot$


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-19 8:35 

注册: 2007-10-19 20:08
帖子: 164
送出感谢: 0 次
接收感谢: 0 次
你需要的是这个吗?
/rpool/boot/grub/menu.lst
代码:
splashimage /boot/grub/splash.xpm.gz
background 215ECA
timeout 5
default 2
#---------- ADDED BY BOOTADM - DO NOT EDIT ----------
title OpenSolaris 2009.06
findroot (pool_rpool,0,a)
bootfs rpool/ROOT/opensolaris
splashimage /boot/solaris.xpm
foreground d25f00
background 115d93
kernel$ /platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS,console=graphics
module$ /platform/i86pc/$ISADIR/boot_archive
#---------------------END BOOTADM--------------------

title Windows 7
   rootnoverify (hd0,0)
   chainloader +1

# Unknown partition of type 15 found on /dev/rdsk/c8t0d0p0 partition: 2
# It maps to the GRUB device: (hd0,1) .
title opensolaris-1
findroot (pool_rpool,0,a)
bootfs rpool/ROOT/opensolaris-1
splashimage /boot/solaris.xpm
foreground d25f00
background 115d93
kernel$ /platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS,console=graphics
module$ /platform/i86pc/$ISADIR/boot_archive
#============ End of LIBBE entry =============


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-19 21:24 

注册: 2009-05-20 12:30
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
弄好了,谢谢大家!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-25 14:24 

注册: 2007-06-29 23:18
帖子: 157
地址: 重庆大学机械学院
送出感谢: 0 次
接收感谢: 0 次
ubuntu好像不能读取ZFS吧?!opensolaris可以装在其他格式的文件系统里就好了!


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-28 10:56 

注册: 2009-07-28 10:53
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
lz,可否把你的grub中关于solaris的启动命令贴出来看看阿,我也遇到这个问题了,试了上面的代码没有成功,非常感谢!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 先装Solaris后装ubuntu出现问题
帖子发表于 : 2009-07-28 10:59 

注册: 2009-07-28 10:53
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我的solaris安装在hd0,9分区上,另外电脑上还装了 windows,和ubuntu。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译