「Adobe Flash Player 官方版」更新腳本

其它Linux/Unix/BSD/OSX等发行版讨论
回复
头像
torachiyo
帖子: 75
注册时间: 2015-11-29 8:32
系统: Kali Linux
送出感谢: 0
接收感谢: 4 次

「Adobe Flash Player 官方版」更新腳本

#1

帖子 torachiyo » 2016-07-02 13:05

支援 Linux Mint (ubuntu) LMDE (debian) LMAE (archlinux) 64/32-bit 版本

安裝更新腳本

代码: 全选

$ wget https://github.com/Mint-Fans/linux-package/raw/master/update-flashplayer
$ chmod 755 update-flashplayer
$ sudo mv update-flashplayer /usr/local/bin/
Adobe Flash Player 更新

代码: 全选

$ sudo update-flashplayer
每當想到時執行 sudo update-flashplayer
即可自動更新 Adobe Flash Player 到官方最新版本 图片
onlylove
论坛版主
帖子: 4374
注册时间: 2007-01-14 16:23
送出感谢: 0
接收感谢: 96 次

Re: 「Adobe Flash Player 官方版」更新腳本

#2

帖子 onlylove » 2016-07-02 16:23

要那个11.2的flash有何用,flex都不支持 :Noting
#include <stdio.h>
void main()
{
double world;
unsigned letter;
short stay;
long memories;
printf("I miss you.\n");
}
头像
torachiyo
帖子: 75
注册时间: 2015-11-29 8:32
系统: Kali Linux
送出感谢: 0
接收感谢: 4 次

Re: 「Adobe Flash Player 官方版」更新腳本

#3

帖子 torachiyo » 2016-07-02 19:33

onlylove 写了:要那个11.2的flash有何用,flex都不支持 :Noting
看片有用 我們只看韓劇 不看大陸劇 :Haha
onlylove
论坛版主
帖子: 4374
注册时间: 2007-01-14 16:23
送出感谢: 0
接收感谢: 96 次

Re: 「Adobe Flash Player 官方版」更新腳本

#4

帖子 onlylove » 2016-07-02 22:38

torachiyo 写了:
onlylove 写了:要那个11.2的flash有何用,flex都不支持 :Noting
看片有用 我們只看韓劇 不看大陸劇 :Haha
vmware的vcenter web client需要flex,没flex直接不干活
#include <stdio.h>
void main()
{
double world;
unsigned letter;
short stay;
long memories;
printf("I miss you.\n");
}
头像
torachiyo
帖子: 75
注册时间: 2015-11-29 8:32
系统: Kali Linux
送出感谢: 0
接收感谢: 4 次

Re: 「Adobe Flash Player 官方版」更新腳本

#5

帖子 torachiyo » 2016-07-03 10:33

onlylove 写了:
torachiyo 写了:
onlylove 写了:要那个11.2的flash有何用,flex都不支持 :Noting
看片有用 我們只看韓劇 不看大陸劇 :Haha
vmware的vcenter web client需要flex,没flex直接不干活
我只知道 線上看韓劇要裝 Adobe Flash Player :Haha

沒 Flash Player flv 播放器幹不了活 :Haha

flex 雖然目前沒用到 但我們的系統自己都有裝 :em04
头像
YeLee
论坛版主
帖子: 26408
注册时间: 2008-08-13 8:48
系统: Fundu i64
来自: 东海硇州,一双管钥。
送出感谢: 25 次
接收感谢: 307 次
联系:

Re: 「Adobe Flash Player 官方版」更新腳本

#6

帖子 YeLee » 2016-07-04 10:43

https://github.com/YeLee/code/blob/mast ... dlflash.sh
其实,当年我还活着的时候也写过类似的东西。 :Adore
◎当我站在道德的高度上俯视别人的时候,发现自己是多么渺小。
♥执着但不偏激,反对而不排斥,坚决捍卫矛盾体的存在方式。
★★★天气预报★★★
fcitx-yatable一个可以使用的码表输入法
[教程]几个实例攻克软件编译难关
Gentoo Development Guide
字体相关
头像
qy117121
论坛版主
帖子: 49936
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 332 次
联系:

Re: 「Adobe Flash Player 官方版」更新腳本

#7

帖子 qy117121 » 2016-07-04 14:28

YeLee 写了:https://github.com/YeLee/code/blob/mast ... dlflash.sh
其实,当年我还活着的时候也写过类似的东西。 :Adore
您老人家死了多久了啊
渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
waterloo2005
帖子: 362
注册时间: 2007-01-15 20:53
送出感谢: 0
接收感谢: 0

Re: 「Adobe Flash Player 官方版」更新腳本

#8

帖子 waterloo2005 » 2016-07-04 15:48

请问ubuntu的 sudo apt-get dist-upgrade 能自动更新吗?为什么要单独写个脚本? linux的flash官方支持不是早就over了吗?
rosynirvana
帖子: 907
注册时间: 2011-02-14 17:46
送出感谢: 3 次
接收感谢: 119 次

Re: 「Adobe Flash Player 官方版」更新腳本

#9

帖子 rosynirvana » 2016-07-04 18:59

waterloo2005 写了:请问ubuntu的 sudo apt-get dist-upgrade 能自动更新吗?为什么要单独写个脚本? linux的flash官方支持不是早就over了吗?
首先,dist-upgrade只是一个比较激进的upgrade,例如dist-upgrade可能移除一些包,但upgrade不会;
然后,apt只会从源里进行更新,flash binary本身并不在普通的ubuntu源中,但是源中有些flash安装器可以帮助用户更新flash,例如flashplugin-installer这个包;

最后,安全更新还是有的,11.2.202.xxx最后那个安全更新的版本号还一直在增加
waterloo2005
帖子: 362
注册时间: 2007-01-15 20:53
送出感谢: 0
接收感谢: 0

Re: 「Adobe Flash Player 官方版」更新腳本

#10

帖子 waterloo2005 » 2016-07-04 23:46

rosynirvana 写了:
waterloo2005 写了:请问ubuntu的 sudo apt-get dist-upgrade 能自动更新吗?为什么要单独写个脚本? linux的flash官方支持不是早就over了吗?
首先,dist-upgrade只是一个比较激进的upgrade,例如dist-upgrade可能移除一些包,但upgrade不会;
然后,apt只会从源里进行更新,flash binary本身并不在普通的ubuntu源中,但是源中有些flash安装器可以帮助用户更新flash,例如flashplugin-installer这个包;

最后,安全更新还是有的,11.2.202.xxx最后那个安全更新的版本号还一直在增加
谢谢。

是不是装了 flashplugin-installer , 就不用楼主的这个脚本了?
rosynirvana
帖子: 907
注册时间: 2011-02-14 17:46
送出感谢: 3 次
接收感谢: 119 次

Re: 「Adobe Flash Player 官方版」更新腳本

#11

帖子 rosynirvana » 2016-07-05 0:55

waterloo2005 写了:
rosynirvana 写了:
waterloo2005 写了:请问ubuntu的 sudo apt-get dist-upgrade 能自动更新吗?为什么要单独写个脚本? linux的flash官方支持不是早就over了吗?
首先,dist-upgrade只是一个比较激进的upgrade,例如dist-upgrade可能移除一些包,但upgrade不会;
然后,apt只会从源里进行更新,flash binary本身并不在普通的ubuntu源中,但是源中有些flash安装器可以帮助用户更新flash,例如flashplugin-installer这个包;

最后,安全更新还是有的,11.2.202.xxx最后那个安全更新的版本号还一直在增加
谢谢。

是不是装了 flashplugin-installer , 就不用楼主的这个脚本了?
如果能用flashplugin-installer正常更新就不用
bobby_winon
帖子: 227
注册时间: 2008-01-31 12:39
送出感谢: 1 次
接收感谢: 1 次

Re: 「Adobe Flash Player 官方版」更新腳本

#12

帖子 bobby_winon » 2017-05-23 10:38

我的那台老笔记本有救了,谢谢!
什么是linux,linux就是没有窗户,更没有大门的小黑屋。听说unix是他爹,mac os和ios是他同父异母的兄弟。android、ps、ps2、ps3、ps4和很多超级电脑都关在小黑屋里。我也在里面,不过很快乐!
回复

回到 “其它类Unix OS发行版”