当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : Thinkpad R61 7755 A13 Gusty tribe 5全历程
帖子发表于 : 2007-08-26 22:45 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
今天终于花了几个小时在自己的R61上成功的装好了Gusty tribe 5,下面介绍一下我配置的过程:

现简单介绍一下R61 7755 A13的胖配置:

1. CPU: Intel Core Duo2 7100
2. 显卡: NVIDIA QUADRO NVS 140M
3. 音频: Intel 高保真音频 AD1984 ICH8
4. 网络接口:集成 Intel PRO/1000 千兆以太网卡

1. 刻牒安装
这一步就不需要我复述了,呵呵,直接从官方网下载Gusty tribe 5,用刻录软件刻牒。我安装的时候没有选择使用硬盘安装,因为显卡的问题硬盘安装还有些问题,嘿嘿。刻牒后要注意的是在光碟启动菜单中要选择:
* Start Ubuntu in safe graphics mode
这样使用的是vesa显卡引擎,才能启动Ubuntu,因为tribe 5中的NVIDIA显卡还有个BUG,在显卡配置的时候我会告诉大家

进入Ubuntu LiveCD后的安装步骤和以前一样,这就也不再复述了

2. 安装好后
用LiveCD安装好Ubuntu后,有两样硬件不能完全正常的工作:
1). NVIDIA显卡,虽然能够进入Ubuntu,而且显示很正常,但3D加速并没有能够启动,所以会导致MPlayer无法使用XV播放RMVB等电影。
2). 声卡虽然能够识别,但因为ALSA引擎最新的稳定版本还没有支持到ICH8系列,所以无法发声。

2.1 解决NVIDIA显卡
在网上搜索了很久,发现Ubuntu自带的NVIDIA显卡受限制驱动虽然是最新的NVIDIA显卡驱动100.14.11,但存在一个BUG,就是gusty的linux-modules-restricted中竟然缺少了一个所需的库libwfb.so...
其实解决方法很简单:
代码:
sudo apt-get install nvidia-glx-new

首先安装NVIDIA最新驱动,然后:
代码:
sudo apt-get source nvidia-glx-new
sh linux-restricted-modules-2.6.22-2.6.22.3/nvidia/NVIDIA-Linux-x86-100.14.11-pkg1.run -x
sudo cp NVIDIA-Linux-x86-100.14.11-pkg1/usr/X11R6/lib/modules/libnvidia-wfb.so.100.14.11 /usr/lib/xorg/modules/
sudo ln -s /usr/lib/xorg/modules/libnvidia-wfb.so.100.14.11 /usr/lib/xorg/modules/libwfb.so

其实原理很简单,就是从nvidia-glx-new的源中题取出需要的库。。。

做完以上的准备步骤后,去“系统-》系统管理-》受限制驱动管理器”中将NVIDIA accelerated graphics cards打上钩,最后重启计算机。恩,这样NVIDIA显卡就配置成功了。Compiz可以用了~~~

但是,受限制驱动毕竟是受限制驱动,Thinkpad上的亮度调节按钮就不再有用了。。。

2.2 解决声卡问题
在网上一番搜索之后发现原来国外许多人和我有同样的问题,所以总会有好心人发出一些解决办法,这不,就有人专为此时给ALSA引擎打了个补丁,这里需要自行编译ALSA引擎了,方法如下:
首先安装编译环境:
代码:
sudo apt-get install build-essential

下载ALSA引擎1.0.14,并保存到某个目录,例如:/home/jack
ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.14.tar.bz2
下载补丁:http://forums.fedoraforum.org/attachment.php?s=ad801e299401a0b291e642561a70662c&attachmentid=12630
解压、编译、安装
代码:
cd /home/jack
tar jxvf alsa-driver-1.0.14.tar.bz2
tar zxvf patch_analog.c.tar.gz
cp ./patch_analog.c ./alsa-driver-1.0.14/alsa-kernel/pci/hda/
cd alsa-driver-1.0.14
./configure && sudo make
sudo make install

编辑配置文件:
代码:
sudo gedit /etc/modprobe.d/alsa-base

在最后加入:
代码:
options snd-hda-intel model=thinkpad

重启计算机

如果照样没有声音的话,检查一下声音控制器,看是否静音。此时Thinkpad上的声音控制按钮也可能不工作了,到"系统-》首选项-》音效"中将“默认混音器轨道”改成PCM然后重启即可。


OK,目前我就是这样安装了Gusty Tribe 5,如果有任何问题,我会继续写上来的,也请大家多多指正~~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-26 22:52 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
LZ的动作真快,赞一个


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-26 23:40 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
7.10 中的nvidia-glx-new 显然不同于7.04 的nvidia-glx-new

这样处理的话, 会不会和ubuntu 7.04正式版发布前一样,部分中古显卡出现断层?


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-26 23:47 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
刚才在7.10的源里看了下:

nvidia-glx-new 是100.14.11
nvidia-glx 是10.9639


这样看来,nvidia 7050/7025 nvs 系列 nvidia 8系都可以安装 ubuntu 7.10

直接: 点系统 ---->系统管理------>受限驱动管理----->nvidia 打钩

N卡驱动就可轻松搞定。


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-08-26 23:51 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
skyx 写道:
7.10 中的nvidia-glx-new 显然不同于7.04 的nvidia-glx-new

这样处理的话, 会不会和ubuntu 7.04正式版发布前一样,部分中古显卡出现断层?


具体情况还不太清楚,至少对于我的显卡目前是适用的~是否会断层还不知道……我看到Launchpad上关于这个也正在吵的沸沸扬扬的,不过原因至少找到了,就是这个libwfb.so缺失的问题……Launchpad上还有些其他的PATCH,不过我试了后至少对于我的显卡是不适用的……


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-26 23:53 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
skyx 写道:
刚才在7.10的源里看了下:

nvidia-glx-new 是100.14.11
nvidia-glx 是10.9639


这样看来,nvidia 7050/7025 nvs 系列 nvidia 8系都可以安装 ubuntu 7.10

直接: 点系统 ---->系统管理------>受限驱动管理----->nvidia 打钩

N卡驱动就可轻松搞定。

恩,按理来说是这样,不过竟然缺了个库,所以如果安装nvidia-glx-new的话,还得按我给的方法把这个库手工补上……


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-08-28 19:20 

注册: 2006-12-29 9:39
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
显卡我是自己在官方网站下载的驱动,安上后就可以用。用受限制驱动里面的自动安装就进如不了桌面。我的是T61,显卡和你的一样。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-08-28 22:16 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
lovesite 写道:
显卡我是自己在官方网站下载的驱动,安上后就可以用。用受限制驱动里面的自动安装就进如不了桌面。我的是T61,显卡和你的一样。

我不是说了嘛,呵呵,进不了桌面是因为少了个库啊,目前已经被Launchpad认为是BUG,我已经给出解决办法了啊~~


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-08-29 3:57 

注册: 2006-12-29 9:39
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
楼上的兄弟,桌面特效开最大你用起来卡么??


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-08-29 14:50 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
lovesite 写道:
楼上的兄弟,桌面特效开最大你用起来卡么??

不卡啊~~我把Compiz 3D桌面打开,然后在屏幕上画火焰都挺正常的


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-08-29 17:29 

注册: 2006-12-29 9:39
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
我的用起来就卡,火焰特效没有什么问题,就最大化、最小化、开个菜单什么的就卡,只要有透明的就卡。

不知道是不是和我直接装的驱动有关。你的方法我还没有用,不过7.10现在已经卸载掉了,我等到正式版出来的时候再装。总的来说目前t5还是很不错的,大多数的驱动都支持。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-09-04 12:36 
头像

注册: 2005-10-19 17:33
帖子: 2052
送出感谢: 0 次
接收感谢: 0 次
楼主,最新的更新,声卡问题已经解决了,不用自己去编译alsa了
另外,nvidia驱动对于2D渲染,效率很低。不知道你在浏览多图的网页的时候,是否有问题


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-09-07 20:55 
头像

注册: 2007-06-23 16:56
帖子: 37
地址: China
送出感谢: 0 次
接收感谢: 0 次
等我换了ibm也试试,ibm真是好东西,用手一摸就知道,真舍不得松手。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-09-08 5:41 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
猛将兄 写道:
楼主,最新的更新,声卡问题已经解决了,不用自己去编译alsa了
另外,nvidia驱动对于2D渲染,效率很低。不知道你在浏览多图的网页的时候,是否有问题

我用的NVIDIA驱动还好啊,至少没有明显的感觉到什么问题


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-09-10 20:53 

注册: 2007-09-10 20:47
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
唉, Intel 4965AGN 無線網卡在我的T61上面一直無法使用, 看下面的Thinkwiki也沒用, 請問各位有沒有啥好建議? 多謝!
http://www.thinkwiki.org/wiki/Installing_Ubuntu_7.10_%28Gutsy_Gibbon%29_Tribe_5_on_a_ThinkPad_T61[/url]


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译