ubuntu 7.10网络不稳定

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
zhongyh
帖子: 4
注册时间: 2007-12-30 10:55
送出感谢: 0
接收感谢: 0

ubuntu 7.10网络不稳定

#1

帖子 zhongyh » 2008-01-11 13:27

我的台式机装了ubuntu7.10,发现网络很不稳定,无论是设成静态ip还是动态ip,都经常连接不上网络。
有时可以上internet
有时可以连上局域网,但上不了internet
更多的情况是连不能局域网,更不用说上网(Ping不通局域网)

但切换到xp下面,一切正常,说明硬件和网络本身是好的。
ubuntu7.10的设置应该正确。
同样的设置在xp下的虚拟机上网是很稳定的。

CPU:Intel Pentium Dual E2160 1.8G 双核
主板:Gigabyte 945GCM-S2L,芯片组 Intel i945G/GZ
内存:1G
网卡:Realtek RTL8168/8111
显卡:Intel 82945G
头像
zhongsanakang
帖子: 156
注册时间: 2008-01-02 23:08
送出感谢: 0
接收感谢: 0

重装网卡驱动,并把系统自带的驱动干掉

#2

帖子 zhongsanakang » 2008-01-31 15:08

具体方法google一下
头像
willbill
帖子: 146
注册时间: 2007-08-02 12:18
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 willbill » 2008-03-16 19:24

二楼的,我也很想知道解决办法,你能不能告诉我们看那篇文章?google的文章是在太多了
纳兰千寻
帖子: 33
注册时间: 2008-03-09 19:09
送出感谢: 0
接收感谢: 0

#4

帖子 纳兰千寻 » 2008-03-16 22:15

我的跟你的差不多 系统安装几天了只上过两次网
CPU是2140 其他的都一样



CPU:Intel Pentium Dual E2140 1.6G 双核
主板:Gigabyte 945GCM-S2L,芯片组 Intel i945G/GZ
内存:1G
网卡:Realtek RTL8168/8111
显卡:Intel 82945G
头像
iskate
帖子: 71
注册时间: 2006-07-23 16:04
送出感谢: 0
接收感谢: 0

#5

帖子 iskate » 2008-03-22 19:37

顶一下,我也遇到同样的问题。

电脑启动后,一切正常,可以上网。

用了一段时间,比如一个小时,就上不了网了。无线网卡的灯狂闪,点System Tray里的网络图标,选手动配置,不会出现网络设置的窗口。

更奇怪的是,有一次,出现这个情况以后,我在终端里运行sudo reboot都不行了,没有任何反应。

我的网络配置:
不用漫游模式,手动连接到指定无线路由,WEP128加密,DHCP。
头像
iskate
帖子: 71
注册时间: 2006-07-23 16:04
送出感谢: 0
接收感谢: 0

#6

帖子 iskate » 2008-03-22 19:39

补充一下,PING网关的结果是network unreachable。
X1902
帖子: 1
注册时间: 2008-03-22 17:32
送出感谢: 0
接收感谢: 0

#7

帖子 X1902 » 2008-03-24 16:01

我也是 一时ping的通 一时ping不通 不知道怎么回事
qzlulin
帖子: 4
注册时间: 2008-03-23 0:35
送出感谢: 0
接收感谢: 0

#8

帖子 qzlulin » 2008-03-25 0:04

我的也是, 你们用的是什么无线网卡啊 , 我用的是 “法国 瑞银INVENTEL ur054g”。
xlchenjing
帖子: 12
注册时间: 2008-03-28 17:38
送出感谢: 0
接收感谢: 0

#9

帖子 xlchenjing » 2008-03-28 23:49

google 之后, 有人说 8168/8111 xp 的驱动装了之后(另外vista下的自带驱动倒是没事), 如果没有选择 wake on lan , 那么xp 关机后, 会在主板中(pci slot data?) 那边填入一些数据, 禁用这个网卡, 下次开机再修改配置, 重新启用; linux 的驱动不知道 xp 的驱动做了这些恶心事情, 所以找不到网卡.
开始我还以为是集成网卡有问题
xlchenjing
帖子: 12
注册时间: 2008-03-28 17:38
送出感谢: 0
接收感谢: 0

#10

帖子 xlchenjing » 2008-03-28 23:52

一般情况下,只要在xp下把wake-on-lan after shutdown给enable就行了.

但我无论如何都不行,你们可以试试。
hfwubaoyu
帖子: 7
注册时间: 2008-04-03 19:48
送出感谢: 0
接收感谢: 0

回复

#11

帖子 hfwubaoyu » 2008-04-06 11:13

我的情况也是这样,偶尔可以上网,不知道具体是什么原因?
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#12

帖子 luojie-dune » 2008-04-06 11:34

大家换装 wicd 或者 knetworkmanager 试试。

wicd请自行查询~~~

代码: 全选

sudo apt-get install knetworkmanager



否则可能是设置/驱动问题?
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
ttydy
帖子: 3
注册时间: 2008-03-31 14:54
送出感谢: 0
接收感谢: 0

#13

帖子 ttydy » 2008-04-18 21:06

下一个dnsmasq

sudo apt-get install dnsmasq 就可以了

我的就是这样
回复

回到 “网卡问题以及网络和拨号”