当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 急救啊!電信adsl拔号能ping到,但不能上网(已解决).
帖子发表于 : 2008-01-20 17:07 

注册: 2008-01-20 16:39
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
用pppoeconfig设置拔号成功,可以打开www.google.com和www.baidu.com.cn。
但不能进入其它网站,如http://ubuntu.org.cn/。
真是急坏我了,请过来人帮帮忙。


最后由 sudan 编辑于 2008-01-23 22:27,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-20 17:42 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
cat /etc/resolv.conf
看下dns设置。
adsl的猫支持路由功能的不?


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-20 22:25 

注册: 2008-01-20 16:39
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我用的是电信线路
adsl的猫是:HUAWEI SmartAX MT880b
cat resolv.conf
nameserver 202.96.128.86
nameserver 202.96.128.166

ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:60:6E:35:E4:9E
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:609 errors:52 dropped:26 overruns:18 frame:77
TX packets:522 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:448655 (438.1 KB) TX bytes:56325 (55.0 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1184 (1.1 KB) TX bytes:1184 (1.1 KB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:219.130.46.173 P-t-P:218.16.0.12 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:583 errors:0 dropped:0 overruns:0 frame:0
TX packets:493 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:442705 (432.3 KB) TX bytes:43349 (42.3 KB)


请帮我分析一下,问题是出在哪?谢谢了!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-20 22:33 

注册: 2008-01-20 16:39
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我能ping到www.ubuntu.org.cn

#ping www.ubuntu.org.cn
PING www.ubuntu.org.cn (59.36.101.19) 56(84) bytes of data.
64 bytes from 59.36.101.19: icmp_seq=1 ttl=57 time=39.4 ms
64 bytes from 59.36.101.19: icmp_seq=2 ttl=57 time=42.9 ms

网面状态栏显示:
waiting for www.ubuntu.org.cn

可是google使用一切正常。
有人说是MTU的问题,可我就是不知该如何做.......

#iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

帮我啊!........


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-23 15:45 
头像

注册: 2008-01-12 21:15
帖子: 201
地址: 南昌
送出感谢: 0 次
接收感谢: 0 次
是浏览器问题么?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-23 17:53 

注册: 2008-01-20 16:39
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
www.google.com.cn可以打開,可搜索.浏览器應該沒有問題.
請多多指教!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-23 21:45 

注册: 2008-01-20 16:39
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
2006-11-17 09:40:19
 标签:MTU 概念与设置 

  在网络介质的传输单位中,MTU即一个数据包的最大字节数是有限制的.如果单位超过了网络媒体所能负荷的大小,除非操作系统支持数据包分片,否则数据包无法传递.如果数据包的大小与最大传输单元无法配合,导致数据包传送时不停的进行分片,将导致网络传输效能下降.同时也造成了连接不上某些网站.

所以网卡的MTU设置最好能够针对网络接口进行最优化.

如果客户端无法浏榄某些网站或无法发送邮件,这样的问题常常与MTU的数值不正确有关.一般而言,MTU在网卡(ENTERNET)的默认值为1500,其它的接口如下所示:

PPPoE(ADSL):1492
Dial-up(model):576

默认的网络接口MTU是1500,而PPPoE使用的是1492,MTU的要求不同,所以有些数据无法正确传输.一般调整客户端MTU值,就可以解决这一问题,通过调整MTU,也可以提高网络网络效率.所以这个时候就要修改MTU值

找出MTU值

  由于MTU与Router具有很大的关系,通常在客户端对Router(就是NAT主机,可能是LINUX,也可能是WINDOWS)进行MTU的检测.

Windows系统上的检测
1.进入DOS命令提示符

2.输入ping -f -l <bytes> IP
如:ping -f -l 1500 192.168.1.2

bytes是本机送出去的数据包大小,IP是GateWay的IP,使用-f,所以数据包没有办法重新组合.

如果结果表明出现响应了,就表示这个MTU是可行的,不过建议找出可行的最大MTU值,就可以达到最优的网络传输.

3.MTU值的计算

如ping -f -l 1464 192.168.1.2,找到的数据是数据包的大小,但每个数据包都具有包头,这个包头部分占去28个字节,所以最终的MTU数值其实是:1464+28=1492.

Linux系统检测

在终端输入:ping -c <number> -M do -s <bytes> IP

如果发现数值为1472,那么MTU=1472+28=1500

修改MTU值

windows98

修改注册表:HKEY_Local_Macchine>System>CurrentControlSet>Services>Class>NetTrans>000n
最后一个n是数字,看看下面有没有网卡的相关信息,如果有,在选择的网卡接口后按下"编辑">"新建">"选择新增DWORD值",将新增的项命名为MaxMTM,并右击选择"修改",选中"十进制",输入找到的MTU值,如:1492.

windows 2000
  选择:HKEY_Local_Macchine>System>CurrentControlSet>Services>Tcpip>Parameters>interface
在下面有多个接口,会有一个与网卡设置相同的接口,在选择的网卡接口后按下"编辑">"新建">"选择新增DWORD值",将新增的项命名为MTU,并右击选择"修改",选中"十进制",输入找到的MTU值.

Linux

使用ifconfig加mtu参数即可:
ifconfig eth0 mtu 1500:就可以了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-01-27 20:04 

注册: 2007-12-27 15:53
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
sudan
你改了什么解决了?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-01-29 11:48 

注册: 2008-01-20 16:39
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
kifever
echo mtu 1452 >> /etc/ppp/options
修改/etc/ppp/peers/dsl-provider
# Minimalistic default options file for DSL/PPPoE connections

noipdefault
defaultroute
replacedefaultroute
hide-password
#lcp-echo-interval 30
#lcp-echo-failure 4
noauth
persist
mtu 1492
#persist
#maxfail 0
#holdoff 20
plugin rp-pppoe.so eth0
usepeerdns

把mtu 1492改为1452 就可以了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译