当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享]无法使用CDMA之类无线上网卡的,请进……
帖子发表于 : 2008-02-20 8:46 

注册: 2007-10-26 0:19
帖子: 53
送出感谢: 0 次
接收感谢: 0 次
Ubuntu对这类上网卡的支持还是不错的。
本人使用的是SRT2000U,基本属于杂牌了吧。曾经也为了驱动的问题而烦恼。
不过经过研究,发现解决起来真的是太简单了。
首先进入控制台,输入
代码:
sudo wvdialconf

确认程序是否认出了你的网卡
输入下面的语句
代码:
sudo gedit /etc/wvdial.conf

看看配置文件怎么写的。
如果类似下面的内容,就表示驱动能够支持你的卡了。
代码:
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Baud = 460800
New PPPD = yes
Modem = /dev/ttyACM0


然后就可以修改拨号号码和密码了,如下

代码:
Phone = #777
Password = card
Username = card


保存,退出编辑器。

最后要上网的时候,按Ctrl+Alt+F1(当然,开一个终端窗口也可以,不过,不小心把那个窗口关闭的话,网络就断开了),输入Ubuntu用户名,密码。
提示符出现以后,输入

代码:
sudo wvdial

等显示出IP地址的时候,你就可以按Ctrl+Alt+F7,切换回桌面,自由上网了。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-20 8:59 
头像

注册: 2006-09-23 12:28
帖子: 485
送出感谢: 1
接收感谢: 0 次
mark待用


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-20 12:44 

注册: 2008-02-02 8:20
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
GC85没有被支持,郁闷


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-10 10:14 

注册: 2008-02-14 10:21
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
留下,回去研究。


页首
 用户资料  
 
5 楼 
 文章标题 : 我的是Huawei E220,能解决吗?
帖子发表于 : 2008-03-16 5:00 
头像

注册: 2008-03-13 23:37
帖子: 950
送出感谢: 0 次
接收感谢: 1
我都快要疯了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-10 20:01 

注册: 2008-05-01 6:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
好像并不是单独支持某一种CDMA上网卡,而是支持里面的通用芯片,只要是这种芯片,基本上都能识别,谁能告诉芯片型号是什么?


页首
 用户资料  
 
7 楼 
 文章标题 : 能不能详细一点
帖子发表于 : 2008-06-01 17:30 

注册: 2008-04-13 1:20
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
还是不行

bill@bill-laptop:~$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1
ttyS2<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS2<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS2<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S3


Sorry, no modem was detected! Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDial

If you still have problems, send mail to <wvdial-list@lists.nit.ca>.
bill@bill-laptop:~$


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-01 18:04 
头像

注册: 2006-06-13 11:02
帖子: 431
地址: 广东 广州
送出感谢: 0 次
接收感谢: 0 次
:oops: 我的也不行
Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.


Sorry, no modem was detected! Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDial

If you still have problems, send mail to <wvdial-list@lists.nit.ca>.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-06-01 21:12 
头像

注册: 2007-07-14 20:45
帖子: 756
送出感谢: 50
接收感谢: 17
问个题外的问题,你们的笔记本在安装UBUNTU之后硬盘是否每隔一会就听到卡卡的异声???


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-06-01 22:03 

注册: 2008-04-13 1:20
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
没有楼上所说得现象。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-06-03 14:41 
头像

注册: 2006-06-13 11:02
帖子: 431
地址: 广东 广州
送出感谢: 0 次
接收感谢: 0 次
九天星 写道:
问个题外的问题,你们的笔记本在安装UBUNTU之后硬盘是否每隔一会就听到卡卡的异声???

这个问题,你可以去这里看看:http://forum.ubuntu.org.cn/viewtopic.php?t=115759&sid=26c20541a553f312a977a43fe0125308
我的笔记本也有这个问题,需要用“hdparm -B 254 /dev/你的硬盘”来解决。 :(


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译