当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]ubuntu更新被ISA阻止了
帖子发表于 : 2008-02-26 13:48 
头像

注册: 2008-02-19 22:33
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
我的ubuntu7.1能上网,但是不能更新.我查了一下后发现是被我们公司的ISA防火墙给阻止了.
我们公司的防火墙ip地址:172.20.0.7端口是:8080.我在浏览器里配置一下代理,再输入一下用户名和密码就可以上网了.但不能更新源.
我就是不知道网络怎么配置也能使更新不被阻止.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-26 14:35 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
apt-get的http代理要在系统---首选项--代理中设定

这个我以前用过,是可行的,浏览器中的设定是针对浏览器的


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-26 16:03 
头像

注册: 2008-02-19 22:33
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
我在系统---首选项--代理中设定代理服务器的ip地址和端口,在detail里设置了用户名和密码.但还是更新不了,更新的时候会报错.407 proxy authentication required( the isa server requies authorization to fufill the request, access to the web proxy service is denied)


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-02-26 16:22 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
引用:
A typical error that you will encounter is error 407 Proxy Authentication Required this means that the authentication has been denied because the user has no valid user account in the domain or that the password has been entered incorrectly. The 401 error however displays an unauthorized error message this mean the user permissions to that resource are denied. This error message tells you to look at the ISA server rules not at the way the authentication is handled


设好后,终端要重开,另外,isa 还涉及到域,实在还有问题,可以与网管联系。


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [问题]ubuntu更新被ISA阻止了
帖子发表于 : 2008-10-19 16:15 

注册: 2008-06-13 14:35
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
和网管联系? 请网管吃饭吧。

我的还是8.04 火狐设置完代理没有反应的 根本不弹出什么帐户密码验证
正在积极处理ING


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [问题]ubuntu更新被ISA阻止了
帖子发表于 : 2008-10-22 10:10 

注册: 2008-10-05 16:01
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
see this page, http://www.linuxdiyf.com/viewarticle.php?id=58095

ISA防火墙下的Ubuntu更新
作者: Advanced 发布日期: 2007-9-04 查看数: 464 出自: http://www.linuxdiyf.com
因为公司的一个SP项目需要安装一个Linux的计算机,我便自告奋勇的给那台机器安了个Ubuntu,因为以前用的很顺手。

但是这次是老革命遇到了新问题,因为Linux的系统遇到了Windows的ISA代理服务器,域用户名和密码便无法使用,Ubuntu的更新便成立一件非常头痛的事情,我是用LiveCD装的,虽然安装完了,Desktop用着没有任何问题,但是这是一台工作机器,很多东西,如C库,输入法等都不在默认安装范围,因此如果不能更新,无疑该Ubuntu便和玩具差不多了。

昨天回来一顿猛搜,还真有不知道的哥们碰到过这个问题,林林总总的解决方法几乎只有一个。那就是需要使用代理,但是有个例外那就是Firefox,使用域下面的用户名和密码就能上网,这只能说Firefox这玩意儿太强悍。

下面介绍下,如何在AD域的情况下,顺利更新Ubuntu吧。

工具名称:NTLM authorization Proxy Server v0.9.9
下载地址:http://ntlmaps.sourceforge.net/

它的工具原理是在本地机上开置一个类似代理服务器(proxy-like)的进程,所有的代理请求经过它后就转化为NT的代理,并向NT代理服务器发送请求。

下载之后,执行
$ tar -zxvf ntlmaps-0.9.9

找到server.cfg,修改它
[GENERAL]
LISTEN_PORT:5865 # 本机监听端口
PARENT_PROXY:192.168.0.2 # ISA服务器
PARENT_PROXY_PORT:8080 # ISA服务器端口
PARENT_PROXY_TIMEOUT:15
ALLOW_EXTERNAL_CLIENTS:0
FRIENDLY_IPS:
URL_LOG:0
MAX_CONNECTION_BACKLOG:5
[CLIENT_HEADER]
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/msword, application/vnd.ms-powerpoint, */*
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
[NTLM_AUTH]
NT_HOSTNAME:192.168.0.2 # 主机名
NT_DOMAIN:demo-domain # 域
USER:test# ISA代理的用户名
PASSWORD:test# ISA代理的密码
LM_PART:1
NT_PART:0
NTLM_FLAGS: 06820000
NTLM_TO_BASIC:0
[DEBUG]
DEBUG:0
BIN_DEBUG:0
SCR_DEBUG:0
AUTH_DEBUG:0

配置完后保存,启动main.py:
# python main.py

然后设置需要连接外网的工具的代理地址为127.0.0.1,端口为5865,即可连接外网。

使用新立得包管理的同学,可以更改设置里面的代理服务器,按照上面的填写。

如果使用apt-get update的话需要执行
$ export http_proxy="http://127.0.0.1:5865"

OK,完成。希望这些东西能被baidu或者google收藏,以便更多在公司ISA代理下不能更新Ubuntu的同学查阅到。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [问题]ubuntu更新被ISA阻止了
帖子发表于 : 2008-10-23 13:44 

注册: 2008-06-13 14:35
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
楼上正解


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [问题]ubuntu更新被ISA阻止了
帖子发表于 : 2009-03-03 11:24 

注册: 2009-02-12 19:27
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
linux 在ISA的环境中不好使吗?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译