长时间打不开网页,网络可以发送数据包,但不能接收。

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
d5ghost
帖子: 40
注册时间: 2007-08-29 15:06
送出感谢: 0
接收感谢: 0

长时间打不开网页,网络可以发送数据包,但不能接收。

#1

帖子 d5ghost » 2008-02-29 20:12

问题症状:有时上网上着上着就打不开网页了,重新打开浏览器也无效,流量图没有流量,没有arp表。

暂时解决方法:拔插网线后马上可以打开网页(多试几次)

问题分析:
1.TP-link 8810路由器负载过重
2.ubuntu自身的问题(可能性不大)
3.可能是路由器的arp轮询机制失效

用wireshark抓包发现都是arp请求报文和DNS请求报文

代码: 全选

$sudo wireshark
解决方法:设置网关的静态arp条目(ip地址192.168.1.1, MAC地址:00:14:78:F2:35:B5)

代码: 全选

$sudo arp -s 192.168.1.1 00:14:78:F2:35:B5
查看是否设置成功

代码: 全选

$ arp -v
 地址                       类型     硬件地址            标志  Mask            接口
192.168.1.1              ether   00:14:78:F2:35:B5   CM                    eth0
 
标志多了个M,表示此条目为静态。
如果你感觉这样比较麻烦 也可以使用

代码: 全选

vi /etc/ethers
建立ethers文件其内容为X.X.X.X S:S:S:S:S:S
192.168.1.1 00:14:78:F2:35:B5
保存后
在/etc/rc.local文件中增加一行
arp -f
这样每次开机后 将自动静态绑定你的网关MAC[/code]

很遗憾,上面的方法不能解决问题。ubuntu和xp都一样有问题。

两个月后。。。

后来发现问题依然,偶尔动一下网线有时会掉线,出现问题是网络可以发送数据包,但不能接收,想想应该是网线8条细芯中的某条接触有问题,所以重做了水晶头,问题改善了好多。

水晶头重做后,每天偶尔也会出现一两次,通过拔插网线可以恢复,所以怀疑是TP-LINK的402M SOHO路由器有问题,上次莫名其妙就是不能登录web界面,今天把里面的软件版本从070201升级到070605。

现在一些看起来很正常。。。
随后试用还是不正常,当开bt或者长时间下载时,问题依旧存在。。。

一个月后的现在,买了一个motorala的无线路由器W850G(200MHz的CPU),固件是DD-WRT V24, 接到tp-link的402m后面当交换机用,试用了两周,一切正常的不得了。

现在应该可以断定:问题出现在tp-link上面,它不稳定。
上次由 d5ghost 在 2008-04-30 17:23,总共编辑 2 次。
ASUS A6NE( Intel Pentium-M Dothan 1.5GHz,256*2 DDR,2MB Cache)
OS:ubuntu Linux 8.04
djd
帖子: 9
注册时间: 2008-02-05 16:57
送出感谢: 0
接收感谢: 0

#2

帖子 djd » 2008-03-01 17:29

我先来试试吧 :D
回复

回到 “网卡问题以及网络和拨号”