当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]Linux下SigmaTel声卡不能用~~~请大家帮忙,感激不尽!
帖子发表于 : 2008-03-12 12:58 

注册: 2008-03-09 0:13
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我的电脑是Dell Inspiron 1520 的
用的是SigmaTel High Definition Audio Codec的声卡
但是无论是安装Ubuntu 7.10 还是 从linux.dell.com/wiki/上下载的Ubuntu7.10
都不能识别我的声卡
希望给为大虾们有谁能帮助我这个菜鸟下
我将感激不尽~~~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-13 2:25 

注册: 2006-05-20 0:41
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
是STAC92xx芯片吧?
比较新的alsa支持,比如1.0.14以后的版本。
不过7.10上似乎有问题,曾见过ubuntu英文论坛中有人问过同样的问题。
尝试直接使用alsa 1.0.16。见如下地址。
http://www.alsa-project.org/main/index.php/Main_Page


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-14 0:18 

注册: 2008-03-09 0:13
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
不行啊朋友~~~

真是伤心

Ubuntu 8.04支持不支持我的声卡啊?


[先去ALSA的官方网站将最新的驱动下载下来

http://www.alsa-project.org/main/index.php/Main_Page

alsa-driver-1.0.16 ftp://ftp.alsa-project.org/pub/driver/a ... 16.tar.bz2
alsa-lib-1.0.16 ftp://ftp.alsa-project.org/pub/lib/alsa ... 16.tar.bz2
alsa-utils-1.0.16 ftp://ftp.alsa-project.org/pub/utils/al ... 16.tar.bz2

将下载的文件放置在/home/"youname"/downloads目录下

先执行下面的命令,确保下面的驱动都能编译过去

代码:
sudo aptitude install build-essential libncurses-dev gettext linux-headers-`uname -r`
sudo apt-get install libncurses5-dev


一步一步执行下面的命令

代码:
sudo mkdir -p /usr/src/alsa
cd /usr/src/alsa
sudo cp ~/downloads/alsa* .
sudo tar xjf alsa-driver*.bz2
sudo tar xjf alsa-lib*.tar.bz2
sudo tar xjf alsa-utils*.tar.bz2


现在开始编译alsa-driver
代码:
cd alsa-driver*
sudo ./configure --with-cards=hda-intel
sudo make
sudo make install


编译alsa-lib
代码:
cd ../alsa-lib*
sudo ./configure
sudo make
sudo make install


编译alsa-utils
代码:
cd ../alsa-utils*
sudo ./configure
sudo make
sudo make install


添加 /etc/modprobe.d/sound 文件,内容为:
alias snd-card-0 snd-MODULE_NAME
alias sound-slot-0 snd-MODULE_NAME
比如我的就是:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

在 /etc/modprobe.d/alsa-base 中最后一行添加:
options snd-MODULE_NAME model=MODEL_NAME
比如我的就是:
options snd-hda-intel model=dell-m44
方括号里的是我引用的另一个网友的方案,但是还是不行阿


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-14 9:35 

注册: 2006-05-20 0:41
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
你安装的alsa-utils包中有个工具alsaconf运行试试看,能不找到你的声卡。如果能找到,应该就没有问题,可以支持。
也可以尝试用最新的kernel,直接使用其中代的alsa驱动。alsa工具应该系统里面有。你看看有没有alsamix或者alsactl等等工具。
如果不开发其实alsa-lib都没有必要下了。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-17 15:25 

注册: 2008-03-05 12:16
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我得笔记本是sony的SZ22,声卡就是SigmaTel 的STAC92系列的。装上ubuntu7.10声卡就能用,也不用设置。而且笔记本的快捷键也能用。试了试,亮度,声音都能调整。用suse10.3,红旗6.0就不成。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-17 16:05 

注册: 2006-07-28 8:51
帖子: 407
送出感谢: 0 次
接收感谢: 0 次
安装linux-backproted内核,也可以解决这个问题,


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译