(解决了)加载了网卡驱动,但网卡不能点亮

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
头像
percy
帖子: 508
注册时间: 2006-09-10 8:19
系统: Gentoo/Mac OS X
来自: Shanghai,China
送出感谢: 0
接收感谢: 0
联系:

(解决了)加载了网卡驱动,但网卡不能点亮

#1

帖子 percy » 2008-03-26 20:48

刚装好的8.04,手动加载了网卡驱动8139cp,8139too,
用ifconfig可以看到网卡的配置,有eth0项,但就是上不了网,网卡后面的灯也不能点亮,是什么原因来,有谁知道吗?
(当手动将网卡模块删除后,就没有eth0项了,能不能说明此时网卡驱动已经安装了呢?)
难道是8.04的一个BUG,以前装7.10的时候,没有这个问题,装上就能用了。
谢谢~!@!~ :em52 :em68



下面是ifconfig信息
手动配置了IP地址

代码: 全选

 cat /media/disk/ifconfig.txt 
eth0      Link encap:Ethernet  HWaddr 00:e0:a0:10:44:1a  
          inet addr:10.0.1.175  Bcast:10.0.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2e0:a0ff:fe10:441a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:19 Base address:0xcc00 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:820 errors:0 dropped:0 overruns:0 frame:0
          TX packets:820 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:41152 (40.1 KB)  TX bytes:41152 (40.1 KB)

这里也有类似问题
viewtopic.php?p=640947

看到一种解决方法
照那样做,问题解决了,看来是XP系统安装盘的问题,以前没有这个问题的

viewtopic.php?t=72737

http://autumncat.blog.ubuntu.org.cn/200 ... l81688111/
上次由 percy 在 2008-03-26 21:28,总共编辑 8 次。
ljbjnh
帖子: 1
注册时间: 2007-04-06 13:16
送出感谢: 0
接收感谢: 0

ifconfig

#2

帖子 ljbjnh » 2008-03-26 20:53

eth0 Link encap:Ethernet HWaddr 00:0C:29:86:14:65
inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe86:1465/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:13277 errors:0 dropped:0 overruns:0 frame:0
TX packets:13673 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:15278344 (14.5 MiB) TX bytes:1551596 (1.4 MiB)
Interrupt:169 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:11 errors:0 dropped:0 overruns:0 frame:0
TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:572 (572.0 b) TX bytes:572 (572.0 b)

ljbjnh@jh-desktop:~$
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2008-03-26 20:58

搜索一下, 是不是xp的设置问题
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
percy
帖子: 508
注册时间: 2006-09-10 8:19
系统: Gentoo/Mac OS X
来自: Shanghai,China
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 percy » 2008-03-26 21:00

BigSnake.NET 写了:搜索一下, 是不是xp的设置问题
XP没问题啊,在XP下可以正常上网的啊
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 BigSnake.NET » 2008-03-26 21:03

percy 写了:
BigSnake.NET 写了:搜索一下, 是不是xp的设置问题
XP没问题啊,在XP下可以正常上网的啊
8139 的xp驱动默认会关机时禁用网卡, 导致Linux用不了
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
percy
帖子: 508
注册时间: 2006-09-10 8:19
系统: Gentoo/Mac OS X
来自: Shanghai,China
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 percy » 2008-03-26 21:05

BigSnake.NET 写了:
percy 写了:
BigSnake.NET 写了:搜索一下, 是不是xp的设置问题
XP没问题啊,在XP下可以正常上网的啊
8139 的xp驱动默认会关机时禁用网卡, 导致Linux用不了
那要怎么设置呢?
以前7.04都是没问题的啊
with0out
帖子: 3
注册时间: 2006-07-16 9:37
送出感谢: 0
接收感谢: 0

#7

帖子 with0out » 2008-06-14 14:15

8139没wake on lan选项啊...难道要升级驱动?
with0out
帖子: 3
注册时间: 2006-07-16 9:37
送出感谢: 0
接收感谢: 0

#8

帖子 with0out » 2008-06-14 21:11

well...
now everything is ok,since i updated the driver in xp and changed the function "wake on lan" to enable.
thanks gays :)
头像
drvicar
帖子: 1285
注册时间: 2007-12-17 18:07
来自: 西安
送出感谢: 1 次
接收感谢: 1 次
联系:

#9

帖子 drvicar » 2008-06-19 20:02

:roll: 回去看下 我的 我的也是只能认到lo!
jinlintu
帖子: 2
注册时间: 2008-07-13 12:03
送出感谢: 0
接收感谢: 0

#10

帖子 jinlintu » 2008-07-13 12:08

BigSnake.NET 写了:
percy 写了:
BigSnake.NET 写了:搜索一下, 是不是xp的设置问题
XP没问题啊,在XP下可以正常上网的啊
8139 的xp驱动默认会关机时禁用网卡, 导致Linux用不了
我INTEL810的主板,USB ADSL的猫,在XP下正常上网,装了UBUNTU8.04网卡找不到,楼主说的XP默认怎么改呀,等回复.
wxj120bw
帖子: 24
注册时间: 2008-08-26 23:29
送出感谢: 0
接收感谢: 0

ubuntu8.04因XP驱动更改网卡而无法上网的解决办法

#11

帖子 wxj120bw » 2008-09-16 1:01

本人网卡是RTL8139/810x 本人先升级下网卡驱动 网卡驱动下载地址:ftp://file6.mydrivers.com/net/realtek_8 ... uto_xp.zip
此驱动安装号后 在网卡的高级选项卡中有了wake-on-lan after shutdown选项 选择右面下拉框 选中“enable” 再进入ubuntu8.04系统就能上网了
本人已测过
似水流年
帖子: 9
注册时间: 2008-08-11 21:56
送出感谢: 0
接收感谢: 0

#12

帖子 似水流年 » 2008-09-16 19:43

我的网卡同上8139,但是这些方法没有奏效,到底什么原因?
在网卡的电源管理中“允许这台计算关闭此设备以节约电源”划了对号,这有问题吗?
biloba
帖子: 3
注册时间: 2008-09-19 22:11
送出感谢: 0
接收感谢: 0

#13

帖子 biloba » 2008-09-19 22:39

我装的是ubuntu 8.04和xp双系统,xp下上网正常。可是不管怎么设置,ubuntu下都上不了网,网卡的灯也不亮,好像网卡没有识别出来。更奇怪的是,只要我一转到ubuntu,办公室内所有的电脑都没法上网了。但是我启动xp后,大家又都能上网了。弄得大家都怪 我捣蛋。我们是校园网,内网静态IP。办公室几个电脑通过一个hub上网。接到这个hub上的电脑全部用的是xp,上网都正常。只要我一启动ubuntu,大家的网就全断了。我的网卡还是不亮灯。但是别的办公室电脑不受影响。我弄了两周了,一直就是这样。请高人给指点指点,到底是什么原因。
wxj120bw
帖子: 24
注册时间: 2008-08-26 23:29
送出感谢: 0
接收感谢: 0

Re: 跟那个没关系

#14

帖子 wxj120bw » 2008-09-21 22:05

似水流年 写了:我的网卡同上8139,但是这些方法没有奏效,到底什么原因?
在网卡的电源管理中“允许这台计算关闭此设备以节约电源”划了对号,这有问题吗?
跟那个没有关系 那个是待机或者休眠时候 关掉网卡的电源 你再试下我的方法 网上差不多都是这个方法
wxj120bw
帖子: 24
注册时间: 2008-08-26 23:29
送出感谢: 0
接收感谢: 0

Re:

#15

帖子 wxj120bw » 2008-09-21 22:12

biloba 写了:我装的是ubuntu 8.04和xp双系统,xp下上网正常。可是不管怎么设置,ubuntu下都上不了网,网卡的灯也不亮,好像网卡没有识别出来。更奇怪的是,只要我一转到ubuntu,办公室内所有的电脑都没法上网了。但是我启动xp后,大家又都能上网了。弄得大家都怪 我捣蛋。我们是校园网,内网静态IP。办公室几个电脑通过一个hub上网。接到这个hub上的电脑全部用的是xp,上网都正常。只要我一启动ubuntu,大家的网就全断了。我的网卡还是不亮灯。但是别的办公室电脑不受影响。我弄了两周了,一直就是这样。请高人给指点指点,到底是什么原因。
很有意思的情况 请问 hub是不是集线器 还是交换机后者路由器 若是集线器 有可能有这种情况 若不是 还是你的网卡是8139之类的 没有wake on lan after shutdown 这个选项 等待你下次回复
回复

回到 “网卡问题以及网络和拨号”