当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]请教关于XP下用vmware虚拟ubuntu局域网内不能上网的问题
帖子发表于 : 2008-05-07 17:19 

注册: 2007-12-19 16:26
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
搜索了一天,还是无法解决这个问题
我的系统是:winXP pro SP2
VM是下载这个来安装的:VMware-workstation-e.x.p-84113.exe
ubuntu是:ubuntu-8.04-desktop-i386.iso

本机有两张网卡,具体情况是这样(不知道怎么贴图):
C:\Documents and Settings\Administrator>ipconfig

Windows IP Configuration


Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.231.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.23.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter 内网:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 10.73.0.119
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.73.0.77

Ethernet adapter 外网:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.1.156
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1


按照论坛上很多方法设置都不能上网,本人很菜,有高人请耐心打点一下


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-07 17:58 

注册: 2008-03-27 13:20
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
要确定在vmware中,虚拟的那块网卡是怎么设置的。桥接?NAT?或者是HOST-ONLY


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-08 8:24 

注册: 2007-12-19 16:26
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
桥接试过,NAT也试过


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-08 8:33 

注册: 2007-12-19 16:26
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
用Bridged这种方式,我将虚拟系统的IP设置成与本机系统在同一网段
IP Address. . . . . . . . . . . . : 192.168.1.157
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
也不知道设置得对不对,DNS也和XP一样,这样不行,删了DNS也不行


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-08 9:23 

注册: 2007-12-19 16:26
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
:oops: 问题已解决,在虚拟机的edit->virtual network settings->host virtual network mapping里把vmnet0选成可以上宽带的那个网卡就可以了(原来是自动选择),也不知道是为什么,现在的是问题是虚拟系统ubuntu不像主那样可以访问两个局域网,而只能访问一个局域网(就是可以联结因特网那个),另一个的无法访问,这是个头疼的问题,不过能够上外网我就已经很高兴了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译