当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]HELP!! 8.04下无线网卡不工作
帖子发表于 : 2008-05-10 8:45 

注册: 2008-05-10 8:36
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
1.我的安装版本是8.04,内核为2.6.24-16-generic
2.系统可以找到无线网卡,指示灯也正常亮,用笔记本快捷键开启关闭无线网卡都有反应,但就是搜索不到无线信号, 用漫游模式也不行。
3.有线上网正常,在XP下无线上网也正常
4.我的无线网卡型号: Intel(R) PRO/Wireless 3945BG Network Connection
小弟十是个新手,麻烦高手解决我的问题,郁闷中。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-10 16:00 
头像

注册: 2007-02-14 13:54
帖子: 308
送出感谢: 0 次
接收感谢: 0 次
我的好像更惨,iwconfig 只显示
代码:
lo        no wireless extensions.

eth0      no wireless extensions

用 lshw 可以看到
代码:
...
*-network
                description: Network controller
                product: PRO/Wireless 3945ABG Network Connection
                vendor: Intel Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: 02
                width: 32 bits
                clock: 33MHz
                capabilities: bus_master cap_list
                configuration: driver=iwl3945 latency=0 module=iwl3945
...

用 lsmod 检查模块显示:
代码:
...
iwl3945               100468  0
iwlwifi_mac80211      251876  1 iwl3945
...

请问我该怎么办啊 :(


最后由 sense 编辑于 2008-05-10 16:03,总共编辑了 1 次

页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-10 16:02 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
先确认有无线网可用


_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-10 16:06 
头像

注册: 2007-02-14 13:54
帖子: 308
送出感谢: 0 次
接收感谢: 0 次
RegentW 写道:
先确认有无线网可用

我的是没有无线网络,但就算没有无线网络,用 iwconfig 应该不仅仅显示
代码:
lo        no wireless extensions.

eth0      no wireless extensions.

:(


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-11 12:08 
头像

注册: 2007-05-06 8:19
帖子: 7433
送出感谢: 0 次
接收感谢: 4
确认了,7.10那边就ok,都不敢说vista了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-11 12:12 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
我的dell vostro 1500也是这个网卡,7.10要受限驱动,现在8.04不用了,直接连上没有问题。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-11 14:02 

注册: 2008-01-19 15:10
帖子: 114
送出感谢: 0 次
接收感谢: 0 次
我的搞定了。
装上驱动就搞定了,但是经常断,有点郁闷。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-11 17:30 
头像

注册: 2006-09-23 12:28
帖子: 485
送出感谢: 1
接收感谢: 0 次
代码:
modprobe -r iwl3945


代码:
modprobe iwl3945


代码:
ifconfig wlan0  up


在 /etc/modprobe.d/下创建iwl3945文件, 文件内写入以下内容:
引用:
alias wlan0 iwl3945
options iwl3945 disable_hw_scan=1


重启计算机。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-18 14:37 

注册: 2008-05-10 8:36
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
顶一个


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译