当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : madwifi make 问题
帖子发表于 : 2008-05-29 0:10 

注册: 2008-04-05 11:05
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
dury@Lottop:~/madwifi-0.9.4$ cd /usr/src/
dury@Lottop:/usr/src$ ll
total 8
drwxr-xr-x 20 root root 4096 2008-05-28 23:40 linux-headers-2.6.24-16
drwxr-xr-x 6 root root 4096 2008-05-28 23:40 linux-headers-2.6.24-16-server
dury@Lottop:/usr/src$ cd /home/dury/madwifi-0.9.4/
dury@Lottop:~/madwifi-0.9.4$ make KERNELPATH=/usr/src/linux-headers-2.6.24-16
./kernelversion.c:13:30: error: linux/utsrelease.h: No such file or directory
Makefile.inc:91: *** KERNELCONF: /usr/src/linux-headers-2.6.24-16/.config does not exist.. Stop.

这是什么问题?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-29 0:20 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
指定内核版本编译?那还不如用老内核呢。
比如 2.6.22-14-generic

或者 sudo aptitude install linux-headers-2.6.24-16-generic


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-29 10:32 

注册: 2008-04-05 11:05
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
sudo aptitude install linux-headers-2.6.24-16-generic
后 make KERNELPATH=/usr/src/linux-headers-2.6.24-16-generic/
make install
都正常可是 sudo modprobe ath_pci
WARNING: Error inserting ath_hal (/lib/modules/2.6.24-16-server/net/ath_hal.ko): Invalid module format
WARNING: Error inserting wlan (/lib/modules/2.6.24-16-server/net/wlan.ko): Invalid module format
FATAL: Error inserting ath_pci (/lib/modules/2.6.24-16-server/net/ath_pci.ko): Invalid module format
怎么办?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译