当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : thinkpadt40网卡问题,不能开启(激活、启动)电源
帖子发表于 : 2008-06-04 12:24 

注册: 2008-05-26 11:34
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
引用:
yu@YYC:~$ iwconfig ath0
ath0 IEEE 802.11g ESSID:"" Nickname:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:17 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=0/70 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:5060 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


以前也装过这个系统,当时可以用Fn+F5开启/关闭,最近加装了个内置蓝牙,结果只能开关蓝牙,而无线网卡一点动静都没有。
请教:如何打开该网卡的电源呢?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-09 2:30 

注册: 2008-05-26 11:34
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
用以下两个命令显示出的信息:

代码:
root@YYC:~# lspci -v
     -----
     -----
     -----
02:02.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)
   Subsystem: AMBIT Microsystem Corp. ThinkPad 11b/g Wireless LAN Mini PCI Adapter
   Flags: bus master, medium devsel, latency 168, IRQ 11
   Memory at c0200000 (32-bit, non-prefetchable) [size=64K]
   Capabilities: [44] Power Management version 2

02:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet Controller (rev 81)
   Subsystem: IBM ThinkPad R40
   Flags: bus master, medium devsel, latency 66, IRQ 11
   Memory at c0210000 (32-bit, non-prefetchable) [size=4K]
   I/O ports at 8000 [size=64]
   Capabilities: [dc] Power Management version 2



代码:
root@YYC:~# lshw
     -----
     -----
     -----
           *-network:0
                description: Wireless interface
                product: AR5212/AR5213 Multiprotocol MAC/baseband processor
                vendor: Atheros Communications Inc.
                physical id: 2
                bus info: pci@0000:02:02.0
                logical name: wifi0
                version: 01
                serial: 00:11:f5:2c:b5:58
                width: 32 bits
                clock: 33MHz
                capabilities: pm bus_master cap_list logical ethernet physical wireless
                configuration: broadcast=yes driver=ath_pci latency=168 maxlatency=28 mingnt=10 module=ath_pci multicast=yes wireless=IEEE 802.11g
           *-network:1
                description: Ethernet interface
                product: 82801DB PRO/100 VE (MOB) Ethernet Controller
                vendor: Intel Corporation
                physical id: 8
                bus info: pci@0000:02:08.0
                logical name: eth0
                version: 81
                serial: 00:0d:60:37:74:20
                size: 10MB/s
                capacity: 100MB/s
                width: 32 bits
                clock: 33MHz
                capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
                configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.23-k4-NAPI duplex=half firmware=N/A latency=66 link=no maxlatency=56 mingnt=8 module=e100 multicast=yes port=MII speed=10MB/s


root@YYC:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:""  Nickname:""
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power:17 dBm   Sensitivity=1/1 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/70  Signal level=-95 dBm  Noise level=-95 dBm
          Rx invalid nwid:28  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0



本站wiki上的提示:
引用:
Driver looks ok, device disabled
Newer laptops come with features to disable the wireless radio to save battery when not in use. Usually
this is switched by a FN+Fx key combo or specific button for the purpose. It is possible driver and
everything is ok but the wireless device is in the disabled state and can't be used. Using the designated
key(s) in linux sometimes does not work. Usually this is apparent by running the lshw lshw command
you see *-network:1 DISABLED or wireless=radio off, or if you run the iwconfig iwconfig
command you see eth1 NOT READY!. So how do you rectify this? It varies so much the exact solution
can't be put here in this document for all the different models. So...
1. Look at the Ubuntu:LaptopTestingTeam page on the team wiki to see if your laptop is listed with
any information.
2. Do a google search using terms such as manufacture, model, linux, wireless, enable, button,
radio....etc. When searching and finding similar pages that don't help, use words that are used in
those pages to help you search.
3. Go to the ubuntu forums and ask, maybe someone else has the same laptop and knows the work
around.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译