当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求高手帮帮忙,EXPRESS接口的EDGE/GPRS的无线网卡如何设置上网?我已经列出相关代码
帖子发表于 : 2008-06-26 14:28 

注册: 2008-05-17 8:53
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
求高手帮帮忙,EXPRESS接口的EDGE/GPRS的无线网卡如何设置上网?

我冒着不怕XP崩溃的危险,去网吧下了ubuntu8.04中文版经过两次安装终于成功。我想设置我的EXPRESS接口的EDGE/GPRS的无线网卡上网,用论坛里面介绍手机上网的方式,发现行不通,估计是设置时硬件没有找到的原因吧,希望高手帮帮忙。告诉我具体该怎么做。我爱死Ubuntu了,3D效果很漂亮。

先对您的辛苦表示感谢。我正在苦苦等待

首先运行终端,sudo wvdialconf,
看系统能否识别网卡的驱动。
成功识别的话显示信息如下:
yjp0126@yjp0126-laptop:~$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- NEXPERIA SY.SOL 5209
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Modem configuration written to /etc/wvdial.conf.
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"


上面是检测成功,并且把网卡的相关信息保存在了/etc/wvdial.conf里,然后我们编辑它,
sudo gedit /etc/wvdial.conf

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
; Phone = <Target Phone Number>
ISDN = 0
; Password = <Your Password>
New PPPD = yes
; Username = <Your Login Name>
Modem = /dev/ttyACM0
Baud = 460800

修改完成后,使用
sudo wvdial
显示如下信息:
yjp0126@yjp0126-laptop:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Configuration does not specify a valid phone number.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.


看了这些东西我知道失败了,求高手告诉我/etc/wvdial.conf里怎么改?
然后在网络里面啥玩意也没有,Ubuntu毕竟不是XP,高手看了文章后知道怎么回事的一定要告诉我啊
再次感谢~~~ :x


页首
 用户资料  
 
2 楼 
 文章标题 : 我也需要这个驱动
帖子发表于 : 2008-09-11 10:18 
头像

注册: 2005-10-01 21:38
帖子: 964
地址: 湖南邵东流光岭
送出感谢: 0 次
接收感谢: 0 次
我的无线网卡,是express接口的T型口,不知道要用什么驱动啊?难道express接口就只有中国人用吗?如果国际普遍用的,不可能会没有驱动啊。


_________________
小江恩的博客
http://gann.blog.ifeng.com/


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译