无线网卡,配置各种正确却不好用,没招了,Help

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
zongtongyi
帖子: 3
注册时间: 2008-09-18 11:26
送出感谢: 0
接收感谢: 0

无线网卡,配置各种正确却不好用,没招了,Help

#1

帖子 zongtongyi » 2008-09-18 22:24

将无线网卡按网上的方法驱动了,驱动是直接从Windows系统文件夹里拷贝出来的。也使用modprode ndiswrapper加载了模块,使用wifi-radar等无线搜索工具能搜索到家里的无线网络,信号强度,名称都能显示。IP、网关、DNS等配置都正确,并且与Windows的相同。

但是我的无线网卡就是连接不上。
无法ping网关和DNS,更不能连接外网。

系统是Ubuntu 8.04.1

/etc/network/interface的内容为

代码: 全选

auto lo
iface lo inet loopback


iface wlan0 inet static
address 192.168.1.96
netmask 255.255.255.0
gateway 192.168.1.1
wireless-essid TP-LINK

auto wlan0

iface eth0 inet static
address 192.168.1.97
netmask 255.255.255.0
gateway 192.168.1.1

auto eth0
以前装FC9,驱动好后就可以上了。

这该如何是好?
上次由 zongtongyi 在 2008-09-18 22:34,总共编辑 1 次。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2008-09-18 22:33

难道最近都中风了?最近帖子提到mtu的事情。
你找找。

可没道理ping不到网关哦。
你iwconfig看下,连接了没哦。
● 鸣学
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 想入非非 » 2008-09-18 22:41

对无线网失望了。。。 :oops:
Ubuntu User
zongtongyi
帖子: 3
注册时间: 2008-09-18 11:26
送出感谢: 0
接收感谢: 0

#4

帖子 zongtongyi » 2008-09-18 22:57

好用了。

刚才又搞了搞,没有什么实际动作。刚开始的时候用KWiFiManager查看,能看到各无线网落和信号强度,但是没有链接到任何无线网络,后来不知怎么搞的,显示连接到TP_LINK网络,信号较好,但是ping 192.168.1.1会失败,然后我把有线网卡禁用掉了,能ping通,并且能上外网了。

我再弄弄,希望能找到可操作的手顺。
zongtongyi
帖子: 3
注册时间: 2008-09-18 11:26
送出感谢: 0
接收感谢: 0

#5

帖子 zongtongyi » 2008-09-18 23:02

没的搞了。

现在进Ubuntu就能上网了。

唯一能记住的动作就是把有线网卡的配置关掉了。

现在在Ubuntu下上论坛。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2008-09-18 23:20

~~~~~~~~~~~乌龙了。
● 鸣学
回复

回到 “网卡问题以及网络和拨号”