ubuntu8.04网卡设置问题

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
头像
artofegg
帖子: 21
注册时间: 2006-10-09 11:29
来自: 天津
送出感谢: 0
接收感谢: 0
联系:

ubuntu8.04网卡设置问题

#1

帖子 artofegg » 2008-09-26 1:02

安装之后我设置网络为静态IP:192.168.1.2,网关和DNS也全部设置好了,启动网络可以正常上网

但是我重启电脑之后,我的网络又变成了漫游模式

使用ifconfig查看发现,之前的eth0不见了,现在变成了eth1

再重启变成了eth2,每次重启增加1

网络默认回到了漫游模式

请问这是什么原因,如何解决?
上次由 artofegg 在 2008-09-30 23:54,总共编辑 1 次。
头像
artofegg
帖子: 21
注册时间: 2006-10-09 11:29
来自: 天津
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04网卡设置问题

#2

帖子 artofegg » 2008-09-30 23:26

没人碰到这种情况么?
c61的板子,集成网卡
coolhty
帖子: 174
注册时间: 2008-09-23 19:40
送出感谢: 2 次
接收感谢: 0

Re: ubuntu8.04网卡设置问题

#3

帖子 coolhty » 2008-09-30 23:36

只要能上网就行,漫游模式有什么不好吗?我用的漫游模式,网速和XP的差不多啊。
头像
artofegg
帖子: 21
注册时间: 2006-10-09 11:29
来自: 天津
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04网卡设置问题

#4

帖子 artofegg » 2008-09-30 23:50

我电脑连着路由,一定要设置静态ip和网关才行
头像
fouvy
帖子: 32
注册时间: 2008-09-29 3:23
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04网卡设置问题

#5

帖子 fouvy » 2008-10-02 1:18

用sudo ifconfig eth0 0.0.0.0试试

5.系统—>系统管理—>网络

设置静态IP,子网掩码,默认网关(在刚装完系统的时候,都是英文的,具体是什么忘了)


//好像还有个过程,记得不大清楚了,昨天试了好多次,都乱掉了

// ifconfig eth0 刚才设置的静态IP

-----------------------------------------

晚了,早点休息silencefree

---------------------------------
论坛网速的速度太慢了....每次都让我想起ubuntu系统
我的博客
Ubuntu交流群:60345539
头像
artofegg
帖子: 21
注册时间: 2006-10-09 11:29
来自: 天津
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04网卡设置问题

#6

帖子 artofegg » 2008-10-05 0:24

多谢兄台热心相助
设置ip没有问题,只是重启后就失效了

代码: 全选

auto lo
iface lo inet loopback



iface eth27 inet static
address 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1

auto eth27

iface eth28 inet static
address 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1

auto eth28

iface eth31 inet static
address 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1

auto eth31

iface eth32 inet static
address 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1

auto eth32
这是我的/etc/network/interfaces文件... eth的设备号已经累加到32了
头像
fouvy
帖子: 32
注册时间: 2008-09-29 3:23
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04网卡设置问题

#7

帖子 fouvy » 2008-10-05 2:26

#这是我的那个文件

auto lo
iface lo inet loopback


iface eth0 inet static
address 198.168.1.2
netmask 255.255.255.0
gateway 198.168.1.1

auto eth0

#我想你的那个文件里每次在都会增加一个eth(注意我上面的那两个粗体字eth0)
#我建议你按着我的这个修改一下试试。
#修改时你可能会保存不了,所以现在命令窗口输入
sudo nautilus
#这时会弹出一个窗口,(你是用root的权限浏览文件)。在这个窗口中找到那个文件修改后就可以保存了。
#我在网络设置中没有勾选启用漫游模式
#到时候看有什么问题。
论坛网速的速度太慢了....每次都让我想起ubuntu系统
我的博客
Ubuntu交流群:60345539
头像
artofegg
帖子: 21
注册时间: 2006-10-09 11:29
来自: 天津
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04网卡设置问题

#8

帖子 artofegg » 2008-10-06 22:10

我以前试过,自己写成eth0的后果就是没有网络设备,系统每次重启都会把eth设备号加1,这也是每次ip设置都丢失的原因
回复

回到 “网卡问题以及网络和拨号”