当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : vpnc未编译openssl的问题
帖子发表于 : 2008-10-03 10:12 
头像

注册: 2008-08-21 8:00
帖子: 11
地址: Hong Kong
送出感谢: 0 次
接收感谢: 0 次
因为要连接香港大学的vpn,所以需要vpnc。
但是配置好了以后,用 vpnc-connect 连接时候,报错:
代码:
vpnc-connect was built without openssl: Can't do hybrid or cert mode.

请问这个问题应该如何解决?
是不是只能使用vpnc?

另外,我尝试了下载vpnc的源码自己编译,步骤是(采用的方法自 http://ubuntuforums.org/showthread.php?t=812381):
1. 下载vpnc-0.5.1.tar.gz
2. 解压缩
3. 去到解压后的文件夹
4. sudo apt-get build-dep vpnc (这步没有懂什么意思……)
5. sudo dpkg-buildpackage -rfakeroot
出现如下信息:
代码:
breakds@AzraelPlanet:~/incoming/vpnc-0.5.1$ dpkg-buildpackage -rfakeroot
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value:
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
tail: cannot open `debian/changelog' for reading: No such file or directory
dpkg-buildpackage: failure: tail of debian/changelog gave error exit status 1

望有人能够答复。 many thanks.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: vpnc未编译openssl的问题
帖子发表于 : 2008-10-03 11:42 
头像

注册: 2008-08-21 8:00
帖子: 11
地址: Hong Kong
送出感谢: 0 次
接收感谢: 0 次
关于后面那个问题我知道了。 因为我没有使用apt-get source来获得源,所以缺少好几个文件。 之后就可以了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译