当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-19 10:07 
头像

注册: 2007-10-25 20:24
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
大家帮我看看,到底是什么问题,我都整了两天了,网上找了很多资料,都没法解决。
这是我的 /etc/network/interfaces 文件内容
代码:
auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.2.11
netmask 255.255.255.0
gateway 192.168.2.1


iface wifi0 inet static
address 192.168.2.11
netmask 255.255.255.0
gateway 192.168.2.1
wireless-key restricted 362880BBBB
wireless-essid TP-LINK

auto wifi0

iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider

auto eth0


这是我用iwconfig命令看到的结果
代码:
linphy@linphy-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     IEEE 802.11b  ESSID:"TP-LINK"  Nickname:""
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:1D:0F:59:A4:A0   
          Bit Rate:11 Mb/s   Sensitivity=1/3 
          Retry short limit:8   RTS thr:off   Fragment thr:off
          Power Management:off
         
wlan0     IEEE 802.11b  ESSID:"TP-LINK"  Nickname:""
          Frequency:2.437 GHz  Access Point: 00:1D:0F:59:A4:A0   
          Bit Rate:11 Mb/s   Sensitivity=1/3 
          Retry short limit:8   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=62/70  Signal level=-33 dBm  Noise level=-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:184  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2094   Missed beacon:0

 irda0     no wireless extensions.


这是我查看IP分配情况看到的结果
代码:
linphy@linphy-laptop:~$ sudo lshw -C network
  *-network:0 DISABLED   
       description: Wireless interface
       product: Prism 2.5 Wavelan chipset
       vendor: Intersil Corporation
       physical id: 2
       bus info: pci@0000:02:02.0
       logical name: wifi0
       version: 01
       serial: 00:05:3c:08:46:4b
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list logical wireless ethernet physical
       configuration: broadcast=yes driver=hostap firmware=1.4.9 ip=192.168.2.11 latency=64 module=hostap_pci multicast=yes wireless=IEEE 802.11b
  *-network:1
       description: Ethernet interface
       product: 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:02:08.0
       logical name: eth0
       version: 41
       serial: 00:d0:59:be:d4:5b
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.23-k4-NAPI duplex=full firmware=N/A ip=192.168.2.12 latency=66 link=yes maxlatency=56 mingnt=8 module=e100 multicast=yes port=MII speed=100MB/s


这是我用ifconfig命令看到的结果
代码:
linphy@linphy-laptop:~$ ifconfig
eth0      Link encap:以太网  硬件地址 00:d0:59:be:d4:5b 
          inet 地址:192.168.2.12  广播:192.168.2.255  掩码:255.255.255.0
          inet6 地址: fe80::2d0:59ff:febe:d45b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  跃点数:1
          接收数据包:611 错误:0 丢弃:0 过载:0 帧数:0
          发送数据包:66 错误:0 丢弃:0 过载:0 载波:0
          碰撞:0 发送队列长度:1000
          接收字节:37224 (36.3 KB)  发送字节:8921 (8.7 KB)

lo        Link encap:本地环回 
          inet 地址:127.0.0.1  掩码:255.0.0.0
          inet6 地址: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  跃点数:1
          接收数据包:3068 错误:0 丢弃:0 过载:0 帧数:0
          发送数据包:3068 错误:0 丢弃:0 过载:0 载波:0
          碰撞:0 发送队列长度:0
          接收字节:155809 (152.1 KB)  发送字节:155809 (152.1 KB)

wifi0     Link encap:未指定  硬件地址 00-05-3C-08-46-4B-00-00-00-00-00-00-00-00-00-00 
          inet 地址:192.168.2.11  广播:192.168.2.255  掩码:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  跃点数:1
          接收数据包:452 错误:0 丢弃:0 过载:0 帧数:0
          发送数据包:7 错误:0 丢弃:119 过载:0 载波:0
          碰撞:0 发送队列长度:1000
          接收字节:38428 (37.5 KB)  发送字节:684 (684.0 B)
          中断:11


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-19 11:27 
头像

注册: 2007-10-25 20:24
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
希望能帮我看看,我的问题处在哪啊,我最开始能用有线接路由器上网,但是之后我又试验了一下直接用ADSL拨号上网,也成功了,这个时候我看到我的无线有信号了,也就想着配下无线的IP,看能不能通过无线接路由器上网,反正改了些东西,不过从没 改过这个/etc/network/interfaces配置 文件之外的东西,现在无线上不了网,有线也上不了。麻烦各位帮帮我,实在太折腾人了


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-19 12:03 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
必须确保interface里有eth0和wifi0的IP配置
而不是只有wifi0

先停止无线
sudo ifconfig wifi0 down
sudo ifconfig wlan0 down
再启动eth0
sudo ifconfig eth0 up
看看能不能有线上网了? :em11


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-19 16:16 
头像

注册: 2007-10-25 20:24
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
sunzhaoyu2000 写道:
必须确保interface里有eth0和wifi0的IP配置
而不是只有wifi0

先停止无线
sudo ifconfig wifi0 down
sudo ifconfig wlan0 down
再启动eth0
sudo ifconfig eth0 up
看看能不能有线上网了? :em11

interface里有eth0和wifi0的IP配置,刚下午开机有线又能上了,没做任何改变,真的很奇怪。但是无线还是不能上,我想知道如果配无线的IP话是wifi0和wlan0这两个都要配吗?我不太清楚这两个是什么关系,看到你停止无线时也停止了wlan0,还是谢谢你了。呵呵,终于有人回应了。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-19 19:21 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
我前天搞了半天无线
终于搞定了
不过因为其他原因现在用不了无线

我的是有线eth0和无线wlan0
看你的
难道是两个无线?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-19 19:29 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
我回忆一下
应该是用network-admin
点击unlock成管理员
禁止wired连接
点击wireless连接,点击property
输入密码(我当时没有填,所以右上角有很清楚的无线信号,但是ping不通网关)

我自己配置IP地址成DHCP,静态IP也可以在这设置
就可以ping通网关了

你再试试看


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-19 19:30 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
关键是你已经识别自己的wireless了
后面应该是很容易的


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-20 8:31 
头像

注册: 2007-10-25 20:24
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
sunzhaoyu2000 写道:
我前天搞了半天无线
终于搞定了
不过因为其他原因现在用不了无线

我的是有线eth0和无线wlan0
看你的
难道是两个无线?

我有两个无线连接,wifi0和wlan0,而且我知道的是我机器有红外线和无线网卡,不知道哪个是无线网卡,是wlan0是还是wifi0是,现在发现有线上网也是有一阵没一阵的,每次如果上不了网了,都是拔掉网线重新插一下就行了。宿舍同学说是ubuntu下的网卡驱动有问题,因为在windows里用没出现这样的问题!交流一下,谢谢!你可以看看我上面用命令查看的设备情况,我看不太明白。只好全贴出来了,呵呵!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-20 8:42 
头像

注册: 2007-10-25 20:24
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
sunzhaoyu2000 写道:
我回忆一下
应该是用network-admin
点击unlock成管理员
禁止wired连接
点击wireless连接,点击property
输入密码(我当时没有填,所以右上角有很清楚的无线信号,但是ping不通网关)

我自己配置IP地址成DHCP,静态IP也可以在这设置
就可以ping通网关了

你再试试看

这些我都试过了,呵呵,不过他们说这个Networking不怎么好用,有BUG。我也发现了,明明在里面设置了IP可是打开/etc/network/interfaces,发现里面的配置根本就没改过来,感觉好像在Networking配置的东西他都要写进这个文件里吧。在就是明明在里面配好的DNS,下次进去还是换成他自己默认的192.168.1.1了,郁闷坏了!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-20 9:18 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
这文件废弃了的。
你的essid怎么有乱码的?那可不行。


_________________
● 鸣学


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 无线网卡上不了网,捣鼓了几次后连有线也上不了。
帖子发表于 : 2008-10-20 21:36 
头像

注册: 2007-10-25 20:24
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
这文件废弃了的。
你的essid怎么有乱码的?那可不行。

没乱码,只是贴出来的时候乱码了,当时没发在ubuntu里上网,就弄去XP下发的!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译