板载的网卡8102E有时正常,有时开机网络不可用,需要重启电脑才行

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
cocaxl
帖子: 41
注册时间: 2006-06-16 17:32
送出感谢: 0
接收感谢: 0

板载的网卡8102E有时正常,有时开机网络不可用,需要重启电脑才行

#1

帖子 cocaxl » 2008-11-04 11:18

华硕P5KPL-AM的主板,网卡是板载的realtek RTL 8102EL,装ubuntu8.04,安装后网卡即可使用。时常发现启动电脑之后,其他都正常但网络不可用,ping本机IP正常,ping其他所有局域网内地址均不可到达,重启电脑后又正常(有时需要重启2次),机子上装的windows xp没有这个问题。IP是固定的内网地址,dns也固定不变。网络可用与不可用的情况,ifconfig的结果一致,
dmesg中都有

代码: 全选

r8169 Gigabit Ethernet driver 2.2LK loaded
网络可用时:

代码: 全选

r8169: eth0: link up
r8169: eth0: link up
不可用时:

代码: 全选

r8169: eth0: link up
 NETDEV WATCHDOG: eth0: transmit timed out
 r8169: eth0: link up
 NETDEV WATCHDOG: eth0: transmit timed out
lsmod的结果,
网络可用时:

代码: 全选

sd_mod                 30720  4
scsi_mod              151436  4 sg,sr_mod,sd_mod,libata
usbcore               146028  4 usbhid,ehci_hcd,uhci_hcd
网络不可用时:

代码: 全选

sd_mod                 30720  6
scsi_mod              151436  5 usb_storage,sg,sr_mod,sd_mod,libata
usbcore               146028  6 usb_storage,libusual,usbhid,ehci_hcd,uhci_hcd
问题:
1,出现这种情况是什么原因导致的?
2,如何解决?
3,为什么8102的网卡在dmesg里显示的是r8169?
头像
heihaier
帖子: 168
注册时间: 2008-09-29 22:16
送出感谢: 0
接收感谢: 0
联系:

Re: 板载的网卡8102E有时正常,有时开机网络不可用,需要重启电脑才行

#2

帖子 heihaier » 2008-11-04 11:23

我也遇到过,当时我如果先启动计算机,再启动路由器就会不能联网。可能是你的物理线路问题吧。
Keep it simple, stupid!
https://heiher.info
cocaxl
帖子: 41
注册时间: 2006-06-16 17:32
送出感谢: 0
接收感谢: 0

Re: 板载的网卡8102E有时正常,有时开机网络不可用,需要重启电脑才行

#3

帖子 cocaxl » 2008-11-04 16:37

我这里没有用路由,直接网线连到2层交换机。

每次重启,什么都不用动,网线交换机都不动,如果可以,网络就正常了;如果网络还是不可用,再重启一次也能正常(我最多重启2次就可以)。

windows从来没有这个问题。
wifibt
帖子: 35
注册时间: 2007-12-03 22:53
送出感谢: 0
接收感谢: 0

Re: 板载的网卡8102E有时正常,有时开机网络不可用,需要重启电脑才行

#4

帖子 wifibt » 2008-11-12 15:01

呵呵,这是8.04的一个bug,该bug在8.10中依然存在。我现在只能另插一块网卡先用着!
回复

回到 “网卡问题以及网络和拨号”