解决锐捷在8.10里的认证问题,广大学子受益拉!

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
hhzcl
帖子: 3
注册时间: 2008-11-12 18:29
送出感谢: 0
接收感谢: 0

解决锐捷在8.10里的认证问题,广大学子受益拉!

#1

帖子 hhzcl » 2008-12-13 0:10

从开始装了8.10 Ubuntu,windows里用的就是锐捷3.32版,最近学校升级到了3.35版本,我今天试了一下,老的登录器还可以登的,已经连续上了一个小时,还没断过。不多说什么了,介绍下步骤,还有不懂的可以跟帖

1.首先把附件解压到/home,得到myxrgsu, libpcap.so.0.6.2, libstdc++.so.5,等文件
执行
sudo cp /home/myxrgsu /bin
sudo cp /home/libpcap.so.0.6.2 /bin
sudo cp /home/libstdc++.so.5 /bin
sudo cp /home/libpcap.so.0.6.2 /usr/lib
sudo cp /home/libpcap.so.0.8 /usr/lib
sudo cp /home/libpcap.so.0.9.8 /usr/lib
sudo cp /home/libstdc++.so.6 /usr/lib
sudo cp /home/libstdc++.so.6.0.10 /usr/lib
sudo cp /home/libstdc++.so.5 /usr/lib

2.修改网络配置:
(每次重启过后就要重新设置,不知道为什么不能保存,求教大虾)
首先查出自己的IP,DNS,掩码,网关(一般在windows下查,运行cmd,运行命令ipconfig/all即可查看),记下IP,网关,掩码,主备DNS
系统—首选项—网络设置,在有线里选Auto eth0,点编辑,把自动连接和系统设置选上,点IPv4设置,将方法改为手动,地址里填入IP、子网掩码、默认网关。之前找到的主备DNS分别填到DNS服务器和搜索域名里,(好像搜索域名不填就不行)

3.开始登录
执行(每次登录前都要执行)
sudo ifconfig eth0 *.*.*.*(本机IP

sudo route add default gw *.*.*.*(默认网关) dev eth0

sudo myxrgsu -a
出现
Please input your username:XXXX(你的账号)

Please input yourpassword:XXXX(你的密码,这里不会显示出来,但是你确实是输入进去了,要注意。)

Use DHCP,1-Use,0-UnUse(Default: 0):1←Enter (这里要选择1使用DHCP,切记!不知道为什么,有点反常理
Use default auth parameter,0-Use 1-UnUse(Default: 0):←Enter
Searching server...
Connecting server...
Authenticating...
Authenticate SUCCESSFULLY!
Please input 'unauth' to LogOff:
附件
ruijie.zip
锐捷
(1015.21 KiB) 下载 3321 次
aurorayang
帖子: 5
注册时间: 2008-12-12 23:14
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#2

帖子 aurorayang » 2008-12-13 10:03

受益了
ljhlhh
帖子: 9
注册时间: 2008-11-05 17:15
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#3

帖子 ljhlhh » 2008-12-13 10:32

你用的是动态IP,我们用静态IP没这么复杂:
先设置好IP,DNS等参数。只要copy三个文件就可以了:xrgsu,libpcap.so.0.6.2,libtsdc++.so.5第一个到/usr/bin,其它两个到/usr/lib,对/usr/bin里的xrgsu执行权限操作:sudo chmod 777 /usr/bin/xrgsu
然后执行 sudo xrgsu 按提示输入用户名和密码后一路按确定就可以了
stormdemon
帖子: 8
注册时间: 2008-11-26 23:00
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#4

帖子 stormdemon » 2008-12-15 5:08

有人成功没,报个信。我咋个失败啊 还是连接不上
lihaidong
帖子: 251
注册时间: 2008-01-31 22:05
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#5

帖子 lihaidong » 2008-12-28 16:53

hhzcl 写了:从开始装了8.10 Ubuntu,windows里用的就是锐捷3.32版,最近学校升级到了3.35版本,我今天试了一下,老的登录器还可以登的,已经连续上了一个小时,还没断过。不多说什么了,介绍下步骤,还有不懂的可以跟帖

1.首先把附件解压到/home,得到myxrgsu, libpcap.so.0.6.2, libstdc++.so.5,等文件
执行
sudo cp /home/myxrgsu /bin
sudo cp /home/libpcap.so.0.6.2 /bin
sudo cp /home/libstdc++.so.5 /bin
sudo cp /home/libpcap.so.0.6.2 /usr/lib
sudo cp /home/libpcap.so.0.8 /usr/lib
sudo cp /home/libpcap.so.0.9.8 /usr/lib
sudo cp /home/libstdc++.so.6 /usr/lib
sudo cp /home/libstdc++.so.6.0.10 /usr/lib
sudo cp /home/libstdc++.so.5 /usr/lib

2.修改网络配置:
(每次重启过后就要重新设置,不知道为什么不能保存,求教大虾)
首先查出自己的IP,DNS,掩码,网关(一般在windows下查,运行cmd,运行命令ipconfig/all即可查看),记下IP,网关,掩码,主备DNS
系统—首选项—网络设置,在有线里选Auto eth0,点编辑,把自动连接和系统设置选上,点IPv4设置,将方法改为手动,地址里填入IP、子网掩码、默认网关。之前找到的主备DNS分别填到DNS服务器和搜索域名里,(好像搜索域名不填就不行)

3.开始登录
执行(每次登录前都要执行)
sudo ifconfig eth0 *.*.*.*(本机IP

sudo route add default gw *.*.*.*(默认网关) dev eth0

sudo myxrgsu -a
出现
Please input your username:XXXX(你的账号)

Please input yourpassword:XXXX(你的密码,这里不会显示出来,但是你确实是输入进去了,要注意。)

Use DHCP,1-Use,0-UnUse(Default: 0):1←Enter (这里要选择1使用DHCP,切记!不知道为什么,有点反常理
Use default auth parameter,0-Use 1-UnUse(Default: 0):←Enter
Searching server...
Connecting server...
Authenticating...
Authenticate SUCCESSFULLY!
Please input 'unauth' to LogOff:
每次重启过后就要重新设置,不知道为什么不能保存,求教大虾
恩。要改开机配置文件,你改的只是临时的。
sudo vim /etc/resolv.conf #改DNS
sudo vim /etc/network/interfaces #改IP,可以设成静态(这样连ifconfig和route这两句也省了)或DHCP(需要ifconfig和route)。
这就是永久的设置了。最后使配置生效
sudo /etc/init.d/networking restart
细节自己搜一下。提醒先备份。系统的配置不能乱改的。错了还可以恢复。

:em03 :em02
logyfish
帖子: 3
注册时间: 2008-12-31 11:32
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#6

帖子 logyfish » 2008-12-31 11:35

我输入了sudo route add default gw 192.168.1.1 dev eth0
但是显示“没有该进程”??
u是8.10,我跳过这一步,启动myxrgsu,但最后总是Authenticate fail!
请问怎样解决?
lihaidong
帖子: 251
注册时间: 2008-01-31 22:05
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#7

帖子 lihaidong » 2009-01-02 18:37

logyfish 写了:我输入了sudo route add default gw 192.168.1.1 dev eth0
但是显示“没有该进程”??
u是8.10,我跳过这一步,启动myxrgsu,但最后总是Authenticate fail!
请问怎样解决?
先运行
sudo ifconfig eth0 IP地址 netmask 子网掩码
再设置网关。没有IP地址,哪来网关呢? :em04
suzb
帖子: 1
注册时间: 2008-12-31 21:02
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#8

帖子 suzb » 2009-01-03 21:50

:em04 :em04
stonethree
帖子: 32
注册时间: 2005-11-04 9:47
来自: 武汉
送出感谢: 0
接收感谢: 0
联系:

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#9

帖子 stonethree » 2009-01-04 10:14

我的ubuntu8.10是在windows下用wubi安装的,然后配置了锐捷客户端,执行是没问题,可认证不了,

网络设置为:
IP: 192.168.XX.XXX 网关:192.168.xx.254 DNS:202.xx.xxx.xxx
截图
jietu2.png
abide
帖子: 74
注册时间: 2009-01-04 11:46
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#10

帖子 abide » 2009-01-05 0:20

这个方法怎么看起来是静态IP的~现在学校用3.35的锐捷,在XP下设置IP地址都会断~这样做难行吗?
Hurry
帖子: 3
注册时间: 2009-01-02 17:03
送出感谢: 0
接收感谢: 0

Re: 解决锐捷在8.10里的认证问题,广大学子受益拉!

#11

帖子 Hurry » 2009-01-10 18:22

我来说下自己的经验:
1、8.1下面不能保存ip、子网掩码还有默认网关之类的
2、我们学校用的是动态IP,就是认证后获取的那种,锐捷版本 3.30-0222…………
3、按照楼主的方法执行

1.首先把附件解压到/home,得到myxrgsu, libpcap.so.0.6.2, libstdc++.so.5,等文件
执行
sudo cp /home/myxrgsu /bin
sudo cp /home/libpcap.so.0.6.2 /bin
sudo cp /home/libstdc++.so.5 /bin
sudo cp /home/libpcap.so.0.6.2 /usr/lib
sudo cp /home/libpcap.so.0.8 /usr/lib
sudo cp /home/libpcap.so.0.9.8 /usr/lib
s udo cp /home/libstdc++.so.6 /usr/lib
sudo cp /home/libstdc++.so.6.0.10 /usr/lib
sudo cp /home/libstdc++.so.5 /usr/lib
4、执行 sudo ifconfig eth0 *.*.*.*(本机IP)
sudo route add default gw *.*.*.*(默认网关) dev eth0

5、执行 sudo myxrgsu -a
…… ……
…………
Use DHCP,1-Use,0-UnUse(Default: 0):1←Enter (这里要选择1使用DHCP,切记!)这个地方一定选1 ,表示动态IP~
等着认证成功吧~
终端可以不关掉~最后退出 锐捷要用到。
这个时候如果你打开浏览器会发现大不开网页。
6、在右上角的 网络管理小工具 里选择eth0。OK,可以上网了~~
7、每次上网只要 执行 4 5 6步 就行了。
回复

回到 “网卡问题以及网络和拨号”