CDMA网卡的上网设置问题

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
8la8la
帖子: 7
注册时间: 2008-05-18 2:37
送出感谢: 0
接收感谢: 0

CDMA网卡的上网设置问题

#1

帖子 8la8la » 2009-01-03 0:21

最近抢了朋友的CDMA网卡想安在我的Ubuntu本本上上网,在网上找到了一篇配置文章,照着做了,前面的步骤都很成功,到了最后拨号的时候出现了问题,麻烦大家帮忙看看这是怎么回事

参考文章:http://hi.baidu.com/zhtf/blog/item/1564 ... 6e07f.html

我的操作步骤:
1. $ sudo dmesg | grep tty
显示结果:
[ 0.004000] console [tty0] enabled
[ 1.692911] 00:0a ttyS0 at I/O 0x3f8 (irq = 4) is a NS16550A
[ 19.578565] ttyS2: detected caps 00000700 should be 00000100
[ 19.578565] 0.0: ttyS2 at I/O 0x3e8 (irq = 3) is a 16C950/954

2.$ sudo ln -sf /dev/ttyS1 /dev/modem

3.$ sudo gedit /etc/wvdial.conf
内容编辑如下:
QUOTE:
[Modem0]
Modem = /dev/modem
Baud = 57600
SetVolume =1
Dial Command = ATDT
Init1 = ATZ
FlowControl = Hardware (CRTSCTS)

[Dialer Defaults]
Username = CARD
Password = CARD
Phone = #777
Stupid Mode = 1
Inherits = Modem0

3.$ sudo apt-get install setserial

4.$ sudo setserial /dev/ttyS2 baud_base 230400

5.sudo wvdial (到这里出现问题了 )
显示结果:
--> WvDial: Internet dialer version 1.60
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
OK
--> Re-Sending: ATZ
OK
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
OK
--> Re-Sending: ATZ
OK

就没后续了?这是怎么回事?并没有拨号啊

我的Ubuntu版本 8.10
8la8la
帖子: 7
注册时间: 2008-05-18 2:37
送出感谢: 0
接收感谢: 0

Re: CDMA网卡的上网设置问题

#2

帖子 8la8la » 2009-01-03 0:51

原来是我家信号太弱了,搬到凉台拨号就好了.... :em06

再问一下,我装了个gnome-ppp图形界面的拨号软件,在setup设置里,Device点击Detect为什么告诉我“No modem was found on your system”??用这个软件拨号就不能用呢?
271629693
帖子: 4
注册时间: 2008-04-16 15:35
送出感谢: 0
接收感谢: 0

Re: CDMA网卡的上网设置问题

#3

帖子 271629693 » 2009-01-04 13:11

你的拨号后浏览器可以上网吗?
回复

回到 “网卡问题以及网络和拨号”