当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 8.10通过路由器上网的问题求解
帖子发表于 : 2009-01-15 9:28 

注册: 2008-04-13 14:26
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
3个人牵了一根电信的宽带,pppoe拨号上网。我们用路由器,然后通过路由器上网。
以前用winxp,现在装了个ubuntu 8.10,从硬盘安装的,安装的时候没有拔网线,但是系统检测的时候说无法找到有效连接。
winxp下面有两个连接,LAN(正常),WAN(PPPOE拨号,无法拨通。是由路由器代拨了么?)
winxp下可以正常上网,ubuntu无法上网,总说找不到有效连接。
按照论坛上的n个帖子一个一个的试,还是不行。
求求大侠们支个招吧。
如果我有什么东西没有说清楚,请发帖,我把知道的都说出来。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu 8.10通过路由器上网的问题求解
帖子发表于 : 2009-01-15 22:47 
头像

注册: 2008-12-05 17:53
帖子: 24
地址: 新疆克拉玛依
送出感谢: 0 次
接收感谢: 0 次
需要在网络设置里,用静态局域网ip设置一下.包括dns。你先在win里记录下网络参数。并且参考本论坛静态ip设置方法 。多尝试,


_________________
公正不是德性的一个部分,而是整个德性;相反,不公正也不是邪恶的一个部分,而是整个邪恶。如果能抵御饲料的诱惑,一头猪都可以成为公正的判官。
贺卫方关于犯罪的精彩演讲心理测试


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu 8.10通过路由器上网的问题求解
帖子发表于 : 2009-01-16 12:53 

注册: 2008-12-12 15:35
帖子: 133
送出感谢: 0 次
接收感谢: 0 次
dhcp还是非dhcp的?

若那两台是不需要设置什么ip的话,那么就在
/etc/network/interface文件下增加
代码:
auto eth0
iface eth0 inet dhcp


应该没有问题,如果不行,可以试一下静态网络(就是将dhcp改成static),但注意还要在后面添ip地址,网关等等东西。上网再搜搜。
一般路由默认都是有地址池段的,否则即使在xp下也不能即插即用了(当然第一次设置好,后面的就不用再设置了)。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu 8.10通过路由器上网的问题求解
帖子发表于 : 2009-01-20 22:39 

注册: 2008-04-13 14:26
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我重新装了个8.04的,还是不行。我放弃了。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu 8.10通过路由器上网的问题求解
帖子发表于 : 2009-01-21 9:41 
头像

注册: 2008-12-16 14:01
帖子: 1080
地址: 漂在江湖
送出感谢: 12
接收感谢: 13
younthu 写道:
3个人牵了一根电信的宽带,pppoe拨号上网。我们用路由器,然后通过路由器上网。
以前用winxp,现在装了个ubuntu 8.10,从硬盘安装的,安装的时候没有拔网线,但是系统检测的时候说无法找到有效连接。
winxp下面有两个连接,LAN(正常),WAN(PPPOE拨号,无法拨通。是由路由器代拨了么?)
winxp下可以正常上网,ubuntu无法上网,总说找不到有效连接。
按照论坛上的n个帖子一个一个的试,还是不行。
求求大侠们支个招吧。
如果我有什么东西没有说清楚,请发帖,我把知道的都说出来。


你没有说清楚,3个人合用一个线路,PPPOE的拨号是怎么设置的?
1.“只要打开猫,就自动拨号上网”,那么你的电脑是不需要拨号的,就象有线LAN一样就能直接上网的。
2.“如何一人拨号,就上网”,那么你是第一个,就要发起拨号,如果已经有人上网了,就和1.的情况一样。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu 8.10通过路由器上网的问题求解
帖子发表于 : 2009-11-07 10:50 

注册: 2008-11-13 7:59
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
我也遇到同样的问题
ADSL网络通过路由器上网 台式机是主机,设置了网络拨号,笔记本不用设置,xp下直接可以上网
但是在xubuntu下无法上网
sudo pppoeconf 提示找不到,错误


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu 8.10通过路由器上网的问题求解
帖子发表于 : 2011-01-25 18:10 

注册: 2010-09-18 23:44
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我的貌似也是这个问题,通过路由器拨号上网,刚开始时win7下能上网,但linux下不行,我的是通过以下方法解决的:
代码:
sudo gedit /etc/NetworkManager/nm-system-settings.conf

将打开的文件里 managed=false 改为 managed=true

代码:sudo service network-manager restart
这样之后就奇迹般地可以上网了,希望对你有所帮助。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译