当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无线网络连上了还是没连上?
帖子发表于 : 2009-02-03 7:16 

注册: 2008-09-08 22:10
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
tplink wr240g,好几年前买的,在xp下无线上网正常,可是在linuxmint下,怎么都上不了网,截了两张图,拜托各位给看看这到底是连上了还是没连上呢?如果算是连上了怎么网页都打不开呢?
谢谢啦!


附件:
1.png
1.png [ 16.81 KiB | 被浏览 1210 次 ]
2.png
2.png [ 11.33 KiB | 被浏览 1212 次 ]
页首
 用户资料  
 
2 楼 
 文章标题 : Re: 无线网络连上了还是没连上?
帖子发表于 : 2009-02-03 9:12 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
iwconfig
iwlist
提供这些信息吧。
看图有何用啊。又不知道你那什么软件显示的。机制都可能不同。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 无线网络连上了还是没连上?
帖子发表于 : 2009-02-03 9:25 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
以第一张图来说是连上了,但连上了未必能上网,因为你的网关设定是否正常未知


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 无线网络连上了还是没连上?
帖子发表于 : 2010-01-09 17:13 

注册: 2008-09-08 22:10
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
现在终于有空来折腾这个linux了,现在装的是mint8,可是同样的问题发生了!跟去年一模一样。查了无数帖子还是没解决,还是到这里请教,下面是 iwconfig、iwlist、ifconfig、cat /etc/resolv.conf 信息,

zhfc@zhfc-laptop ~ $ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:"zhulu"
Mode:Managed Frequency:2.437 GHz Access Point: 00:0A:EB:ED:25:0C
Bit Rate=54 Mb/s Tx-Power=14 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=70/70 Signal level=-14 dBm Noise level=-92 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.


zhfc@zhfc-laptop ~ $ iwlist
Usage: iwlist [interface] scanning [essid NNN] [last]
[interface] frequency
[interface] channel
[interface] bitrate
[interface] rate
[interface] encryption
[interface] keys
[interface] power
[interface] txpower
[interface] retry
[interface] ap
[interface] accesspoints
[interface] peers
[interface] event
[interface] auth
[interface] wpakeys
[interface] genie
[interface] modulation


zhfc@zhfc-laptop ~ $ ifconfig
eth0 Link encap:以太网 硬件地址 00:1d:72:9c:9f:e1
UP BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)
Memory:fe000000-fe020000

lo Link encap:本地环回
inet 地址:127.0.0.1 掩码:255.0.0.0
inet6 地址: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 跃点数:1
接收数据包:16 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:16 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:920 (920.0 B) 发送字节:920 (920.0 B)

wlan0 Link encap:以太网 硬件地址 00:21:5c:70:7b:55
inet 地址:192.168.1.101 广播:192.168.1.255 掩码:255.255.255.0
inet6 地址: fe80::221:5cff:fe70:7b55/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:11 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:147 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:1596 (1.5 KB) 发送字节:19795 (19.7 KB)

wmaster0 Link encap:未指定 硬件地址 00-21-5C-70-7B-55-37-30-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)


zhfc@zhfc-laptop ~ $ cat /etc/resolv.conf
# Generated by NetworkManager
domain domain
search domain
nameserver 202.96.128.68
nameserver 202.96.134.188
nameserver 202.96.134.133
# NOTE: the libc resolver may not support more than 3 nameservers.
# The nameservers listed below may not be recognized.
nameserver 192.168.1.1


下面这些是在tp-link里查询到的

LAN口状态
MAC地址: 00-0A-EB-ED-25-0C
IP 地址: 192.168.1.1
子网掩码: 255.255.255.0


无线状态
无线功能: 开 启
SSID 号: zhulu
频 段: 6
模 式: 54Mbps (802.11g)
MAC地址: 00-0A-EB-ED-25-0C
IP 地址: 192.168.1.1


WAN口状态
MAC地址: 00-0A-EB-ED-25-0D
IP 地址: 58.25.99.43 动态IP
子网掩码: 255.255.252.0
网关: 58.25.96.1
DNS服务器: 219.233.241.166 ,211.167.97.67


WAN口流量统计
接收 发送
字节数: 489390679 305366550
数据包数: 661555 718871


这些信息有用吗?我看很多帖子都提到这几项,可是我看不懂它,求教,十分感谢!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 无线网络连上了还是没连上?
帖子发表于 : 2010-01-09 18:23 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
iwlist <tab> scan
其中tab可以补全无线设备名。应该是wlan0。
iwconfig看,你的无线设备是驱动正常的。只是没连接。在nm-applet图标点下,或者右键点配置,看下。
从你的ifconfig来看。没连上。
/etc/resolv.conf 里面,只需要 nameserver。而且别自己去改。
tp-link的信息看,没看出你是否设置了dhcp服务。nm是需要dhcpd的。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 无线网络连上了还是没连上?
帖子发表于 : 2010-01-12 23:49 

注册: 2008-09-08 22:10
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
十分感谢您的回复!还是没弄好。

您说的iwilist是这个吗?

zhfc@zhfclaptop ~ $ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:0A:EB:ED:25:0C
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=70/70 Signal level=-18 dBm
Encryption key:on
ESSID:"zhulu"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s
Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000000010392181
Extra: Last beacon: 86152ms ago
IE: Unknown: 00057A68756C75
IE: Unknown: 010882848B960C183048
IE: Unknown: 030106
IE: Unknown: 0706434E20010D14
IE: Unknown: 2A0100
IE: Unknown: 32041224606C
IE: Unknown: DD0900037F01010000FF7F

pan0 Interface doesn't support scanning.


DHCP已经开启了,麻烦您了!十分感谢!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 无线网络连上了还是没连上?
帖子发表于 : 2010-01-15 13:02 

注册: 2008-09-08 22:10
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
经过坚持不懈的折腾(不幸的是我忘了怎么弄得了),现在在地址栏里输入ip地址可以上网输入域名就不行,查了一下说是DNS的问题,找了一圈没找到怎么设置,再来请教一下,十分感谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译