锐捷认证的终结解决(ubuntu8.10amd64下)

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
头像
tbam
帖子: 77
注册时间: 2008-10-04 15:19
送出感谢: 0
接收感谢: 0
联系:

锐捷认证的终结解决(ubuntu8.10amd64下)

#1

帖子 tbam » 2009-03-08 10:00

32位系统下锐捷认证的问题已经得到解决:(前提是把xrgsu,libpcap,libstdc++解压出来放到tmp下面哦)
sudo cp /tmp/xrgsu /usr/bin

sudo cp /tmp/libpcap.so.0.6.2 /usr/lib

sudo cp /tmp/libstdc++.so.5 /usr/lib


linux作为支持64位CPU的先驱,而且64位的系统迟早成为主流,对于我这台amd4400+的机子,我把心一横,投身64位~
这样我要到的问题就是:如何让32位的程序xrgsu运行在64位的系统上。方法有很多种,但对于我这种离开锐捷认证电脑无法上网的特殊情况(虚拟机还没尝试过,嘿嘿),还是采用下面的方法更方便些。
我采用的方案就是安装:ia32-libs(http://packages.ubuntu.com/intrepid/ia32-libs)
ia32 shared libraries for use on amd64 and ia64 systems
This package contains runtime libraries for the ia32/i386 architecture, configured for use on an amd64 or ia64 Debian system running a 64-bit kernel.
(版本应该无所谓,不过新一点更好啦),不幸的是这个软件包依赖其他的软件包,如
( dpkg (>= 1.14.12ubuntu3)
Debian软件包管理系统
lib32asound2
ALSA library (32bit)
lib32gcc1
GCC support library (32 bit Version)
lib32ncurses5
Shared libraries for terminal handling (32-bit)
lib32stdc++6
The GNU Standard C++ Library v3 (32 bit Version)
lib32z1
compression library - 32 bit runtime
libc6-i386 (>= 2.3.6-2)
GNU C Library: 32bit shared libraries for AMD64
lsb-release
Linux Standard Base version reporting utility
),于是乎,在win下面把这几个该死的文件下载下来安上xrgsu就正常运行拉!
上次由 tbam 在 2009-03-08 10:10,总共编辑 2 次。
头像
tbam
帖子: 77
注册时间: 2008-10-04 15:19
送出感谢: 0
接收感谢: 0
联系:

Re: 锐捷认证的终结解决(ubuntu8.10amd64下)

#2

帖子 tbam » 2009-03-08 10:08

另外注明:以上方案在遇到如此之提示时可行:
Q1: unable to execute /usr/bin/xrgsu: No such file or directory

(Q1问题就是因为32位的xrgsu不能在amd63系统上使用拉)

Q2: Package:libc6-i386,Error:Dependency is not satisfiable:libc6
(之所以会遇到Q2问题是因为网上对amd64系统下xrgsu的使用需要安装libc6-i386_2.5-0ubuntu14_amd64.deb,而安装这个包时报错Package:libc6-i386,Error:Dependency is not satisfiable:libc6,故另辟蹊径使用ia32-libs)
praying
帖子: 1
注册时间: 2009-03-21 15:45
送出感谢: 0
接收感谢: 0

Re: 锐捷认证的终结解决(ubuntu8.10amd64下)

#3

帖子 praying » 2009-03-21 15:55

请问一下是不每个软件是怎么装,一个个不讲顺序吗?(我是新手 :em03
每个软件又依赖别的好象绕进去了。
我搞了三天才发现他们讲方法都是32位下的。(郁闷了好久,都是按步骤来的为什么我的就不行!!)
头像
tbam
帖子: 77
注册时间: 2008-10-04 15:19
送出感谢: 0
接收感谢: 0
联系:

Re: 锐捷认证的终结解决(ubuntu8.10amd64下)

#4

帖子 tbam » 2009-06-02 21:37

那些软件里面最先要装的是libc6-i386_2.8~20080505-0ubuntu7_amd64.deb,当然所有的软件不一定都是最新版的,大家可以自己选择。




praying 写了:请问一下是不每个软件是怎么装,一个个不讲顺序吗?(我是新手 :em03
每个软件又依赖别的好象绕进去了。
我搞了三天才发现他们讲方法都是32位下的。(郁闷了好久,都是按步骤来的为什么我的就不行!!)
回复

回到 “网卡问题以及网络和拨号”