当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 卸载掉network manager之后的问题
帖子发表于 : 2009-03-23 15:49 
头像

注册: 2007-05-31 20:17
帖子: 207
地址: DUT
送出感谢: 0 次
接收感谢: 0 次
我觉得network manager,就给它在remove了,然后改了配置文件 /etc/network/interfaces/
auto eth0
iface eth0 inet static
address XXX
netmask 255.255.255.0
gateway XXX
但是有个问题出现了,我每次开机的时候网卡设备名会变成eth1, 如果我把配置文件改成eth1,再重启机器设备名又变成eth0了。
这样我每次开机都得改次配置文件才能上网。

为什么设备名是变呢?怎么能让它固定下来就是eth0?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 卸载掉network manager之后的问题
帖子发表于 : 2009-03-23 16:19 
头像

注册: 2008-08-16 9:39
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
只要能上网不就行了?
还有你是不是插了两网卡?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 卸载掉network manager之后的问题
帖子发表于 : 2009-03-23 16:25 
头像

注册: 2007-05-31 20:17
帖子: 207
地址: DUT
送出感谢: 0 次
接收感谢: 0 次
zjz00zjz 写道:
只要能上网不就行了?
还有你是不是插了两网卡?

我只有一块有线网卡,另一块网卡是无线网卡,每次都以wlan0标识。
每次都改配置文件很麻烦,FIREFOX打开的时候默认都是离线模式,需要手动改了才能上网。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 卸载掉network manager之后的问题
帖子发表于 : 2009-03-25 20:17 

注册: 2008-10-18 15:13
帖子: 77
送出感谢: 0 次
接收感谢: 0 次
试试自动获取IP呢,
或是你把两块网卡eth0 和eth1都配一下,看启动能不能上网,只要不用设置就能上网就行了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 卸载掉network manager之后的问题
帖子发表于 : 2009-03-29 20:25 
头像

注册: 2007-05-31 20:17
帖子: 207
地址: DUT
送出感谢: 0 次
接收感谢: 0 次
sdomain 写道:
试试自动获取IP呢,
或是你把两块网卡eth0 和eth1都配一下,看启动能不能上网,只要不用设置就能上网就行了

我这用的是静态IP,用DHCP的时候没出现过这样的问题。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 卸载掉network manager之后的问题
帖子发表于 : 2009-04-02 13:10 

注册: 2008-09-25 21:01
帖子: 241
送出感谢: 0 次
接收感谢: 0 次
安装wicd试试!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译