当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : gcc版本切换
帖子发表于 : 2009-03-26 22:08 

注册: 2009-02-25 10:09
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
1.产看你的gcc版本 ls /usr/bin/gcc -l
2.查看当前GCC版本 gcc --dumpversion
3.下载安装所需版本的gcc
4.查看当前安装的gcc版本 ls /usr/bin/gcc* -l
5.增加gcc可选项(假如你增加的为gcc-3.3)
update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.3 40
update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-3.3 30
6选择你的gcc
update-alternatives --config gcc
7最后查看gcc版本


页首
 用户资料  
 
2 楼 
 文章标题 : Re: gcc版本切换
帖子发表于 : 2009-10-11 12:55 

注册: 2009-09-23 19:29
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
cws@cws-laptop:~/桌面/skyeye-1.2.7_rc1$ ls /usr/bin/gcc -l
lrwxrwxrwx 1 root root 18 2009-10-11 12:54 /usr/bin/gcc -> /usr/bin/gcc-3.4.1

我看了下,是3.4的版本阿,难道不能用来编译安装skyeye么? :em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译