当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 各位大虾们看看,偶的网络配置到底那里有问题
帖子发表于 : 2009-04-09 9:37 

注册: 2009-04-08 6:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
前些天装的ubuntu8.10,主要是为了管理文件方便一些,可是叫人郁闷的是总是上不了网
首先我的网络环境是校园网,网卡驱动正常,宿舍使用以太网交换机,直接分配IP不适用任何拨号软件。
我是这样配置的:

1.卸载传说中的网络管理器,reboot
2.将以下语句添加进 /etc/network/interfaces
auto eth0
iface eth0 inet static
address 10.1.57.207
netmask 255.255.248.0
gateway 10.1.56.1
3.将以下语句写入 /etc/resolv.conf (本来/etc里面是没有这个文件的,所以就自己创建了一个)
nameserver 211.82.xxx.xxx(后面不记得了 :em06 )
nameserver 202.206.xxx.xxx
4.reboot 发现关机不能……(将第三步的resolv.conf删掉就没有事了)
5.再次登陆后,用ifconfg检查网卡状态,没问题
6.使用ping命令测试网络情况,发现除了自己以外,谁都ping不通 :em20 (包括同宿舍同学的电脑,当然,防火墙都是关着的)
7.使用firefox浏览网页会显示 域名分析错误

初步判断在设置静态DNS服务器的时候出了错误,如果还有其它什么地方有问题的话,还请各位大大多多指教啊 :em11


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 各位大虾们看看,偶的网络配置到底那里有问题
帖子发表于 : 2009-04-09 9:56 
头像

注册: 2009-04-09 9:16
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
DNS设置错误不会引起IP通信失败,把ifconfig -a的输出粘出来大家帮你分析一下


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 各位大虾们看看,偶的网络配置到底那里有问题
帖子发表于 : 2009-04-09 10:20 

注册: 2009-04-08 6:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
这是我ifconfg -a 命令运行的结果

eth0 Link encap:Ethernet HWaddr 00:22:15:65:81:d7
inet addr:10.1.57.207 Bcast:10.1.63.255 Mask:255.255.248.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:3527008606 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:221 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:368 (368.0 B) TX bytes:368 (368.0 B)

pan0 Link encap:Ethernet HWaddr ee:b5:4c:4b:77:d0
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 各位大虾们看看,偶的网络配置到底那里有问题
帖子发表于 : 2009-04-10 8:42 
头像

注册: 2009-04-09 9:16
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
eth0上的包全部DROP了,是不是有防火墙或IP过滤之类的?
ip route show
sudo iptables -L -v
检查一下路由和iptables的设置试试


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译