当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Atheros 242X无线网卡在8.10新内核2.6.27-14不工作的补丁
帖子发表于 : 2009-04-12 2:05 

注册: 2008-12-19 9:29
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
Ubuntu 8.10内核最新的版本2.6.27-14因为调整了pci驱动的一些行为,使以前通过madwifi稳定版生成的驱动不能正常工作,用dmesg查看可以找到提示为wifi%d:...开头的出错信息。
查找相关资料abgn的9xxx系列可以直接由并入内核树的ath9k驱动,影响比较大的是Atheros的AR242X系列芯片的无线网卡因为它不能被ath9k所驱动。因此这个附件主要针对AR242x无线模块了。

BTW:本人的无线模块是 微星MSI-PRO210 笔记本内置的模块。
附驱动后的lspci -v消息如下:
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
Subsystem: Device 1a3b:1026
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fdff0000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
Capabilities: [60] Express Legacy Endpoint, MSI 00
Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
Capabilities: [100] Advanced Error Reporting <?>
Capabilities: [140] Virtual Channel <?>
Kernel driver in use: ath_pci
Kernel modules: ath_pci, ath5k


附件:
madwifi_20090412-1_i386.deb [463.27 KiB]
被下载 74 次
页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译