当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 有线网卡在重启后消失
帖子发表于 : 2009-04-18 10:07 

注册: 2008-07-09 0:39
帖子: 353
送出感谢: 1
接收感谢: 0 次
不知有没有人也跟我一样,就是有线网卡在重启后会消失,要“重启”的话只能关机再开机
虽然不怎么影响日常使用,但这是目前Linux在我的机上的一个小瑕疵。
我的机是Benq Joybook 5000U,有线网卡是Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet Controller

lspci -v片段:
代码:
01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet Controller (rev 83)
   Subsystem: Benq Corporation Device 500c
   Flags: bus master, medium devsel, latency 128, IRQ 10
   Memory at e0008000 (32-bit, non-prefetchable) [size=4K]
   I/O ports at c0c0 [size=64]
   Capabilities: <access denied>
   Kernel driver in use: e100
   Kernel modules: e100, eepro100


在网卡消失的时候,也即是重启后,lspci也能列出网卡,跟上面差不多,就是少了"Kernel driver in use: e100"一行。我手动modprobe e100,但网卡仍然无法启动。

如果在正常的情况下,也就是在网卡能用的时候,modprobe -r e100可以卸载网卡,再modprobe e100可以重新启用网卡。


最后由 cheeselee 编辑于 2009-04-18 10:40,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 有线网卡在重启后消失
帖子发表于 : 2009-04-18 10:16 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
Intel不该如此吧

你肯定吗,82801是桥芯片组啊

别是螃蟹的网卡卡芯片


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 有线网卡在重启后消失
帖子发表于 : 2009-04-18 10:20 

注册: 2008-07-09 0:39
帖子: 353
送出感谢: 1
接收感谢: 0 次
hcym 写道:
Intel不该如此吧

你肯定吗,82801是桥芯片组啊

别是螃蟹的网卡卡芯片


那是lspci列出的啊


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 有线网卡在重启后消失
帖子发表于 : 2009-04-18 10:55 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
cheeselee 写道:
hcym 写道:
Intel不该如此吧

你肯定吗,82801是桥芯片组啊

别是螃蟹的网卡卡芯片


那是lspci列出的啊



螃蟹卡以前有这毛病,Intel的真不知道了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译