当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-04-26 16:21 

注册: 2008-10-03 2:10
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
networkmanager 显示有线网络设备未托管,现在有线、dsl都没法用了,有谁知道解决办法吗?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-04-26 17:49 

注册: 2008-11-25 17:20
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
我的也是这种情况。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-04-26 21:26 

注册: 2008-11-25 17:20
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
我把这个网络管理小程序个删掉了,重新启动后,sudo pppoeconf之后就又能上网了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-04-29 23:01 

注册: 2008-06-12 20:52
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
在nm-connection-editor中把ADSL的用户名和密码在DSL里设置好。
把/etc/network/interfaces和/etc/resolv.conf备份一下都删除。
然后重启或重启网络,就会自动上拨号


页首
 用户资料  
 
5 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-05-02 17:44 

注册: 2008-02-18 10:06
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
我的也是,但可以上网,奇怪!根据楼上老师的做了,但找到文件后,删除不了,看来需要使用命令来强行删除,所以暂时未动,等待救援!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-05-03 9:16 

注册: 2009-04-21 11:37
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
3楼的方法可行,可以安装拨号软件这样就不用每次都用命令。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-05-07 8:18 

注册: 2009-04-11 10:12
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
打开/etc/NetworkManager/nm-system-settings.conf

将false改成true,重启一下就可以了。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-07-14 23:37 

注册: 2009-07-01 22:10
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
果然7楼高手!!!在下佩服!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-07-18 21:03 

注册: 2007-11-05 23:52
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
直接换wicd 一劳永逸 我实在受不在nm隔三差五的不起作用 直接iwcofig比它还稳定
intel 3945abg


页首
 用户资料  
 
10 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-08-06 16:38 

注册: 2009-07-15 14:56
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
我把false改成true了,然后用sudo /etc/init.d/networking restart 重启网络服务,出现了下面的提示,


* Reconfiguring network interfaces...
WARNING: ifup -a is disabled in favour of NetworkManager.
Set ifupdown:managed=false in /etc/NetworkManager/nm-system-settings.conf.
[ OK ]
这怎么提示managed=false啊,我重启过电脑啊?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-09-10 18:14 

注册: 2009-08-18 11:37
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我和10楼一样 郁闷,10楼的问题有没有解决啊


页首
 用户资料  
 
12 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2009-09-13 0:18 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
shendapeng 写道:
我把false改成true了,然后用sudo /etc/init.d/networking restart 重启网络服务,出现了下面的提示,


* Reconfiguring network interfaces...
WARNING: ifup -a is disabled in favour of NetworkManager.
Set ifupdown:managed=false in /etc/NetworkManager/nm-system-settings.conf.
[ OK ]
这怎么提示managed=false啊,我重启过电脑啊?


Linux里面有两套管理网络连接的方案:
1、/etc/network/interfaces(/etc/init.d/networking)
2、Network-Manager

两套方案是冲突的,不能同时共存。
第一个方案适用于没有X的环境,如:服务器;或者那些完全不需要改动连接的场合。
第二套方案使用于有桌面的环境,特别是笔记本,搬来搬去,网络连接情况随时会变的。

-------------
他们两个为了避免冲突,又能共享配置,就有了下面的解决方案:
1、当Network-Manager发现/etc/network/interfaces被改动的时候,则关闭自己(显示为未托管),除非managed设置成真。
2、当managed设置成真时,/etc/network/interfaces,则不生效。

-------------


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表



_________________
评价: 3.85% macong
 
页首
 用户资料  
 
13 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2010-03-06 21:28 
头像

注册: 2009-07-27 11:03
帖子: 239
地址: 广东 深圳
送出感谢: 0 次
接收感谢: 0 次
我也遇到了,9.10的Network Manager确实有bug! ADSL直接拨号的用pppoeconf很方便。
参考:http://wiki.ubuntu.org.cn/ADSL%EF%BC%88PPPOE%EF%BC%89%E6%8E%A5%E5%85%A5%E6%8C%87%E5%8D%97


_________________
服务器运维与架构 ha97.com


页首
 用户资料  
 
14 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2010-08-31 21:30 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
steven zhao 写道:
打开/etc/NetworkManager/nm-system-settings.conf

将false改成true,重启一下就可以了。


问题解决! :em11


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
15 楼 
 文章标题 : Re: networkmanager 显示有线网络设备未托管
帖子发表于 : 2010-12-06 9:42 

注册: 2010-05-13 20:02
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
cnkilior 写道:
shendapeng 写道:
我把false改成true了,然后用sudo /etc/init.d/networking restart 重启网络服务,出现了下面的提示,


* Reconfiguring network interfaces...
WARNING: ifup -a is disabled in favour of NetworkManager.
Set ifupdown:managed=false in /etc/NetworkManager/nm-system-settings.conf.
[ OK ]
这怎么提示managed=false啊,我重启过电脑啊?


Linux里面有两套管理网络连接的方案:
1、/etc/network/interfaces(/etc/init.d/networking)
2、Network-Manager

两套方案是冲突的,不能同时共存。
第一个方案适用于没有X的环境,如:服务器;或者那些完全不需要改动连接的场合。
第二套方案使用于有桌面的环境,特别是笔记本,搬来搬去,网络连接情况随时会变的。

-------------
他们两个为了避免冲突,又能共享配置,就有了下面的解决方案:
1、当Network-Manager发现/etc/network/interfaces被改动的时候,则关闭自己(显示为未托管),除非managed设置成真。
2、当managed设置成真时,/etc/network/interfaces,则不生效。

-------------


12楼说有很明白,不过还是没有解决问题等于没回答。问的是西北风回答的是追风马,无益。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译