当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 26 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-27 9:50 

注册: 2009-07-22 5:46
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我的情况是这样的,房东是路由器adsl上网,我们是接的路由器,而且房东在路由器上给每台机子绑定了局域网ip,这样是为了出了问题,好找是谁干的。我拔掉我机子的网线,ubuntu的链接图标就显示未链接状态,插上网线就显示链接状态。但是就是ping不通网关,什莫也ping不通!都是显示Destination Host Unreachable。同样配置xp上正常上网。

以下是
fly@fly-net:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:16:17:93:55:39
inet addr:192.168.1.105 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::216:17ff:fe93:5539/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1300 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:5000 (5.0 KB)
Interrupt:20 Base address:0xcc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1262 (1.2 KB) TX bytes:1262 (1.2 KB)

pan0 Link encap:Ethernet HWaddr 0e:16:a2:a8:13:5e
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

fly@fly-net:~$
fly@fly-net:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 100 0 0 eth0
fly@fly-net:~$
fly@fly-net:~$ arp -an
? (192.168.1.1) at <incomplete> on eth0
fly@fly-net:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1300 qdisc pfifo_fast state UNKNOWN qlen 1000
link/ether 00:16:17:93:55:39 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.105/24 brd 192.168.1.255 scope global eth0
inet6 fe80::216:17ff:fe93:5539/64 scope link
valid_lft forever preferred_lft forever
3: pan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
link/ether 0e:16:a2:a8:13:5e brd ff:ff:ff:ff:ff:ff
fly@fly-net:~$
fly@fly-net:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.105 icmp_seq=1 Destination Host Unreachable
From 192.168.1.105 icmp_seq=2 Destination Host Unreachable
From 192.168.1.105 icmp_seq=6 Destination Host Unreachable
^C
--- 192.168.1.1 ping statistics ---
9 packets transmitted, 0 received, +6 errors, 100% packet loss, time 8046ms
, pipe 3
fly@fly-net:~$


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-27 9:56 
头像

注册: 2007-04-14 11:17
帖子: 1035
送出感谢: 0 次
接收感谢: 2
是不是得需要pppoeconf拨号啊?
我这里是需要的,先五连连接上,然后再用pppoeconf。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-27 10:07 
头像

注册: 2009-05-20 19:32
帖子: 2462
送出感谢: 0 次
接收感谢: 2
irc <r_444444> say: 静态IP?DHCP?掩码?网关?


_________________
irc 聊天室
ubuntu-cn 的irc 频道为
irc.ubuntu.com 8001 #ubuntu-cn
UTF8编码 可用 irssi xchat pidgin weechat 登录

http://webchat.freenode.net/?channels=ubuntu-cn
irc://irc.freenode.net/ubuntu-cn


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-27 10:47 

注册: 2009-07-22 5:46
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
dwl301 写道:
是不是得需要pppoeconf拨号啊?
我这里是需要的,先五连连接上,然后再用pppoeconf。

那需要帐号密码吗?房东肯定不给我了,另外为什莫windows xp就不需要呢?局域网内的机子只是连路由还不行吗?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-27 17:08 

注册: 2009-07-27 16:11
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
呵呵呵 无奈吧 我的也联不上网
在Vista下很轻松的事
到这我都整了很久了 还还是联不上
等待高手帮忙


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-27 22:46 

注册: 2009-07-22 5:46
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
angeldeangel 写道:
呵呵呵 无奈吧 我的也联不上网
在Vista下很轻松的事
到这我都整了很久了 还还是联不上
等待高手帮忙

沉默无语了,是什末问题呢? 是内核我换内核,是配置问题我改配置,是驱动问题我换驱动,是网卡问题我换网卡.
是什末问题呢?谁知道?????????????


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-27 22:47 

注册: 2009-07-22 5:46
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
就这点,怎莫和win争市场?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-27 23:56 

注册: 2006-11-27 12:25
帖子: 458
送出感谢: 0 次
接收感谢: 0 次
你的机子的IP是怎么来的?自己设置的?还是通过路由器的DHCP服务分配的?
房东的是如何做到IP梆定的?

能贴一下你的/etc/network/interfaces文件吗?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-28 9:34 

注册: 2009-07-22 5:46
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
/etc/network/interfaces

auto lo
auto eth0
iface lo inet loopback

iface eth0 inet static
address 192.168.1.105
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
-----------------------------------------------------------------------
路由把ip和mac绑定了。

我现在很怀疑是网卡的驱动不对头,我在xp下,换了网卡的最新的windows xp驱动,结果就出现和linux下类似的情况,ping不通网关,但显示连接状态。我有换回机子原带的驱动就又好了。
网卡是r8169。我下载了官方最新的r8169 linux驱动,然后安装上,问题还是那样。谁有在用的r8169的linux驱动呢???


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-28 10:35 

注册: 2005-11-15 23:10
帖子: 61
送出感谢: 0 次
接收感谢: 0 次
楼主都有路由了,还拔鸟号干啥啊。
gnome的网络设置一下就好了。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-28 11:37 
头像

注册: 2009-05-27 21:55
帖子: 1394
送出感谢: 1
接收感谢: 0 次
我 猫坏拉
向联通换了一个, :em05


_________________


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-28 12:55 

注册: 2009-07-28 12:38
帖子: 280
送出感谢: 0 次
接收感谢: 0 次
我刚安装好904,情况和楼主一样, :em06
奇怪的是我在图形界面设置IP地址时网关地址192.168.1.1一直设置不成功,显示为空
删除那个网络管理器,然后终端添加IP静态地址。。。。。还是一样 :em20
不知是不是要添加路由表设置。。。。。。还在努力 :em11


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-28 12:57 

注册: 2009-07-28 12:38
帖子: 280
送出感谢: 0 次
接收感谢: 0 次
引用:
/etc/network/interfaces

auto lo
auto eth0
iface lo inet loopback

iface eth0 inet static
address 192.168.1.105
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
-----------------------------------------------------------------------



那个nework 192.168.1.0是什么? :em23


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-28 13:10 

注册: 2008-03-30 8:46
帖子: 557
地址: 江西吉安
送出感谢: 1
接收感谢: 0 次
试一下ifup eth0看看,或许网卡木激活?


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 上不去网,一个月了,上不去网
帖子发表于 : 2009-07-28 14:02 

注册: 2006-11-27 12:25
帖子: 458
送出感谢: 0 次
接收感谢: 0 次
可能是nm-applet和NetworManager冲突了。你的/etc/network/interfaces文件做了设置,但看你的描述,又是用NetworkManager来管理网络。试一下如下的修改:
方法一:用NetworkManager来管理网络,而不使用nm-applet:
1、修改/etc/network/interfaces文件,将eth0的设置全部注释掉,仅留下lo的设置,也就是说保留如下两行,其他都不要:
auto lo
iface lo inet loopback
2、再修改/etc/NetworkManager/nm-system-settings.conf文件,做下面的修改:
将managed=false 改为 managed=true
稳阵起见,重启一下电脑,再试一下。
方法二:干脆将NetworkManager卸载掉,仅使用nm-applet来管理网络。
我建议试一下方法一。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 26 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译