当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-08-09 9:30 

注册: 2009-02-03 14:52
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04.
我安装了 wvdial和vodafone-mobile-connect 还是不行啊
运行vodafone-mobile-connect 出现提示:没有vmc.common.startup
运行wvdial也不行,msn和firefox都不能用。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-08-10 21:00 

注册: 2009-02-03 14:52
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
希望高手帮帮忙啊


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-08-17 11:07 

注册: 2009-06-19 1:45
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
REF: http://www.linuxsir.org/bbs/showthread. ... ost2014246
安装软件:
1. usb_modeswitch(版本0.9.4不行,要安装1.0.2)
2. wvdial

更改配置文件
1. 此文件 /etc/udev/rules.d/50-zte-mu350.rules 如果没有,可以创建一个
代码:
# /etc/udev/rules.d/50-zte-mu350.rules
ACTION=="add", SUBSYSTEM=="usb", DRIVERS=="usb", ATTR{idVendor}=="19d2", ATTR{idProduct}=="0003",  RUN+="/usr/sbin/usb_modeswitch -v %s{idVendor} -p %s{idProduct} -M 5553424312345678000000000000061b000000020000000000000000000000 -R 1"
# 卸载自动加载成硬盘
SUBSYSTEM=="usb", SYSFS{idProduct}=="0003", SYSFS{idVendor}=="19d2", RUN+="/sbin/modprobe usbserial vendor=0x19d2 product=0x0003"
#将MU350转换成串口modem,如果你用的不是MU350,请将vendor, product 改正 


2. /etc/wvdial.conf
代码:
[Dialer Defaults]
Modem = /dev/ttyUSB2
Init1 = ATZ
Init3 = ATE0V1
Init5 = ATS0=0
Init6 = AT+CGDCONT=1,"IP","cmnet"
Init7 = AT+CFUN=1
Modem Type = USB Modem
Baud = 460800
New PPPD = yes
ISDN = 0
Phone = *98*1#
Password = any
Username = any
Stupid Mode = 1


设置权限,将自己加入以下组dailout, uucp, plugdev,netdev
sudo wvdial就可以上网了


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-08-27 9:33 

注册: 2009-02-03 14:52
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我的现在可以连接上,也能PING 通外面的网站,但是就是不能用firefox上网,PIDGIN也登不了。

sudo wvdial 的反馈也是连接上的。
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATE0V1
OK
--> Sending: ATS0=0
OK
--> Sending: AT+CGDCONT=1,"IP","cmnet"
OK
--> Sending: AT+CFUN=1
OK
--> Modem initialized.
--> Sending: ATDT*98*1#
--> Waiting for carrier.
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sun Jun 21 00:38:50 2009
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 4765
--> Using interface ppp0
--> pppd: ��[07][08]��[07][08]��[07][08]X�[07][08]
--> pppd: ��[07][08]��[07][08]��[07][08]X�[07][08]
--> pppd: ��[07][08]��[07][08]��[07][08]X�[07][08]
--> pppd: ��[07][08]��[07][08]��[07][08]X�[07][08]
--> local IP address 10.140.223.148
--> pppd: ��[07][08]��[07][08]��[07][08]X�[07][08]
--> remote IP address 192.168.0.1
--> pppd: ��[07][08]��[07][08]��[07][08]X�[07][08]
--> primary DNS address 221.130.33.60
--> pppd: ��[07][08]��[07][08]��[07][08]X�[07][08]


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-09-13 1:01 

注册: 2005-10-27 23:16
帖子: 80
送出感谢: 0 次
接收感谢: 1
我的已经可以了,美中不足的是不能在网络管理器中显示网络连接状态,还有就是流量无法统计。

楼上的状态我看应该是已经可以上网了啊,已经显示和我一样了。是不是没有把浏览器的脱机给去掉?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-09-13 1:04 

注册: 2005-10-27 23:16
帖子: 80
送出感谢: 0 次
接收感谢: 1
刚开始拿到这张卡还心中一凉,里面的包装明确写明了不支持MAC、Linux等操作系统。希望中兴尽快推出官方的Driver。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-09-15 8:13 

注册: 2006-04-13 13:53
帖子: 305
送出感谢: 0 次
接收感谢: 1
lisheng 写道:
刚开始拿到这张卡还心中一凉,里面的包装明确写明了不支持MAC、Linux等操作系统。希望中兴尽快推出官方的Driver。

希望能早点推出


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-11-03 17:52 

注册: 2009-11-03 8:37
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
:em06 :em06 :em06

兄弟们,帮我看看。我的也是ZTE MU351, 按照上面说的,通过新立得装了usb_modeswitch 1.0.2 和 wvdial 1.6.0。结果现在还是认不出modem!!!

~$ lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04fc:05da Sunplus Technology Co., Ltd
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 003: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
Bus 005 Device 002: ID 0a5c:2110 Broadcom Corp. Bluetooth Controller
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 19d2:0003 ONDA Communication S.p.A.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

dmesg 结果如下:
[ 295.653064] usb 4-1: new full speed USB device using uhci_hcd and address 2
[ 295.819254] usb 4-1: configuration #1 chosen from 1 choice
[ 296.016124] usb 4-1: USB disconnect, address 2
[ 296.935030] usbcore: registered new interface driver usbserial
[ 296.935060] USB Serial support registered for generic
[ 296.935135] usbcore: registered new interface driver usbserial_generic
[ 296.935139] usbserial: USB Serial Driver core
[ 296.975580] Initializing USB Mass Storage driver...
[ 296.975689] usbcore: registered new interface driver usb-storage
[ 296.975695] USB Mass Storage support registered.
[ 298.404059] usb 4-1: new full speed USB device using uhci_hcd and address 3
[ 298.566455] usb 4-1: configuration #1 chosen from 1 choice
[ 298.572350] usbserial_generic 4-1:1.0: generic converter detected
[ 298.572463] usb 4-1: generic converter now attached to ttyUSB0
[ 298.573970] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[ 298.573998] usbserial_generic 4-1:1.0: device disconnected
[ 299.700064] usb 4-1: reset full speed USB device using uhci_hcd and address 3

usb_modeswitch -W (找不到 Vendor ID, 所以Abort :em06 :em06 :em06 :em20 :em20

* usb_modeswitch: tool for controlling "flip flop" mode USB devices
* Version 1.0.2 (C) Josua Dietze 2009
* Works with libusb 0.1.12 and probably other versions

Reading config file: /etc/usb_modeswitch.conf
DefaultVendor= 0x0000
DefaultProduct= 0x0000
TargetVendor= not set
TargetProduct= not set
TargetClass= not set

DetachStorageOnly=0
HuaweiMode=0
SierraMode=0
SonyMode=0
MessageEndpoint= not set
MessageContent= not set
NeedResponse=0
ResponseEndpoint= not set
Interface=0x00

InquireDevice enabled (default)
Success check disabled

usb_set_debug: Setting debugging level to 15 (on)
usb_os_find_busses: Found 003
usb_os_find_busses: Found 002
usb_os_find_busses: Found 001
usb_os_find_busses: Found 005
usb_os_find_busses: Found 004
usb_os_find_devices: couldn't get connect info
usb_os_find_devices: Found 001 on 003
error obtaining child information: Operation not permitted
usb_os_find_devices: couldn't get connect info
usb_os_find_devices: Found 002 on 002
skipped 1 class/vendor specific interface descriptors
usb_os_find_devices: couldn't get connect info
usb_os_find_devices: Found 001 on 002
error obtaining child information: Operation not permitted
error obtaining child information: Operation not permitted
usb_os_find_devices: couldn't get connect info
usb_os_find_devices: Found 001 on 001
error obtaining child information: Operation not permitted
usb_os_find_devices: Found 003 on 005
usb_os_find_devices: couldn't get connect info
usb_os_find_devices: Found 002 on 005
skipped 1 class/vendor specific interface descriptors
usb_os_find_devices: couldn't get connect info
usb_os_find_devices: Found 001 on 005
error obtaining child information: Inappropriate ioctl for device
error obtaining child information: Operation not permitted
error obtaining child information: Operation not permitted
usb_os_find_devices: couldn't get connect info
usb_os_find_devices: Found 003 on 004
usb_os_find_devices: couldn't get connect info
usb_os_find_devices: Found 001 on 004
error obtaining child information: Operation not permitted
error obtaining child information: Operation not permitted

No default vendor/product ID given. Aborting.

我完全是照本帖的流程操作的,麻烦大家帮忙看看阿。

PS: 我用新立的装完以后,担心装得有问题,就删除后想手动重装。

结果,提示如下,不知道有没有什么关联?
~/usb_modeswitch-1.0.2$ make install
mkdir -p /usr/sbin
install ./usb_modeswitch /usr/sbin
install: 无法删除 “/usr/sbin/usb_modeswitch”: Permission denied
make: *** [install] 错误 1


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-11-03 18:45 

注册: 2009-11-03 8:37
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我的问题似乎和 viewtopic.php?f=116&t=230170 文章提到的类似,可能都是把光驱/U盘/Mondem 一起识别出来了。

我用
ACTION=="add", SUBSYSTEM=="usb", DRIVERS=="usb", \
ATTR{idVendor}=="19d2", ATTR{idProduct}=="0003", \
RUN+="/usr/sbin/vmc-usb_modeswitch-eject.sh %s{idVendor} %s{idProduct}"
替换了本帖在/etc/udev/rules.d/50-zte-mu350.rules 的内容,然后重新启动。目前是可以识别网卡了。(现在的指示灯是蓝色的。)

目前wvdial拨号还是有问题,如下
wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATE0V1
OK
--> Sending: ATS0=0
OK
--> Sending: AT+CGDCONT=1,"IP","cmnet"
OK
--> Sending: AT+CFUN=1
OK
--> Modem initialized.
--> Sending: ATDT*98*1#
--> Waiting for carrier.
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.


ERROR
--> Invalid dial command.
--> Disconnecting at Tue Nov 3 18:46:45 2009


但总算比刚才前进了一步。 :em11 :em11


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-11-03 19:25 

注册: 2009-11-03 8:37
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
下面帖子的东西有些参考价值,但是我填了PPPD Path = /usr/sbin/pppd之后,还是显示 unable to run /usr/sbin/pppd

viewtopic.php?f=28&t=231599
(我的IBM X31老机上hiweed,比之前的9.04确实快了不少)
1,先安装wvdial
2,配置 /etc/wvdial.conf 内容网上可以搜到,要加一句:
PPPD Path = /usr/sbin/pppd
不然可能会提示 unable to run /usr/sbin/pppd
3, 在终端中拨号用 sudo wvdial cdma3g(这个名字在wvdial.conf 中自己定)
我就是没有用sudo 所以一直上不去
可能要改 /usr/sbin/pppd 的执行权限,我也没闹懂怎么改

另外,用sudo wvdial 代替 wvdial, 出现下面的新情况

~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
--> Re-Sending: ATZ
--> Modem not responding.


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-11-03 20:40 

注册: 2009-11-03 8:37
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
郁闷,重新启动以后,又回到了解放前。系统又认不出351卡了。今天尝试到此为止,等待高手指点。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-11-03 21:42 

注册: 2009-02-03 14:52
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我的已经OK了。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-11-03 22:55 

注册: 2005-10-27 23:16
帖子: 80
送出感谢: 0 次
接收感谢: 1
有没有哪位试过直接用网络管理器拨号成功的?以前9.04会识别出3个设备,9.10进步了,只会识别出一个设备了,但是拨号不成功。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-11-04 23:32 

注册: 2009-11-03 8:37
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
:em20 :em20

Mark 一下,今天本来想升级一下固件,看看有什么新发现。结果,刷成砖了。我的是G3随E行的MU351


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 中兴mu351无线网卡怎么安装不了啊?我的是ubuntu 9.04
帖子发表于 : 2009-11-13 20:58 

注册: 2009-09-20 13:32
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
pppd问题的同学 ,执行以下命令sudo adduser x (x是用户名) root 重启再拨号看看。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译