当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : firefox不能启动啦,提示Permission denied
帖子发表于 : 2009-09-03 16:19 
头像

注册: 2008-11-03 14:59
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
按照网上月光博客的方法,将我的9.04d的firefox换成3.5 的,接着问题就出现了。点击firefox时提示Permission denied,然后在新立得里将其标记重新安装和卸载重装都不行,请问这是怎么回事啊?
这个是月光博客里说的方法:
“Ubuntu安装完成后会自动安装一个Firefox浏览器,遗憾的是这个Firefox版本通常较低,例如Ubuntu 9.04会安装Firefox 3.0,不过我们可以想办法下载最新的Firefox覆盖掉老版本Firefox,具体方法是,先上Firefox官方网站下载最新的Linux版本 Firefox,然后将其解压缩到某一个目录下,例如firefox目录,进入终端,到这个目录的父目录,执行下面的语句:

  sudo cp -r firefox /usr/lib/firefox-3.5.2

  sudo mv /usr/bin/firefox /usr/bin/firefox.old

  sudo ln -s /usr/lib/firefox-3.5.2/firefox /usr/bin/firefox-3.5.2

  sudo ln -s /usr/bin/firefox-3.5.2 /usr/bin/firefox

  之后就可以将Firefox成功替换为最新的Firefox 3.52版本,未来的Firefox更新也可以使用这种方法。”
我记得以前用过这个方法,没什么问题出现,这次重装就有了这个问题,郁闷。
补充一下,在终端里直接firefox不行,提示没安装,然后sudo firefox就可以打开了,这样太麻烦了吧?


附件:
Screenshot.png
Screenshot.png [ 17.38 KiB | 被浏览 563 次 ]


_________________
要好好混论坛

blog: http://zhiwei.in
页首
 用户资料  
 
2 楼 
 文章标题 : Re: firefox不能启动啦,提示Permission denied
帖子发表于 : 2009-09-03 16:26 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
改一下用户组也不行?


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
3 楼 
 文章标题 : Re: firefox不能启动啦,提示Permission denied
帖子发表于 : 2009-09-03 16:29 
头像

注册: 2008-11-03 14:59
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
tenzu 写道:
改一下用户组也不行?

你的意思是将自己改为一个权限更高的用户?那其他的软件会不会有影响?


_________________
要好好混论坛

blog: http://zhiwei.in


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译