当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]无线网卡不能用,蓝牙也跟着不能用了,希望有人能帮助我
帖子发表于 : 2010-02-26 16:31 

注册: 2007-11-24 22:04
帖子: 137
送出感谢: 0 次
接收感谢: 0 次
UPDATE:我重新恢复了一遍bios的初始设置就ok了,我想可能在windows的时候关闭了无线网卡,导致修改了某些隐藏的bios设置的关系。

这次我绝对把硬件开关打开了,而且Y450A的BIOS里面几乎没什么东西可设置,也肯定打开wifi了。如果bios里面禁用wifi的话,gnome的默认applet会不显示无线网卡存在,但是现在的情况是它提示“无线网络已禁用”。找了一下午辙了,实在没办法,希望有人能帮助我,笔记本突然性失去这两个功能有点不爽。

iwconfig
wlan0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

ifconfig -a
wlan0 Link encap:以太网 硬件地址 00:1e:65:e7:d5:9c
BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)

lsmod|grep iwl
iwlagn 125914 0
iwlcore 130873 1 iwlagn
mac80211 243533 2 iwlagn,iwlcore
cfg80211 152955 3 iwlagn,iwlcore,mac80211
compat_firmware_class 8491 1 iwlagn

lspci|grep 5100
06:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

dmesg|grep agn
[ 13.069025] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 2.6.32-14-generic-ks
[ 13.069028] iwlagn: Copyright(c) 2003-2009 Intel Corporation
[ 13.069110] iwlagn 0000:06:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 13.069119] iwlagn 0000:06:00.0: setting latency timer to 64
[ 13.070891] iwlagn 0000:06:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
[ 13.090510] iwlagn 0000:06:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[ 13.090665] iwlagn 0000:06:00.0: irq 31 for MSI/MSI-X
[ 13.271708] phy0: Selected rate control algorithm 'iwl-agn-rs'


最后由 dqh3000 编辑于 2010-02-28 12:01,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 无线网卡不能用,蓝牙也跟着不能用了,希望有人能帮助我
帖子发表于 : 2010-02-27 0:53 

注册: 2007-11-24 22:04
帖子: 137
送出感谢: 0 次
接收感谢: 0 次
笔记本是Y450A,本来Fn+F5是默认的无线开关,但是不好使啊

老贴有人说要装个windows,然后windows里面开启无线网络就可以了……这不是瞎扯吗……我上哪装个windows啊,求求各位了


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 无线网卡不能用,蓝牙也跟着不能用了,希望有人能帮助我
帖子发表于 : 2010-02-27 18:24 

注册: 2009-09-21 17:27
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
Intel Corporation PRO/Wireless 5100 AGN

打开终端,输入:
gksudo iwconfig wlan0 power on


_________________
喀纳斯自由软件专卖店
出售Ubuntu 自启动优盘,各种linux DVD光盘,开源文化衫
提供各种linux解决方案。
每出售一件商品,将捐献一元给相关社区。
近期捐款将用于支持GNOME ASIA Summit 2010.
QQ:1217577689
MSN:kanas123@yahoo.cn


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 无线网卡不能用,蓝牙也跟着不能用了,希望有人能帮助我
帖子发表于 : 2010-02-27 20:55 

注册: 2007-11-24 22:04
帖子: 137
送出感谢: 0 次
接收感谢: 0 次
opbsder 写道:
Intel Corporation PRO/Wireless 5100 AGN

打开终端,输入:
gksudo iwconfig wlan0 power on


电源是能打开
wlan0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on

但是ifconfig wlan0 up还是打不开,会提示
SIOCSIFFLAGS: 未知错误 132


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [已解决]无线网卡不能用,蓝牙也跟着不能用了,希望有人能帮助我
帖子发表于 : 2010-03-19 22:39 
头像

注册: 2010-03-17 17:03
帖子: 445
地址: 北京市海淀区
送出感谢: 0 次
接收感谢: 0 次
恢复Bios初始设置确实可用 谢谢楼主
PS.我的本本也是Ideapad Y450 现在终于完美了
楼主万岁


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [已解决]无线网卡不能用,蓝牙也跟着不能用了,希望有人能帮助我
帖子发表于 : 2011-10-01 21:38 
头像

注册: 2010-01-31 15:12
帖子: 71
地址: 地球
送出感谢: 0 次
接收感谢: 0 次
因为要陪人去买本,所以昨天晚上做了个LiveUSB准备拿到卖场去测试机器,做好后在自己的本上启动了一次就关机睡了,结果今晚回来就出了相同的状况,驱动没问题,但无线指示灯就是不亮,输入
sudo ifconfig wlan0 up 提示
SIOCSIFFLAGS: 未知错误 132

根据这个错误提示搜到了此帖,重置BIOS为初始设置的确就解决问题了,我仔细看了重置前后的变化,Wireless状态都是Enable, 只是 SATA Controller Mode 由 Non-AHCI 变成了AHCI, 看来用LiveUSB启动机器可能会自动修改BIOS的设置。


_________________
才登船便知终究要弃船


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译