网卡不能识别

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
tozp
帖子: 36
注册时间: 2006-11-24 22:17
送出感谢: 0
接收感谢: 0
联系:

网卡不能识别

#1

帖子 tozp » 2010-05-26 12:56

硬件:
笔记本型号:惠普520,网卡型号 Intel pro/100 ve adapter.

软件:
已经安装Windows 7,OEM激活……嘿嘿!网卡正常使用。
wubi安装Ubuntu 10.04后,发现不能识别网卡,后来用虚拟机安装,也是不能识别,后来以为是版本问题,换成原来可以正常使用的9.10后问题依旧,9.04问题依旧,然后就不用尝试了,另,无线网卡一切正常。

表现:
Ubuntu上面状态栏中网卡图标灰色,Config Connection对话框中MAC Address一栏空白,也就是说查不出来存在网卡硬件。

不知道上面说清楚了没有,如果没有请提示我一下,一直想解决这个问题,网上也找不到答案,所以来这里请教各位大侠,非常感谢你的帮助!
tozp
帖子: 36
注册时间: 2006-11-24 22:17
送出感谢: 0
接收感谢: 0
联系:

Re: 网卡不能识别

#2

帖子 tozp » 2010-05-26 13:00

哦,Ubuntu不能识别网卡,重新进去Windows一点影响都没有,照样上网。就是Ubuntu下面不认识我的网卡。后来专门查到对应的驱动型号,发现内核中已经自带,重新加载一次,依然问题依旧……
头像
monk
帖子: 19507
注册时间: 2010-01-28 10:45
送出感谢: 6 次
接收感谢: 33 次

Re: 网卡不能识别

#3

帖子 monk » 2010-05-27 13:31

分别输入以下命令,贴结果
ifconfig
iwconfig

*********宁静致远*********
如果我说的有什么不对,请看签名第一行
tozp
帖子: 36
注册时间: 2006-11-24 22:17
送出感谢: 0
接收感谢: 0
联系:

Re: 网卡不能识别

#4

帖子 tozp » 2010-05-27 15:09

monk 写了:分别输入以下命令,贴结果
ifconfig
iwconfig

代码: 全选

tozp@ubuntu:~$ ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:1f:3c:74:53:f8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-1F-3C-74-53-F8-00-00-00-00-00-00-00-00-00-00  
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

tozp@ubuntu:~$ iwconfig
lo        no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=12 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
谢谢帮我分析一下。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 网卡不能识别

#5

帖子 eexpress » 2010-05-27 15:17

分析结果:果然没认出来。
:em04
按照网卡型号搜索吧。
● 鸣学
tozp
帖子: 36
注册时间: 2006-11-24 22:17
送出感谢: 0
接收感谢: 0
联系:

Re: 网卡不能识别

#6

帖子 tozp » 2010-05-27 15:47

我的是Intel 945自带的网卡啊,不是那么稀缺吧……请问如何安装?
头像
monk
帖子: 19507
注册时间: 2010-01-28 10:45
送出感谢: 6 次
接收感谢: 33 次

Re: 网卡不能识别

#7

帖子 monk » 2010-05-27 17:25


*********宁静致远*********
如果我说的有什么不对,请看签名第一行
阿萨斯
帖子: 21
注册时间: 2010-05-08 12:45
送出感谢: 0
接收感谢: 0

Re: 网卡不能识别

#8

帖子 阿萨斯 » 2010-05-28 10:50

已经能识别了,ifconfig 能见到wlan0就已经是能识别了。
tozp
帖子: 36
注册时间: 2006-11-24 22:17
送出感谢: 0
接收感谢: 0
联系:

Re: 网卡不能识别

#9

帖子 tozp » 2010-06-01 10:43

楼上的哥们,wlan0是出来了,那个是无线网卡,我的无线网卡本来就正常,不正常的是有线的,呵呵,谢谢你。
回复

回到 “网卡问题以及网络和拨号”