当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 水星MW54u在ubuntu 9.10下的不能使用的问题,求助!!!!
帖子发表于 : 2010-07-26 23:24 

注册: 2010-07-26 22:56
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
本人是linux初学者,说错的地方请大家包含。 :em06
昨天我家装了电信宽带,用usb 借口的无线网卡连着电信猫,无线网卡的型号是MW54u,我在网上查了一下,说它的芯片属于Rt2571系列,我也在/lib/firmware 文件夹下找到了Rt2571系列芯片的驱动 rt73.bin。但问题是我的网卡灯亮都不亮一下,linux好像没有去主动识别,在windows 下一进系统网卡灯就狂闪。这是为什么,难道我的无线网络支持没有开?
我的linux内核版本是2.6 server
请各位前辈指点指点!!!!!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 水星MW54u在ubuntu 9.10下的不能使用的问题,求助!!!!
帖子发表于 : 2010-07-27 9:34 

注册: 2010-07-26 22:56
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
没人帮我啊?自己顶起

我用IFCONFIG查看网卡只有三个网卡,一个虚拟的 一个回环的 一个真实网卡
我用iwconfig提示没有,真的是内核的无线网络支持没有开?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 水星MW54u在ubuntu 9.10下的不能使用的问题,求助!!!!
帖子发表于 : 2010-07-27 10:05 

注册: 2010-07-18 18:15
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也是用這個型號的網卡,也不亮,同求方法


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 水星MW54u在ubuntu 9.10下的不能使用的问题,求助!!!!
帖子发表于 : 2010-07-29 13:41 

注册: 2006-10-30 21:39
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
action_reg 写道:
本人是linux初学者,说错的地方请大家包含。 :em06
昨天我家装了电信宽带,用usb 借口的无线网卡连着电信猫,无线网卡的型号是MW54u,我在网上查了一下,说它的芯片属于Rt2571系列,我也在/lib/firmware 文件夹下找到了Rt2571系列芯片的驱动 rt73.bin。但问题是我的网卡灯亮都不亮一下,linux好像没有去主动识别,在windows 下一进系统网卡灯就狂闪。这是为什么,难道我的无线网络支持没有开?
我的linux内核版本是2.6 server
请各位前辈指点指点!!!!!


usb的RaLink系列的无线网卡指示灯的确是不同,在没有正确驱动之前,多个发行版上openwrt.debian.fd都是一直亮灯,在win是闪烁的。

rt2571有一个衍生的rt2571w,对应了两个不同的驱动模块,你要用dmesg查看清楚,如果不行拆卡来看看。

rt2571对应rt2500模块,rt2571w对应rt73模块,用lsmod看看内核是否包含这些驱动

很早的内核2.6.18/2.6.24几乎都包含了这两个模块,另外rt2571模块不需要firmware,rt2571w需要,在这里下载
http://www.ralinktech.com.tw/license_cn ... TVM0NEM%3D

都是很老的无线网卡了,linux内核肯定支持的,我在debian和openwrt backfire下驱动了所有的RALINK系列的无线网卡,包括54G,108M,300M(openwrt还没解决3070sta),固件是ralink官方,驱动模块是内核官方,我没用过ralink自己的驱动

另外还有个经验,如果内核包含了很多ralink系列的模块,需要做一下mod的blacklist

这些都是我在debian和openwrt的经验,供你参考一下

补充一下,有时内核版本的问题,你可以做一下这些动作
# modprobe rt2500usb
# ifconfig wlan0 down //假设wlan0是无线接口名称
# vim /etc/network/interface
# ifconfig wlan0 up


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 水星MW54u在ubuntu 9.10下的不能使用的问题,求助!!!!
帖子发表于 : 2010-08-01 22:33 

注册: 2010-07-26 22:56
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
谢谢 tsengtim 前辈
但是有个很严重的问题 iwconfig 看不到wlan0 只有 lo和eth0


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 水星MW54u在ubuntu 9.10下的不能使用的问题,求助!!!!
帖子发表于 : 2010-08-02 0:06 

注册: 2006-10-30 21:39
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
我用的是debian 6,内核认出的第一片无线网卡接口名字是wlan0,我在这里看了几个帖子,估计接口名字应该是 ethxxxxxxx 之类的

对了,这卡的芯片你有无搞错的,我查到的资料有说是ralink的,也有说是atheros的,贴下dmesg和lsusb信息看看


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 水星MW54u在ubuntu 9.10下的不能使用的问题,求助!!!!
帖子发表于 : 2010-08-02 9:59 

注册: 2010-07-26 22:56
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
lsusb的结果,看样子确实是atheros,另外我的pc架构是amd64,不知道你给我的固件能不能用
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 093a:2510 Pixart Imaging, Inc. Hama Optical Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0cf3:1006 Atheros Communications, Inc.
Bus 001 Device 002: ID 093a:2700 Pixart Imaging, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译