无线已联接,但不能上网?

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
头像
anway
帖子: 398
注册时间: 2007-07-22 12:13
送出感谢: 1 次
接收感谢: 0

无线已联接,但不能上网?

#1

帖子 anway » 2011-01-10 20:35

Asus F8Tr,Atheros 5007EG无线网卡,安装的是ubuntu10.10的改装版Linux Deepin10.12,上网环境是单位的无线上网(自己拉了根网线接无线路由器)。进行系统后能正确识别该无线信号并显示已连接。可不能打开上网。(相同环境下windows是可以上网的)。
终端运行iwconfig,ifconfig,lspci|grep "wireless"结果如图。
请高手分析一下原因,如何解决?
附件
终端_002.png
卿舞飞扬
帖子: 32
注册时间: 2011-01-07 11:11
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#2

帖子 卿舞飞扬 » 2011-01-10 21:51

跟我的问题一样。我也在找这问题的答案。今天我又分析了一下,在终端里用IWCONFIG命令能够看到WLAN0但是network Manager里面却没有显示无线连接,所以我怀疑是NETWORK Manager的问题。。。求高手解答。。
头像
anway
帖子: 398
注册时间: 2007-07-22 12:13
送出感谢: 1 次
接收感谢: 0

Re: 无线已联接,但不能上网?

#3

帖子 anway » 2011-01-10 22:06

我在网络管理里倒是可以看到无线网络的名称。可无论怎么设置这个网络属性,都不能上网!

前几天在论坛看到一哥们的帖子,也许这是解决之道。
viewtopic.php?f=116&t=270103

可我在编译是报错。头大!
卿舞飞扬
帖子: 32
注册时间: 2011-01-07 11:11
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#4

帖子 卿舞飞扬 » 2011-01-10 22:32

他说的是10.4版本的,你照做不错菜怪。。。,我也还在找LZ在咱两同是天涯沦落人啊。。。
头像
anway
帖子: 398
注册时间: 2007-07-22 12:13
送出感谢: 1 次
接收感谢: 0

Re: 无线已联接,但不能上网?

#5

帖子 anway » 2011-01-11 8:30

但我在安装10.04时什么也没做就是好的啊!
记得我用的是wicd网络管理。
wangwwzj
帖子: 34
注册时间: 2010-11-16 1:41
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#6

帖子 wangwwzj » 2011-01-11 9:38

帮顶,我有时候也要用无线的。
头像
vicar213
帖子: 7
注册时间: 2007-08-15 13:41
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#7

帖子 vicar213 » 2011-01-11 9:55

不能上网是什么个情况?
是不能PING到网站地址呢?
还是打不开网页?如果是后者的话,建议你看看FIREFOX的脱机工作关了没,,,,我记得我就是有一次因为这个老以为是联网的问题。。。。(新手的时候) :em03
lqql123
帖子: 1
注册时间: 2011-01-11 10:07
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#8

帖子 lqql123 » 2011-01-11 10:22

高手还没出声,还是没出生啊?
卿舞飞扬
帖子: 32
注册时间: 2011-01-07 11:11
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#9

帖子 卿舞飞扬 » 2011-01-11 12:14

我就是怀疑是network Manager的问题。。你换wicd试试啊。。可以的话我也换。。
卿舞飞扬
帖子: 32
注册时间: 2011-01-07 11:11
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#10

帖子 卿舞飞扬 » 2011-01-11 23:46

elephant_what
帖子: 60
注册时间: 2006-04-25 7:08
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#11

帖子 elephant_what » 2011-01-12 9:34

应该是设一下DNS就行。一般通过无线路由都会出现这个问题。设好本机的DNS一切都会好的。
头像
anway
帖子: 398
注册时间: 2007-07-22 12:13
送出感谢: 1 次
接收感谢: 0

Re: 无线已联接,但不能上网?

#12

帖子 anway » 2011-01-12 10:00

DNS设置过了,没用的。
头像
黄美姬
论坛版主
帖子: 8428
注册时间: 2009-10-08 11:15
来自: 大城市铁岭
送出感谢: 0
接收感谢: 1 次

Re: 无线已联接,但不能上网?

#13

帖子 黄美姬 » 2011-01-12 10:32

掩码错,
我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal- ... ts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal- ... tx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 无线已联接,但不能上网?

#14

帖子 eexpress » 2011-01-12 10:46

http_proxy设置过?清空吧。

ping内网机器没问题吧。那就剩下路由的许可和dns了啊。

nslookup www.xxx.com看下 dns的实际解析地址。
● 鸣学
卿舞飞扬
帖子: 32
注册时间: 2011-01-07 11:11
送出感谢: 0
接收感谢: 0

Re: 无线已联接,但不能上网?

#15

帖子 卿舞飞扬 » 2011-01-12 11:59

问题依然没解决,显示连接上了。但不能访问网络。ping路由器都ping不通。。。
回复

回到 “网卡问题以及网络和拨号”