当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 菜鸟问题:局域网,XP联网正常,ubuntu找不到连接,求助
帖子发表于 : 2011-04-01 17:09 

注册: 2011-03-31 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
DELL380计算机,原装有XP PROFESSIONAL,上网正常,单位局域网,须通过HTTP代理上互联网,网卡设置 IP, 子网掩码、网关、dns,即可连通局域网。
现安装ubuntu 9.04(随机附送盘),可以双系统,但在xp时联网正常,在无版图不能连接局域网,桌面右上角网络连接图标红叉。
网络连接图标右键设置:
1 添加有线连接1
2 mac 填写的是xp中用ipconfig -all 命令查找到的物理地址
3 设置 IP, 子网掩码、网关,dns,所有用户可用等。
4 路由空白(不知道,xp中不用设置)

重新启动,可还是红叉

浏览了近期论坛:
在终端下:
1 sudo gedit /etc/network/interfaces
查看文件,只有两项内容:auto l0

iface l0 inet loopback

2 ifconfig -a
显示:
l0 inet 127.0.0.1 255.0.0.0 ..........mtu:16436........
pan0 link encap: 以太网 MAC 5a:24:41:cc:e9:54(此地址是变动的,重启后不同,)
.........................................mtu:1500...

初次接触无版图,请高手们给与帮助,多谢,再谢。


最后由 wxzss 编辑于 2011-04-04 8:59,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 菜鸟问题:局域网,XP联网正常,无版图ubuntu找不到连接,求助
帖子发表于 : 2011-04-02 16:07 

注册: 2011-03-31 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
网上查,有用手工设置的,我试着修改interfaces:

sudo gedit /etc/network/interfaces
原来只有:
auth l0
iface l0 inet loopback

我增加分配的静态ip:

auto pan0
iface pan0 inet static
address 10.**.**.**
netmask 255.255.255.0
gateway 10.**.***.***

保存再设dns:
sudo gedit /etc/resolv.conf
原是空的,增加:
nameserver 10.aa.bb.cc
保存

重启动ubuntu
sudo reboot

结果还是上不了网,网络连接红叉,
再求帮助。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 菜鸟问题:局域网,XP联网正常,无版图ubuntu找不到连接,求助
帖子发表于 : 2011-04-02 18:39 

注册: 2011-03-31 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
在改写interfaces文件时,第一次网卡选的是
auto eth0
iface eth0 inet static
但重启后,提示没有eth0
只好改回pan0
但依然没有解决问题,
这时 ping自己的ip可以,其它不通。

补充一下,机器网卡是 broandcom


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 菜鸟问题:局域网,XP联网正常,无版图ubuntu找不到连接,求助
帖子发表于 : 2011-04-03 8:54 

注册: 2011-03-31 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
高手到哪去了?没有人路过这里


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 菜鸟问题:局域网,XP联网正常,ubuntu找不到连接,求助
帖子发表于 : 2011-04-05 16:34 

注册: 2011-03-31 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
搜索域应该如何设置?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 菜鸟问题:局域网,XP联网正常,ubuntu找不到连接,求助
帖子发表于 : 2011-04-12 15:28 

注册: 2011-04-12 8:16
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
同样的问题 找到了这里 哎。。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 菜鸟问题:局域网,XP联网正常,ubuntu找不到连接,求助
帖子发表于 : 2011-04-21 20:24 

注册: 2011-03-31 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
对ubuntu很失望,
希望11.04能好些
到时再试验


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 菜鸟问题:局域网,XP联网正常,ubuntu找不到连接,求助
帖子发表于 : 2011-05-03 16:16 

注册: 2011-03-31 18:34
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
下载了一个 ubuntu10.10中国版 ,kanas
支持 broadcom网卡,很顺利 安装 成功,上网成功,现在就在新版本下 。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译