当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-05-07 11:05 

注册: 2008-04-19 12:50
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
大家好!
小弟用ubuntu12.04 发现无线网络经常断网,无线网卡是realtek8188ce,
大概在开机不到一分钟之内就断网,此时无线连接显示是正常的
但是输入路由器地址192.168.1.1无法连接路由器,无法打开任何网页
多数情况下只能够断开无线网络重新连接,可是依旧是1分钟左右断网
偶尔能够自动恢复,但是不够稳定,同样是1分钟左右断网
在win7,win8下都是正常的
一开始以为是路由器问题,把老的54M tplink换成cisco的还是不行
在坛子里面搜索了很多类似症状的帖子,
试过的方法包括
1. sudo gedit /etc/NetworkManager/NetworkManager.conf
最后一行true(我的本来就是true)
2.sudo gedit /etc/ppp/options
我的电脑根本没有options这个文件,可能因为我不是拨号上网?
3.修改/etc/NetworkMnaager/system-connections/下的对应的网络连接的
lcp-echo-failure和lcp-echo-interval的值,同样我不是拨号上网所以改不了
我的连接名“Flamelink”,我把文件内容贴出来,不过我不知道怎么改
如果知道的,请告诉我,谢谢
代码:
[connection]
id=FlameLink
uuid=06282d68-92bd-40bc-806b-7a7026c7a1f1
type=802-11-wireless
timestamp=1362649610

[802-11-wireless]
ssid=FlameLink
mode=infrastructure
mac-address=74:DE:2B:0D:17:B3
security=802-11-wireless-security

[802-11-wireless-security]
key-mgmt=wpa-psk
psk=#¥%@……&*#%

[ipv4]
method=auto

[ipv6]
method=auto

怀疑是无线网卡驱动问题,所以下载过官方驱动,但是安装后问题依旧
驱动地址:http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#RTL8188CE

补充一下:我在距离路由器相当近的地方断网情况会好转,大概几十分钟的样子会断一次,而且大都能够恢复,(无线信号3-4格,4格是满格)
我说的一分钟断网是隔了10米左右的距离时出现的情况(无线信号2-4格),其它距离我还没有测试过,
因为我主要在客厅和卧室使用电脑

在win8下10米左右距离无线信号3-5格,5格是满格


最后由 draic 编辑于 2013-05-07 14:49,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-05-07 11:46 

注册: 2012-11-13 10:35
帖子: 14
系统: Ubuntu 12.04
送出感谢: 0 次
接收感谢: 0 次
那肯定是你无线驱动的问题


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-05-07 13:17 
头像

注册: 2010-07-15 13:31
帖子: 1401
送出感谢: 77
接收感谢: 23
楼主哪来的无线驱动?那都是系统自带的。
这个问题不止一个人提及,10.x没有,应该是个bug。


_________________
Ubuntu 命令技巧: http://wiki.ubuntu.org.cn/index.php?title=UbuntuSkills&variant=zh-cn
Ubuntu 桌面指南: https://help.ubuntu.com//


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-05-07 14:37 

注册: 2008-04-19 12:50
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
wikeryong 写道:
那肯定是你无线驱动的问题

我下的驱动
http://www.realtek.com.tw/downloads/dow ... #RTL8188CE


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-05-07 14:38 

注册: 2008-04-19 12:50
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
tang.zhe 写道:
楼主哪来的无线驱动?那都是系统自带的。
这个问题不止一个人提及,10.x没有,应该是个bug。

我下载的驱动
http://www.realtek.com.tw/downloads/dow ... #RTL8188CE


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-05-07 16:26 
头像

注册: 2012-06-09 15:50
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
很奇怪,我也是rtl8188ce,不过我直接编译了内核里自带的驱动代码。用wicd没有你这样的问题。你还是用13.04吧

Sent from my Lenovo A288t using Tapatalk 2


_________________
I abhor a system designed for the “user”, if that word is a coded pejorative meaning “stupid and unsophisticated”.


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-05-07 20:38 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
只记得ipv6启动了,比如mierdo这些,某些isp会定期断你的。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-05-09 16:13 

注册: 2008-04-19 12:50
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
blackheath 写道:
很奇怪,我也是rtl8188ce,不过我直接编译了内核里自带的驱动代码。用wicd没有你这样的问题。你还是用13.04吧

Sent from my Lenovo A288t using Tapatalk 2

折腾了两天了,先是尝试升级12.04-12.10-13.04,失败了
后来直接安装13.04,还是断网,最后换了debian 7 还是断网
看来儿子和妈都一个样啊


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-08-28 22:01 

注册: 2008-11-03 16:06
帖子: 18
送出感谢: 0 次
接收感谢: 2
晕,我的ThinkPad W520 装的Centos 6.4 驱动也跟你的一样,也是这个问题,烦恼死了,你现在解决这个问题了吗?


_________________
我的个人博客


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 请教12.04无线网络1分钟断网问题
帖子发表于 : 2013-09-07 22:03 

注册: 2013-09-07 21:58
帖子: 8
系统: win8.1
送出感谢: 0 次
接收感谢: 0 次
哎 我的也是realtek8188ce的无线网卡
不管是12.04还是13.04都有这个很蛋疼的问题 极度无语中


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译