当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : pptp VPN不能使用
帖子发表于 : 2018-02-02 21:08 

注册: 2018-02-02 21:04
帖子: 3
系统: ubuntu 18.04 LTS
送出感谢: 0 次
接收感谢: 0 次
刚刚从16.04LTS更新到18.04LTS,使用新的gnome桌面,其他一切正常,就是之前可以连接到学校的VPN不能连接了。现在表现为点击connect,面板上VPN图标一闪而过,然后没有连接上。这种闪退问题以前在unity上没见过,请问是软件包的冲突吗,需要怎么操作。另外,很想知道怎么查看networkmanager的日志,在哪个文件夹?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: pptp VPN不能使用
帖子发表于 : 2018-02-02 21:41 

注册: 2018-02-02 21:04
帖子: 3
系统: ubuntu 18.04 LTS
送出感谢: 0 次
接收感谢: 0 次
补充一点附加信息,希望能帮忙定位我的问题。
Feb 2 21:39:47 V3-572G-59TB NetworkManager[1047]: <info> [1517578787.7578] audit: op="connection-activate" uuid="7602779a-d507-4e79-b4eb-a4da2e97d4db" name="VPN 1" pid=2183 uid=1000 result="success"
Feb 2 21:39:47 V3-572G-59TB NetworkManager[1047]: <info> [1517578787.7656] vpn-connection[0x563cf78446b0,7602779a-d507-4e79-b4eb-a4da2e97d4db,"VPN 1",0]: Started the VPN service, PID 4039
Feb 2 21:39:47 V3-572G-59TB NetworkManager[1047]: <info> [1517578787.7742] vpn-connection[0x563cf78446b0,7602779a-d507-4e79-b4eb-a4da2e97d4db,"VPN 1",0]: Saw the service appear; activating connection
Feb 2 21:39:47 V3-572G-59TB gnome-shell[2183]: Invalid VPN service type (cannot find authentication binary)
Feb 2 21:39:47 V3-572G-59TB gnome-shell[2183]: Invalid VPN service type (cannot find authentication binary)
Feb 2 21:39:47 V3-572G-59TB NetworkManager[1047]: <error> [1517578787.8182] vpn-connection[0x563cf78446b0,7602779a-d507-4e79-b4eb-a4da2e97d4db,"VPN 1",0]: Failed to request VPN secrets #3: No agents were available for this request.
Feb 2 21:39:47 V3-572G-59TB NetworkManager[1047]: <info> [1517578787.8262] vpn-connection[0x563cf78446b0,7602779a-d507-4e79-b4eb-a4da2e97d4db,"VPN 1",0]: VPN service disappeared
这是系统日志。
另外,若是在命令行打开nm-applet时,这个VPN就可以连接。
感谢帮忙!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: pptp VPN不能使用
帖子发表于 : 2018-02-02 21:51 

注册: 2009-08-04 16:33
帖子: 17909
送出感谢: 21
接收感谢: 1924
引用:
之前可以连接到学校的VPN不能连接了

https://www.reddit.com/r/PUBATTLEGROUND ... _starting/
China to block off all VPN access starting February 2018
自 2018/02 開始 將阻擋所有 VPN


页首
 用户资料  
 
4 楼 
 文章标题 : Re: pptp VPN不能使用
帖子发表于 : 2018-02-02 21:56 

注册: 2018-02-02 21:04
帖子: 3
系统: ubuntu 18.04 LTS
送出感谢: 0 次
接收感谢: 0 次
https://www.reddit.com/r/PUBATTLEGROUND ... _starting/
我连接的是中国大陆自己学校的VPN,和屏蔽没有关系,况且在终端执行nm-applet后,我的VPN可以连接。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: pptp VPN不能使用
帖子发表于 : 2018-02-03 13:14 

注册: 2009-08-04 16:33
帖子: 17909
送出感谢: 21
接收感谢: 1924
引用:
况且在终端执行nm-applet后,我的VPN可以连接。

點擊右上方連線圖示 看看 有沒有 vpn 設定
另外 可能需要先安裝 (如果還沒安裝的話)
套件: network-manager-vpnc-gnome
https://packages.ubuntu.com/artful/netw ... vpnc-gnome

也可以試試 安裝
套件: network-manager-strongswan
https://packages.ubuntu.com/artful/netw ... strongswan

詳細參閱
https://help.ubuntu.com/community/Netwo ... PN_support
VPN support


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译