当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]各位,我的wine起不来,都块2点了,还弄不好。。
帖子发表于 : 2008-02-16 1:57 
头像

注册: 2008-01-24 18:17
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
我在网上看到帖子,按照他的方法去安装WINE(以前我用ubuntu中的 安装/卸载装过,但不会用然后删除了,这次想手动安装)

他的步骤是:
引用:
1、在Ubuntu 7.10终端执行:
sudo apt-get install gcc libc6-dev fakeroot libglib1.2-dev libglib2.0-dev libltdl3-dev libmad0-dev libmng-dev libodbcinstq1c2 libogg-dev libpng12-dev libqt3-headers libqt3-mt-dev libvorbis-dev libxft-dev libxi-dev libxinerama-dev libxmu-dev libxmu-headers libxmuu-dev libxpm-dev libxtrap-dev libxtst-dev libxv-dev libxxf86dga-dev qt3-dev-tools render-dev unixodbc-dev x-dev x11proto-record-dev x11proto-trap-dev x11proto-video-dev x11proto-xf86dga-dev xlibs-dev fontforge flex bison libxext6

在搭建环境的过程中要求插入Ubuntu 7.10光盘。(注意:有可能提示xlibs-dev 包不存在,请换源或者将xlibs-dev换成xlibs-static-dev)

2、在http://www.winehq.org/?announce=latest 最上面两个地址下载wine 我下的是0.9.52版

解压wine:

cd ~

tar xjvf wine-0.9.52.tar.bz2(下载的wine压缩包)

cd wine-0.9.52/

sudo ./configure (检查wine编译环境包依赖是否通过,如果提示缺少“xxx package”,请执行“sudo apt-get install xxx”)

3、编译环境检测完毕后会提示运行“make depend && make" 只要执行就OK了

sudo make depend && make

然后就是耐心等待!嘎嘎!!

编译完成后会提示“wine build complete”,这时输入“sudo make install”就大功告成了


我在第二步最后执行 sudo./configure时候出现了以下情况

引用:
configure: libxcursor development files not found, the Xcursor extension won't be supported.
configure: libxi development files not found, the Xinput extension won't be supported.
configure: XShm development files not found, X Shared Memory won't be supported.
configure: XShape development files not found, XShape won't be supported.
configure: libxxf86vm development files not found, XFree86 Vidmode won't be supported.
configure: libxrender development files not found, XRender won't be supported.
configure: libxrandr development files not found, XRandr won't be supported.
configure: libxinerama development files not found, multi-monitor setups won't be supported.
configure: libxcomposite development files not found, Xcomposite won't be supported.
configure: libxml2 development files not found, XML won't be supported.
configure: libxslt development files not found, xslt won't be supported.
configure: libhal development files not found, no dynamic device support.
configure: lib(n)curses development files not found, curses won't be supported.
configure: libsane development files not found, scanners won't be supported.
configure: libgphoto2 development files not found, digital cameras won't be supported.
configure: liblcms development files not found, Color Management won't be supported.
configure: libldap (OpenLDAP) development files not found, LDAP won't be supported.
configure: libcapi20 development files not found, ISDN won't be supported.
configure: libcups development files not found, CUPS won't be supported.
configure: fontconfig development files not found, fontconfig won't be supported.
configure: OpenSSL development files not found, SSL won't be supported.
configure: libjpeg development files not found, JPEG won't be supported.
configure: libpng development files not found, PNG won't be supported.

configure: WARNING: OpenGL development headers not found.
OpenGL and Direct3D won't be supported.

configure: WARNING: FontForge is missing.
Fonts will not be built. Dialog text may be invisible or unaligned.

configure: Finished. Do 'make depend && make' to compile Wine.



但我还是按照他的步骤做了:sudo make depend && make

然后出现N多错误。。哎~~疯掉了疯掉了

各位帮我看下吧,我撑不住了。。。~~~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-16 9:26 

注册: 2006-12-14 3:00
帖子: 614
送出感谢: 0 次
接收感谢: 0 次
自己编译干嘛...


_________________
提问的智慧


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-16 10:27 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
sudo aptitude install wine


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-02-16 12:32 
头像

注册: 2008-01-24 18:17
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
但是如果就这样安装会不会缺少里面的环境?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-02-16 12:35 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
apt安装的好处就是自动把包补齐。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-02-16 12:38 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
今天我水瓶 写道:
但是如果就这样安装会不会缺少里面的环境?

安装包管理器会自动解决,
而且编译时需要的软件库大多数编译后就不需要了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-02-16 12:49 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
wine别编译了,还要opengl的支持库的。巨多的库。
折腾。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-02-16 12:54 
头像

注册: 2008-01-24 18:17
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
请问大家,我在wine主页上看到最新版本的是9 55的,但是我系统自己下载的话是9 4x(哪个版本我也记不请了)

是不是要更新wine的源阿,请问该如何设置阿


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-02-16 13:23 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
代码:
sudo gedit /etc/apt/sources.list

添加
deb http://wine.budgetdedicated.com/apt gutsy main #WineHQ - Ubuntu 7.10 "Gutsy Gibbon"
deb-src http://wine.budgetdedicated.com/apt gutsy main #WineHQ - Ubuntu 7.10 "Gutsy Gibbon"
保存
sudo apt-get update
sudo apt-get install wine


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-02-16 13:39 
头像

注册: 2008-01-24 18:17
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上的各位~~


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-02-16 14:22 

注册: 2007-08-10 22:30
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
呵呵,才两点嘛……我经常两点多才睡觉的~不过早上要睡到10点多……赫赫


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-06-02 16:41 
头像

注册: 2008-05-31 17:39
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
直接apt-get install 就是速度太慢呀~~就一直10KB~~哎~


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-06-02 20:41 

注册: 2006-12-05 0:23
帖子: 134
系统: Windows® 7
送出感谢: 0 次
接收感谢: 0 次
Yenom 写道:
直接apt-get install 就是速度太慢呀~~就一直10KB~~哎~


我新疆网通,不知道为啥速度从来没下过150KB/s…… :oops:


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译